Cannot edit or delete created tracker Program inside the Maintenance app. The Tracker Capture app also gets stuck saying "Loading metadata"

I am using version 2.40. I cannot edit or delete an existing tracker Program and its associated tracked entity attributes. The page gets stuck and I just see a blank page. And when I go to the Tracker Capture app it gets stuck saying “loading metadata”. I cleared the browser cache and restarted the server multiple times and the issue still persists. I even restarted my computer and even that doesn’t solve the issue. I cannot even access the previously entered tracker data. Please help.

Hi @therealrajan ,

Deleting a tracker program is not pretty straightforward. You may first have to delete all linked data. Even before we get there, the image you shared kind of suggest that the cache clearing possibly was not successful.

To test if the page is really getting stuck, and not a cache issue, try opening the page in a fresh window / incognito window, now clear the cache in the incognito window, and try accessing the page.

I cleared the cache and it didn’t show me any errors so I assumed it cleared properly . I also cleared the site data through the browser. And I even opened DHIS2 in incognito mode and even on another browser Firefox. It’s the same thing in al browsers unfortunately. I dont know whats happening. Maybe it’s an encoding issue causing the Bad Request error? Maybe the API url is incorrect? How do i fix that?

I cant even delete the tracked entity attributes or he tracked entity type because they are linked causing a paradox and I cant delete either one. And I cannot delete the program because its linked to the attributes and entity type. And the Tracker Capture app gets stuck loading metadata. I tried clearing cache and restarted the server multiple times with no solution. What else can I do?


If its about deleting a tracker program here are steps to follow:

  1. First delete all tracked entity instances associated to the program (In your case, where you cannot access TEIs from the UI, you may want to send a delete API request to the server. I’m sure this won’t fail)
  2. You cannot delete tracked entity attributes that are assigned to a program.
    In the ‘Attribute’ section of your tracker program, unassign all the tracked entity attributes from the program and also remove all data elements possibly assigned in the program stages.
  3. Once you have unassigned the tracked entity attributes, you should be able to delete these tracked entity attributes or the tracker program because it will not be linked to other stuff.
  4. Then when the tracker program is deleted, you can subsequently delete the tracked entity type.

In this fashion you’ll be able to completely remove a tracker program. I hope this helps

My main issue is that I want to create a tracker program that I can use to collect tracker data and be able to edit the program to update it. But when I create a program I cannot access it through the Tracker Capture app and it keeps getting stuck showing “Loading metadata”. And when I try to edit a program it just freezes and see the blank page like I showed above.

I cleared the cache, restarted the browser, tried in incognito mode, tried another browser, restarted server and nothing helped. I can’t find anything to solve this in the official documentation or the community forum. Now I don’t know what to do.


Can you share your server logs here. It may have some info why you’re experiencing these. You may want to leave out any sensitive/security info if there is.


Here are the latest logs. Hopefully, these are the ones you’re asking for.

  2. catalina.2024-06-18.log -
  3. localhost.2024-06-18.log -