[Bug] DataSet Section - allows the same data elements to be assigned to multiple sections

Hi,

We are working on DHIS version 2.24 (revision - 23565). We created a data set with two data elements and tried to create two data set sections with one data element in each. But, even after a data element is assigned to one section, the same data element is still available for assigning to another section as well. The data entry form also reflects the same behaviour of showing the same data element in multiple sections of a single data set. Is this a known bug?

Here are some screenshots depicting the issue.

"Section1" is the first data set section and saved with “element1”

Trying to create a new section and we see that “element1” also appears for assigning to another section

Data Entry form shows “element1” in “section1” and “section2” (we added both element1 and element2 to section2). This will cause repercussions in data.

Please help fix this.

Cheers,

···

Archana Chillala
Application Developer
Email
archanac@thoughtworks.com
Telephone
+91 9100960533
ThoughtWorks

Just to add to the above mail - This issue is only with the new Data Set module in Maintenance app. But the older data Set app, works fine as expected.

···

On Wed, Aug 17, 2016 at 11:46 AM, Archana Chillala archanac@thoughtworks.com wrote:

Hi,

We are working on DHIS version 2.24 (revision - 23565). We created a data set with two data elements and tried to create two data set sections with one data element in each. But, even after a data element is assigned to one section, the same data element is still available for assigning to another section as well. The data entry form also reflects the same behaviour of showing the same data element in multiple sections of a single data set. Is this a known bug?

Here are some screenshots depicting the issue.

"Section1" is the first data set section and saved with “element1”

Trying to create a new section and we see that “element1” also appears for assigning to another section

Data Entry form shows “element1” in “section1” and “section2” (we added both element1 and element2 to section2). This will cause repercussions in data.

Please help fix this.

Cheers,

Archana Chillala
Application Developer
Email
archanac@thoughtworks.com
Telephone
+91 9100960533
ThoughtWorks

Archana Chillala
Application Developer
Email
archanac@thoughtworks.com
Telephone
+91 9100960533
ThoughtWorks

Hi Archana,

thanks for reporting, we’ll get it fixed.

I created a github issue for the bug, here:

https://github.com/dhis2/maintenance-app/issues/217

Best regards,

···

On Wed, Aug 17, 2016 at 8:21 AM, Archana Chillala archanac@thoughtworks.com wrote:

Just to add to the above mail - This issue is only with the new Data Set module in Maintenance app. But the older data Set app, works fine as expected.


Mailing list: https://launchpad.net/~dhis2-devs

Post to : dhis2-devs@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-devs

More help : https://help.launchpad.net/ListHelp

Nicolay Ramm

Front end developer, DHIS 2

University of Oslo

https://www.dhis2.org

Archana Chillala
Application Developer
Email
archanac@thoughtworks.com
Telephone
+91 9100960533
ThoughtWorks

On Wed, Aug 17, 2016 at 11:46 AM, Archana Chillala archanac@thoughtworks.com wrote:

Hi,

We are working on DHIS version 2.24 (revision - 23565). We created a data set with two data elements and tried to create two data set sections with one data element in each. But, even after a data element is assigned to one section, the same data element is still available for assigning to another section as well. The data entry form also reflects the same behaviour of showing the same data element in multiple sections of a single data set. Is this a known bug?

Here are some screenshots depicting the issue.

"Section1" is the first data set section and saved with “element1”

Trying to create a new section and we see that “element1” also appears for assigning to another section

Data Entry form shows “element1” in “section1” and “section2” (we added both element1 and element2 to section2). This will cause repercussions in data.

Please help fix this.

Cheers,

Archana Chillala
Application Developer
Email
archanac@thoughtworks.com
Telephone
+91 9100960533
ThoughtWorks

Thanks, Nicolay.

···

On Wed, Aug 17, 2016 at 2:56 PM, Nicolay Ramm nicolay@dhis2.org wrote:

Hi Archana,

thanks for reporting, we’ll get it fixed.

I created a github issue for the bug, here:

https://github.com/dhis2/maintenance-app/issues/217

Best regards,

Archana Chillala
Application Developer
Email
archanac@thoughtworks.com
Telephone
+91 9100960533
ThoughtWorks

Nicolay Ramm

Front end developer, DHIS 2

University of Oslo

https://www.dhis2.org

On Wed, Aug 17, 2016 at 8:21 AM, Archana Chillala archanac@thoughtworks.com wrote:

Just to add to the above mail - This issue is only with the new Data Set module in Maintenance app. But the older data Set app, works fine as expected.


Mailing list: https://launchpad.net/~dhis2-devs

Post to : dhis2-devs@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-devs

More help : https://help.launchpad.net/ListHelp

Archana Chillala
Application Developer
Email
archanac@thoughtworks.com
Telephone
+91 9100960533
ThoughtWorks

On Wed, Aug 17, 2016 at 11:46 AM, Archana Chillala archanac@thoughtworks.com wrote:

Hi,

We are working on DHIS version 2.24 (revision - 23565). We created a data set with two data elements and tried to create two data set sections with one data element in each. But, even after a data element is assigned to one section, the same data element is still available for assigning to another section as well. The data entry form also reflects the same behaviour of showing the same data element in multiple sections of a single data set. Is this a known bug?

Here are some screenshots depicting the issue.

"Section1" is the first data set section and saved with “element1”

Trying to create a new section and we see that “element1” also appears for assigning to another section

Data Entry form shows “element1” in “section1” and “section2” (we added both element1 and element2 to section2). This will cause repercussions in data.

Please help fix this.

Cheers,

Archana Chillala
Application Developer
Email
archanac@thoughtworks.com
Telephone
+91 9100960533
ThoughtWorks

Hi Nicolay,

The issue is still there on 2.25. We tested on play server too. Could you please provide any update on this?

···

On Fri, Aug 19, 2016 at 3:47 PM, Archana Chillala archanac@thoughtworks.com wrote:

Thanks, Nicolay.

Archana Chillala
Application Developer
Email
archanac@thoughtworks.com
Telephone
+91 9100960533
ThoughtWorks

Archana Chillala
Application Developer
Email
archanac@thoughtworks.com
Telephone
+91 9100960533
ThoughtWorks

On Wed, Aug 17, 2016 at 2:56 PM, Nicolay Ramm nicolay@dhis2.org wrote:

Hi Archana,

thanks for reporting, we’ll get it fixed.

I created a github issue for the bug, here:

https://github.com/dhis2/maintenance-app/issues/217

Best regards,

Nicolay Ramm

Front end developer, DHIS 2

University of Oslo

https://www.dhis2.org

On Wed, Aug 17, 2016 at 8:21 AM, Archana Chillala archanac@thoughtworks.com wrote:

Just to add to the above mail - This issue is only with the new Data Set module in Maintenance app. But the older data Set app, works fine as expected.


Mailing list: https://launchpad.net/~dhis2-devs

Post to : dhis2-devs@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-devs

More help : https://help.launchpad.net/ListHelp

Archana Chillala
Application Developer
Email
archanac@thoughtworks.com
Telephone
+91 9100960533
ThoughtWorks

On Wed, Aug 17, 2016 at 11:46 AM, Archana Chillala archanac@thoughtworks.com wrote:

Hi,

We are working on DHIS version 2.24 (revision - 23565). We created a data set with two data elements and tried to create two data set sections with one data element in each. But, even after a data element is assigned to one section, the same data element is still available for assigning to another section as well. The data entry form also reflects the same behaviour of showing the same data element in multiple sections of a single data set. Is this a known bug?

Here are some screenshots depicting the issue.

"Section1" is the first data set section and saved with “element1”

Trying to create a new section and we see that “element1” also appears for assigning to another section

Data Entry form shows “element1” in “section1” and “section2” (we added both element1 and element2 to section2). This will cause repercussions in data.

Please help fix this.

Cheers,

Archana Chillala
Application Developer
Email
archanac@thoughtworks.com
Telephone
+91 9100960533
ThoughtWorks

Hi Archana,

since this is an issue that can be worked around by the end user there are other issues that have to take precedence. But rest assured - we will get to it eventually.

Best regards,

···

On Wed, Oct 26, 2016 at 9:11 AM, Archana Chillala archanac@thoughtworks.com wrote:

Hi Nicolay,

The issue is still there on 2.25. We tested on play server too. Could you please provide any update on this?

Nicolay Ramm

Front end developer, DHIS 2

University of Oslo

https://www.dhis2.org

Archana Chillala
Application Developer
Email
archanac@thoughtworks.com
Telephone
+91 9100960533
ThoughtWorks

On Fri, Aug 19, 2016 at 3:47 PM, Archana Chillala archanac@thoughtworks.com wrote:

Thanks, Nicolay.

Archana Chillala
Application Developer
Email
archanac@thoughtworks.com
Telephone
+91 9100960533
ThoughtWorks

On Wed, Aug 17, 2016 at 2:56 PM, Nicolay Ramm nicolay@dhis2.org wrote:

Hi Archana,

thanks for reporting, we’ll get it fixed.

I created a github issue for the bug, here:

https://github.com/dhis2/maintenance-app/issues/217

Best regards,

Nicolay Ramm

Front end developer, DHIS 2

University of Oslo

https://www.dhis2.org

On Wed, Aug 17, 2016 at 8:21 AM, Archana Chillala archanac@thoughtworks.com wrote:

Just to add to the above mail - This issue is only with the new Data Set module in Maintenance app. But the older data Set app, works fine as expected.


Mailing list: https://launchpad.net/~dhis2-devs

Post to : dhis2-devs@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-devs

More help : https://help.launchpad.net/ListHelp

Archana Chillala
Application Developer
Email
archanac@thoughtworks.com
Telephone
+91 9100960533
ThoughtWorks

On Wed, Aug 17, 2016 at 11:46 AM, Archana Chillala archanac@thoughtworks.com wrote:

Hi,

We are working on DHIS version 2.24 (revision - 23565). We created a data set with two data elements and tried to create two data set sections with one data element in each. But, even after a data element is assigned to one section, the same data element is still available for assigning to another section as well. The data entry form also reflects the same behaviour of showing the same data element in multiple sections of a single data set. Is this a known bug?

Here are some screenshots depicting the issue.

"Section1" is the first data set section and saved with “element1”

Trying to create a new section and we see that “element1” also appears for assigning to another section

Data Entry form shows “element1” in “section1” and “section2” (we added both element1 and element2 to section2). This will cause repercussions in data.

Please help fix this.

Cheers,

Archana Chillala
Application Developer
Email
archanac@thoughtworks.com
Telephone
+91 9100960533
ThoughtWorks