[Bug 1574953] [NEW] Can't create Data Element

Public bug reported:

I can't create Data Element. When I'm creating data elements, every time I choose Domain Type/Value Type/Aggregate Type it doesn't respond to anything on the data element editor. Also, my orgunit doesn't show up on Organization Levels section, it keep showing symbol of loading page.
I try to import Data Element from .csv file, it succeed but I can't edit it because of the problem I mentioned above.

I'm using DHIS2 live version 2.23 (the one available on DHIS2 web)
Google Chrome Version 50.0.2661.87
Windows 7

Is this a bug or am I missing steps to create Data Element? Any solution to this?
Thank you very much.

** Affects: dhis2
     Importance: Undecided
         Status: New

···

--
You received this bug notification because you are a member of DHIS 2
developers, which is subscribed to DHIS.
https://bugs.launchpad.net/bugs/1574953

Title:
  Can't create Data Element

Status in DHIS:
  New

Bug description:
  I can't create Data Element. When I'm creating data elements, every time I choose Domain Type/Value Type/Aggregate Type it doesn't respond to anything on the data element editor. Also, my orgunit doesn't show up on Organization Levels section, it keep showing symbol of loading page.
  I try to import Data Element from .csv file, it succeed but I can't edit it because of the problem I mentioned above.

  I'm using DHIS2 live version 2.23 (the one available on DHIS2 web)
  Google Chrome Version 50.0.2661.87
  Windows 7

  Is this a bug or am I missing steps to create Data Element? Any solution to this?
  Thank you very much.

To manage notifications about this bug go to:
https://bugs.launchpad.net/dhis2/+bug/1574953/+subscriptions

It might be a bug but we would need some more information to reproduce
what you're experiencing.

Is it possible for you to provide us the data element you tried to
import/add?

Also perhaps you could open dev-tools [1] and show us the console tab.

[1] https://developers.google.com/web/tools/chrome-devtools/

Regards,

Mark

** Changed in: dhis2
       Status: New => Incomplete

** Changed in: dhis2
     Assignee: (unassigned) => Mark Polak (markpo)

···

--
You received this bug notification because you are a member of DHIS 2
developers, which is subscribed to DHIS.
https://bugs.launchpad.net/bugs/1574953

Title:
  Can't create Data Element

Status in DHIS:
  Incomplete

Bug description:
  I can't create Data Element. When I'm creating data elements, every time I choose Domain Type/Value Type/Aggregate Type it doesn't respond to anything on the data element editor. Also, my orgunit doesn't show up on Organization Levels section, it keep showing symbol of loading page.
  I try to import Data Element from .csv file, it succeed but I can't edit it because of the problem I mentioned above.

  I'm using DHIS2 live version 2.23 (the one available on DHIS2 web)
  Google Chrome Version 50.0.2661.87
  Windows 7

  Is this a bug or am I missing steps to create Data Element? Any solution to this?
  Thank you very much.

To manage notifications about this bug go to:
https://bugs.launchpad.net/dhis2/+bug/1574953/+subscriptions

Hi Karina,

  1. Please send questions to our mailing list:

https://www.dhis2.org/contact

  1. Please always also test on the online demo:

https://play.dhis2.org/demo/

Regards,

Knut

···

On Tue, Apr 26, 2016 at 6:35 AM, Karina karinadnlstr@gmail.com wrote:

Public bug reported:

I can’t create Data Element. When I’m creating data elements, every time I choose Domain Type/Value Type/Aggregate Type it doesn’t respond to anything on the data element editor. Also, my orgunit doesn’t show up on Organization Levels section, it keep showing symbol of loading page.

I try to import Data Element from .csv file, it succeed but I can’t edit it because of the problem I mentioned above.

I’m using DHIS2 live version 2.23 (the one available on DHIS2 web)

Google Chrome Version 50.0.2661.87

Windows 7

Is this a bug or am I missing steps to create Data Element? Any solution to this?

Thank you very much.

** Affects: dhis2

 Importance: Undecided

     Status: New

You received this bug notification because you are a member of DHIS 2

developers, which is subscribed to DHIS.

https://bugs.launchpad.net/bugs/1574953

Title:

Can’t create Data Element

Status in DHIS:

New

Bug description:

I can’t create Data Element. When I’m creating data elements, every time I choose Domain Type/Value Type/Aggregate Type it doesn’t respond to anything on the data element editor. Also, my orgunit doesn’t show up on Organization Levels section, it keep showing symbol of loading page.

I try to import Data Element from .csv file, it succeed but I can’t edit it because of the problem I mentioned above.

I’m using DHIS2 live version 2.23 (the one available on DHIS2 web)

Google Chrome Version 50.0.2661.87

Windows 7

Is this a bug or am I missing steps to create Data Element? Any solution to this?

Thank you very much.

To manage notifications about this bug go to:

https://bugs.launchpad.net/dhis2/+bug/1574953/+subscriptions


Mailing list: https://launchpad.net/~dhis2-devs

Post to : dhis2-devs@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-devs

More help : https://help.launchpad.net/ListHelp

Knut Staring

Dept. of Informatics, University of Oslo

Norway: +4791880522

Skype: knutstar

http://dhis2.org

I suppose you are using Live with H2 database, not Postgres? You can check that under the User menu in the top right corner, under About DHIS2

···

On Tue, Apr 26, 2016 at 8:59 AM, Mark Polak mark@dhis2.org wrote:

It might be a bug but we would need some more information to reproduce

what you’re experiencing.

Is it possible for you to provide us the data element you tried to

import/add?

Also perhaps you could open dev-tools [1] and show us the console tab.

[1] https://developers.google.com/web/tools/chrome-devtools/

Regards,

Mark

** Changed in: dhis2

   Status: New => Incomplete

** Changed in: dhis2

 Assignee: (unassigned) => Mark Polak (markpo)

You received this bug notification because you are a member of DHIS 2

developers, which is subscribed to DHIS.

https://bugs.launchpad.net/bugs/1574953

Title:

Can’t create Data Element

Status in DHIS:

Incomplete

Bug description:

I can’t create Data Element. When I’m creating data elements, every time I choose Domain Type/Value Type/Aggregate Type it doesn’t respond to anything on the data element editor. Also, my orgunit doesn’t show up on Organization Levels section, it keep showing symbol of loading page.

I try to import Data Element from .csv file, it succeed but I can’t edit it because of the problem I mentioned above.

I’m using DHIS2 live version 2.23 (the one available on DHIS2 web)

Google Chrome Version 50.0.2661.87

Windows 7

Is this a bug or am I missing steps to create Data Element? Any solution to this?

Thank you very much.

To manage notifications about this bug go to:

https://bugs.launchpad.net/dhis2/+bug/1574953/+subscriptions


Mailing list: https://launchpad.net/~dhis2-devs

Post to : dhis2-devs@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-devs

More help : https://help.launchpad.net/ListHelp

Knut Staring

Dept. of Informatics, University of Oslo

Norway: +4791880522

Skype: knutstar

http://dhis2.org

All, thanks for the respond.

Knut: Yes, I'm using Live version with H2 database. This is what it looked on About DHIS2 (Sorry, I'm mistaken mentioning the DHIS2 earlier. I'm using v2.22, not v2.23)
Web API:
Browse it here
Current user:
admin
Version:
2.22
Build revision:
21760
Build date:
2016-01-15 21:32
User agent:
Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/50.0.2661.87 Safari/537.36
Server date:
2016-04-26 16:24
Last analytics table generation:
Time since last analytics table generation:
Last analytics table runtime:
Environment variable:
DHIS2_HOME
External configuration directory:
C:\Users\user\Downloads\dhis2-live-222\dhis-live\conf
Database type:
H2
Database name:
dhis2;AUTO_SERVER=TRUE;DB_CLOSE_ON_EXIT=FALSE
Database user:
sa
Java opts:
Java home:
C:\Program Files (x86)\Java\jre1.8.0_91
Java temporary directory:
C:\Users\user\AppData\Local\Temp\
Java version:
1.8.0_91
Java vendor:
Oracle Corporation
OS name:
Windows 7
OS architecture:
x86
OS version:
6.1
Server memory:
Mem Total in JVM: 247 Free in JVM: 24 Max Limit: 247
CPU cores:
8

Mark: Attached is the csv file I've imported. And this is what it shows in the Data Element editor console tab

jquery.min.js:4 GET http://10.8.8.73:8082/api/userSettings/keyUiLocale 404 (Not Found)
  k.cors.a.crossDomain.send @ jquery.min.js:4
  n.extend.ajax @ jquery.min.js:4
  (anonymous function) @ Api.js:130
  l.value @ Api.js:123
  l.value @ Api.js:73
  i @ d2.js:79
  s @ d2.js:109
jquery.min.js:4 GET http://10.8.8.73:8082/api/userSettings/keyCurrentStyle 409 (Conflict)
  k.cors.a.crossDomain.send @ jquery.min.js:4
  n.extend.ajax @ jquery.min.js:4
  (anonymous function) @ Api.js:130
  l.value @ Api.js:123
  l.value @ Api.js:73
  u.default.createClass.requestUserStyle @ HeaderBar.component.js:262
  u.default.createClass.getHeaderBarData @ HeaderBar.component.js:110
GroupEditor.component.js:155 Uncaught (in promise) TypeError: this.props.assignedItemStore.state.has is not a function(…)
  t.default.i.default.createClass.getIsValueAssigned @ GroupEditor.component.js:155
  (anonymous function) @ GroupEditor.component.js:168
  t.default.i.default.createClass.getAvailableItems @ GroupEditor.component.js:167
  t.default.i.default.createClass.getAvailableItemsFiltered @ GroupEditor.component.js:178
  t.default.i.default.createClass.render @ GroupEditor.component.js:323
  b._renderValidatedComponentWithoutOwnerOrContext @ ReactCompositeComponent.js:789
  b._renderValidatedComponent @ ReactCompositeComponent.js:816
  b._updateRenderedComponent @ ReactCompositeComponent.js:746
  b._performComponentUpdate @ ReactCompositeComponent.js:726
  b.updateComponent @ ReactCompositeComponent.js:642
  b.performUpdateIfNecessary @ ReactCompositeComponent.js:539
  i.performUpdateIfNecessary @ ReactReconciler.js:115
  a @ ReactUpdates.js:151
  o.perform @ Transaction.js:134
  o.perform @ Transaction.js:134
  m.perform @ ReactUpdates.js:95
  S @ ReactUpdates.js:175
  o.closeAll @ Transaction.js:207
  o.perform @ Transaction.js:148
  p.batchedUpdates @ ReactDefaultBatchingStrategy.js:66
  u @ ReactUpdates.js:215
  r @ ReactUpdateQueue.js:30
  p.enqueueSetState @ ReactUpdateQueue.js:208
  r.setState @ ReactComponent.js:69
  (anonymous function) @ GroupEditor.component.js:86
  Re.AnonymousObserver.t.next @ rx.all.js:1777
  Re.internals.AbstractObserver.t.onNext @ rx.all.js:1711
  Re.AnonymousObserver.t.next @ rx.all.js:1777
  Re.internals.AbstractObserver.t.onNext @ rx.all.js:1711
  (anonymous function) @ rx.all.js:1854
  u @ rx.all.js:59
  (anonymous function) @ rx.all.js:1882
  t @ rx.all.js:1028
  Zt.invokeCore @ rx.all.js:920
  Zt.invoke @ rx.all.js:908
  e @ rx.all.js:1235
  u @ rx.all.js:59
  t @ rx.all.js:1245
  Re.Scheduler.n.scheduleWithState @ rx.all.js:961
  e.scheduleRecursiveWithState @ rx.all.js:1106
  Re.internals.ScheduledObserver.t.ensureActive @ rx.all.js:1874
  Re.ReplaySubject.Ft.onNext @ rx.all.js:7455
  i.value @ Store.js:77
  i.value @ Store.js:51
  t.default.u.default.createClass.populateItemStore @ multi-select.js:228

Is this happening to other people? Or is it just me?
Thank you so much.

** Attachment added: "data element-imp.csv"
   https://bugs.launchpad.net/dhis2/+bug/1574953/+attachment/4650935/+files/data%20element-imp.csv

···

--
You received this bug notification because you are a member of DHIS 2
developers, which is subscribed to DHIS.
https://bugs.launchpad.net/bugs/1574953

Title:
  Can't create Data Element

Status in DHIS:
  Incomplete

Bug description:
  I can't create Data Element. When I'm creating data elements, every time I choose Domain Type/Value Type/Aggregate Type it doesn't respond to anything on the data element editor. Also, my orgunit doesn't show up on Organization Levels section, it keep showing symbol of loading page.
  I try to import Data Element from .csv file, it succeed but I can't edit it because of the problem I mentioned above.

  I'm using DHIS2 live version 2.23 (the one available on DHIS2 web)
  Google Chrome Version 50.0.2661.87
  Windows 7

  Is this a bug or am I missing steps to create Data Element? Any solution to this?
  Thank you very much.

To manage notifications about this bug go to:
https://bugs.launchpad.net/dhis2/+bug/1574953/+subscriptions

Hi all,
any update on this?

Thank you.

···

--
You received this bug notification because you are a member of DHIS 2
developers, which is subscribed to DHIS.
https://bugs.launchpad.net/bugs/1574953

Title:
  Can't create Data Element

Status in DHIS:
  Incomplete

Bug description:
  I can't create Data Element. When I'm creating data elements, every time I choose Domain Type/Value Type/Aggregate Type it doesn't respond to anything on the data element editor. Also, my orgunit doesn't show up on Organization Levels section, it keep showing symbol of loading page.
  I try to import Data Element from .csv file, it succeed but I can't edit it because of the problem I mentioned above.

  I'm using DHIS2 live version 2.23 (the one available on DHIS2 web)
  Google Chrome Version 50.0.2661.87
  Windows 7

  Is this a bug or am I missing steps to create Data Element? Any solution to this?
  Thank you very much.

To manage notifications about this bug go to:
https://bugs.launchpad.net/dhis2/+bug/1574953/+subscriptions