Browser not working

Deal all, we are facing the issue of using Google Chrome, when using username and password there is a message saying wrong username and password. But it is working well with Mozilla Firefox. We tried to clean cash but nothing improved

Does any one know what to do to fix this problem.

oops, forgot users ...

···

---------- Forwarded message ----------
From: Bob Jolliffe <bobjolliffe@gmail.com>
Date: 18 July 2016 at 11:40
Subject: Re: [Dhis2-users] Browser not working
To: Emmanuel Ntawuyirusha <ntawemma@gmail.com>

Hi Emmanuel

If it works with firefox then it is really likely to be a chrome cache
issue. Try and login with chrome incognito mode. If that works then
you can be reasonably sure.

If so, then try ...

https://www.dhis2.org/tutorials/how-to-really-clear-browser-cache

Bob

On 18 July 2016 at 11:08, Emmanuel Ntawuyirusha <ntawemma@gmail.com> wrote:

Deal all, we are facing the issue of using Google Chrome, when using
username and password there is a message saying wrong username and password.
But it is working well with Mozilla Firefox. We tried to clean cash but
nothing improved
Does any one know what to do to fix this problem.

_______________________________________________
Mailing list: https://launchpad.net/~dhis2-users
Post to : dhis2-users@lists.launchpad.net
Unsubscribe : https://launchpad.net/~dhis2-users
More help : https://help.launchpad.net/ListHelp

Hi Emmanuel,

I’ve had this problem before:

Do this,

Click Customize and Control google chrome(three horizontal bars at the right hand top corner)

More Tools

Clear browsing data

on “Obliterate the following items from:” select “the beginning of time”

make sure “passwords” is checked

Clear browsing data

Refresh/Reload the browser page and you should be good to go.

Regards

Seth Okeyo | Data Management Officer

Drugs for Neglected Diseases initiative – Africa

c/o Centre for Clinical Research | Kenya Medical Research Institute| Nairobi | Kenya

T: +254 20 2077767 | +254 20 2403336 | +254 20 2733031 | M: +254 727389149 | sokeyo@dndi.org

skype: dndi_seth.okeyo |@sethokeyo

*Best Science for the Most Neglected * | www.dndi.org

cid:image001.gif@01D049FD.1DA795A0cid:image002.gif@01D049FD.1DA795A0cid:image003.gif@01D049FD.1DA795A0cid:image004.gif@01D049FD.1DA795A0cid:image005.gif@01D049FD.1DA795A0

···

From: Dhis2-users dhis2-users-bounces+sokeyo=dndi.org@lists.launchpad.net on behalf of Bob Jolliffe bobjolliffe@gmail.com

Sent: Monday, July 18, 2016 1:42:58 PM

To: dhis2-users

Subject: [Dhis2-users] Fwd: Browser not working

oops, forgot users …

---------- Forwarded message ----------

From: Bob Jolliffe bobjolliffe@gmail.com

Date: 18 July 2016 at 11:40

Subject: Re: [Dhis2-users] Browser not working

To: Emmanuel Ntawuyirusha ntawemma@gmail.com

Hi Emmanuel

If it works with firefox then it is really likely to be a chrome cache

issue. Try and login with chrome incognito mode. If that works then

you can be reasonably sure.

If so, then try …

https://www.dhis2.org/tutorials/how-to-really-clear-browser-cache

Bob

On 18 July 2016 at 11:08, Emmanuel Ntawuyirusha ntawemma@gmail.com wrote:

Deal all, we are facing the issue of using Google Chrome, when using

username and password there is a message saying wrong username and password.

But it is working well with Mozilla Firefox. We tried to clean cash but

nothing improved

Does any one know what to do to fix this problem.


Mailing list: https://launchpad.net/~dhis2-users

Post to : dhis2-users@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-users

More help : https://help.launchpad.net/ListHelp


Mailing list: https://launchpad.net/~dhis2-users

Post to : dhis2-users@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-users

More help : https://help.launchpad.net/ListHelp

Thank you Bob,

I tried to use New Incognito windows and Clear browsing data but the issue is remaining for Google Chrome , actually when we restart the server the username and password work only once and then after the problem persist. we are still waiting for your support.

Regards

···

On Mon, Jul 18, 2016 at 12:42 PM, Bob Jolliffe bobjolliffe@gmail.com wrote:

oops, forgot users …

---------- Forwarded message ----------

From: Bob Jolliffe bobjolliffe@gmail.com

Date: 18 July 2016 at 11:40

Subject: Re: [Dhis2-users] Browser not working

To: Emmanuel Ntawuyirusha ntawemma@gmail.com

Hi Emmanuel

If it works with firefox then it is really likely to be a chrome cache

issue. Try and login with chrome incognito mode. If that works then

you can be reasonably sure.

If so, then try …

https://www.dhis2.org/tutorials/how-to-really-clear-browser-cache

Bob

On 18 July 2016 at 11:08, Emmanuel Ntawuyirusha ntawemma@gmail.com wrote:

Deal all, we are facing the issue of using Google Chrome, when using

username and password there is a message saying wrong username and password.

But it is working well with Mozilla Firefox. We tried to clean cash but

nothing improved

Does any one know what to do to fix this problem.


Mailing list: https://launchpad.net/~dhis2-users

Post to : dhis2-users@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-users

More help : https://help.launchpad.net/ListHelp


Mailing list: https://launchpad.net/~dhis2-users

Post to : dhis2-users@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-users

More help : https://help.launchpad.net/ListHelp

Mr. Emmanuel NTAWUYIRUSHA
HMIS/MOH
Telephone: +250 788408772

Email: ntawemma@gmail.com
Do Good. Do It Well.

Maybe try to reinstall Chrome.

Knut

···

On Mon, Jul 18, 2016 at 12:42 PM, Bob Jolliffe bobjolliffe@gmail.com wrote:

oops, forgot users …

---------- Forwarded message ----------

From: Bob Jolliffe bobjolliffe@gmail.com

Date: 18 July 2016 at 11:40

Subject: Re: [Dhis2-users] Browser not working

To: Emmanuel Ntawuyirusha ntawemma@gmail.com

Hi Emmanuel

If it works with firefox then it is really likely to be a chrome cache

issue. Try and login with chrome incognito mode. If that works then

you can be reasonably sure.

If so, then try …

https://www.dhis2.org/tutorials/how-to-really-clear-browser-cache

Bob

On 18 July 2016 at 11:08, Emmanuel Ntawuyirusha ntawemma@gmail.com wrote:

Deal all, we are facing the issue of using Google Chrome, when using

username and password there is a message saying wrong username and password.

But it is working well with Mozilla Firefox. We tried to clean cash but

nothing improved

Does any one know what to do to fix this problem.


Mailing list: https://launchpad.net/~dhis2-users

Post to : dhis2-users@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-users

More help : https://help.launchpad.net/ListHelp


Mailing list: https://launchpad.net/~dhis2-users

Post to : dhis2-users@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-users

More help : https://help.launchpad.net/ListHelp


Mr. Emmanuel NTAWUYIRUSHA
HMIS/MOH
Telephone: +250 788408772

Email: ntawemma@gmail.com
Do Good. Do It Well.

i tried to uninstall and reinstall it again but the issue is still remaining, Note that this is happening to all users using Goggle Chrome as most of them are familiar with it.

Regards

···

On Mon, Jul 18, 2016 at 7:49 PM, Knut Staring knutst@gmail.com wrote:

Maybe try to reinstall Chrome.

Knut

On Tuesday, July 19, 2016, Ntawuyirusha Emmanuel ntawemma@gmail.com wrote:

Thank you Bob,

I tried to use New Incognito windows and Clear browsing data but the issue is remaining for Google Chrome , actually when we restart the server the username and password work only once and then after the problem persist. we are still waiting for your support.

Regards

Knut Staring

Dept. of Informatics, University of Oslo

Norway: +4791880522

Skype: knutstar

http://dhis2.org

On Mon, Jul 18, 2016 at 12:42 PM, Bob Jolliffe bobjolliffe@gmail.com wrote:

oops, forgot users …

---------- Forwarded message ----------

From: Bob Jolliffe bobjolliffe@gmail.com

Date: 18 July 2016 at 11:40

Subject: Re: [Dhis2-users] Browser not working

To: Emmanuel Ntawuyirusha ntawemma@gmail.com

Hi Emmanuel

If it works with firefox then it is really likely to be a chrome cache

issue. Try and login with chrome incognito mode. If that works then

you can be reasonably sure.

If so, then try …

https://www.dhis2.org/tutorials/how-to-really-clear-browser-cache

Bob

On 18 July 2016 at 11:08, Emmanuel Ntawuyirusha ntawemma@gmail.com wrote:

Deal all, we are facing the issue of using Google Chrome, when using

username and password there is a message saying wrong username and password.

But it is working well with Mozilla Firefox. We tried to clean cash but

nothing improved

Does any one know what to do to fix this problem.


Mailing list: https://launchpad.net/~dhis2-users

Post to : dhis2-users@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-users

More help : https://help.launchpad.net/ListHelp


Mailing list: https://launchpad.net/~dhis2-users

Post to : dhis2-users@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-users

More help : https://help.launchpad.net/ListHelp


Mr. Emmanuel NTAWUYIRUSHA
HMIS/MOH
Telephone: +250 788408772

Email: ntawemma@gmail.com
Do Good. Do It Well.

Mr. Emmanuel NTAWUYIRUSHA
HMIS/MOH
Telephone: +250 788408772

Email: ntawemma@gmail.com
Do Good. Do It Well.

Did you also follow the instructions Bob linked to? With the chrome plugin?

···

On Jul 19, 2016 12:12 AM, “Ntawuyirusha Emmanuel” ntawemma@gmail.com wrote:

Thank you Bob,

I tried to use New Incognito windows and Clear browsing data but the issue is remaining for Google Chrome , actually when we restart the server the username and password work only once and then after the problem persist. we are still waiting for your support.

Regards


Mailing list: https://launchpad.net/~dhis2-users

Post to : dhis2-users@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-users

More help : https://help.launchpad.net/ListHelp

On Mon, Jul 18, 2016 at 12:42 PM, Bob Jolliffe bobjolliffe@gmail.com wrote:

oops, forgot users …

---------- Forwarded message ----------

From: Bob Jolliffe bobjolliffe@gmail.com

Date: 18 July 2016 at 11:40

Subject: Re: [Dhis2-users] Browser not working

To: Emmanuel Ntawuyirusha ntawemma@gmail.com

Hi Emmanuel

If it works with firefox then it is really likely to be a chrome cache

issue. Try and login with chrome incognito mode. If that works then

you can be reasonably sure.

If so, then try …

https://www.dhis2.org/tutorials/how-to-really-clear-browser-cache

Bob

On 18 July 2016 at 11:08, Emmanuel Ntawuyirusha ntawemma@gmail.com wrote:

Deal all, we are facing the issue of using Google Chrome, when using

username and password there is a message saying wrong username and password.

But it is working well with Mozilla Firefox. We tried to clean cash but

nothing improved

Does any one know what to do to fix this problem.


Mailing list: https://launchpad.net/~dhis2-users

Post to : dhis2-users@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-users

More help : https://help.launchpad.net/ListHelp


Mailing list: https://launchpad.net/~dhis2-users

Post to : dhis2-users@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-users

More help : https://help.launchpad.net/ListHelp


Mr. Emmanuel NTAWUYIRUSHA
HMIS/MOH
Telephone: +250 788408772

Email: ntawemma@gmail.com
Do Good. Do It Well.

Hi Emmanuel

I am following up on a separate thread. I'll copy you into that.

I see it is a problem, seemingly related to chrome mishandling the
JSESSIONID cookie so even though the credentials are tested and dhis2
logs a successful authentication, the browser cookie doesn't match the
session id in dhis and so you don't get in. I am really not sure why
What I also don't know is what might have changed to cause this to
happen. I am assuming you didn't just wake up one morning and this
started to happen. There has been some change to nginx configuration
or dhis2 upgrade or something similar.

···

On 19 July 2016 at 14:40, Ntawuyirusha Emmanuel <ntawemma@gmail.com> wrote:

i tried to uninstall and reinstall it again but the issue is still
remaining, Note that this is happening to all users using Goggle Chrome as
most of them are familiar with it.

Regards

On Mon, Jul 18, 2016 at 7:49 PM, Knut Staring <knutst@gmail.com> wrote:

Maybe try to reinstall Chrome.

Knut

On Tuesday, July 19, 2016, Ntawuyirusha Emmanuel <ntawemma@gmail.com> >> wrote:

Thank you Bob,

I tried to use New Incognito windows and Clear browsing data but the
issue is remaining for Google Chrome , actually when we restart the server
the username and password work only once and then after the problem persist.
we are still waiting for your support.

Regards

On Mon, Jul 18, 2016 at 12:42 PM, Bob Jolliffe <bobjolliffe@gmail.com> >>> wrote:

oops, forgot users ...

---------- Forwarded message ----------
From: Bob Jolliffe <bobjolliffe@gmail.com>
Date: 18 July 2016 at 11:40
Subject: Re: [Dhis2-users] Browser not working
To: Emmanuel Ntawuyirusha <ntawemma@gmail.com>

Hi Emmanuel

If it works with firefox then it is really likely to be a chrome cache
issue. Try and login with chrome incognito mode. If that works then
you can be reasonably sure.

If so, then try ...

https://www.dhis2.org/tutorials/how-to-really-clear-browser-cache

Bob

On 18 July 2016 at 11:08, Emmanuel Ntawuyirusha <ntawemma@gmail.com> >>>> wrote:
> Deal all, we are facing the issue of using Google Chrome, when using
> username and password there is a message saying wrong username and
> password.
> But it is working well with Mozilla Firefox. We tried to clean cash
> but
> nothing improved
> Does any one know what to do to fix this problem.
>
>
> _______________________________________________
> Mailing list: https://launchpad.net/~dhis2-users
> Post to : dhis2-users@lists.launchpad.net
> Unsubscribe : https://launchpad.net/~dhis2-users
> More help : https://help.launchpad.net/ListHelp
>

_______________________________________________
Mailing list: https://launchpad.net/~dhis2-users
Post to : dhis2-users@lists.launchpad.net
Unsubscribe : https://launchpad.net/~dhis2-users
More help : https://help.launchpad.net/ListHelp

--
*Mr. Emmanuel NTAWUYIRUSHA*
HMIS/MOH
Telephone: *+250 788408772*
Email: ntawemma@gmail.com
"Do Good. Do It Well."

--
Knut Staring
Dept. of Informatics, University of Oslo
Norway: +4791880522
Skype: knutstar
http://dhis2.org

--
*Mr. Emmanuel NTAWUYIRUSHA*
HMIS/MOH
Telephone: *+250 788408772*
Email: ntawemma@gmail.com
"Do Good. Do It Well."

Dear Bob,
I am having this same issue to with Chrome. After entering the log in credentials, it opens a page with API data and does not log in. If I am lucky and have a data entry page open, then I can log in at the prompt and that works.
Our instance is set to load the dashboard as the opening page.

Have to keep struggling with it till it eventually logs in.

Thanks
Original Message

···

From: Bob Jolliffe
Sent: Tuesday, 19 July 2016 14:58
To: Ntawuyirusha Emmanuel
Cc: dhis2-users
Subject: Re: [Dhis2-users] Browser not working

Hi Emmanuel

I am following up on a separate thread. I'll copy you into that.

I see it is a problem, seemingly related to chrome mishandling the
JSESSIONID cookie so even though the credentials are tested and dhis2
logs a successful authentication, the browser cookie doesn't match the
session id in dhis and so you don't get in. I am really not sure why
What I also don't know is what might have changed to cause this to
happen. I am assuming you didn't just wake up one morning and this
started to happen. There has been some change to nginx configuration
or dhis2 upgrade or something similar.

On 19 July 2016 at 14:40, Ntawuyirusha Emmanuel <ntawemma@gmail.com> wrote:

i tried to uninstall and reinstall it again but the issue is still
remaining, Note that this is happening to all users using Goggle Chrome as
most of them are familiar with it.

Regards

On Mon, Jul 18, 2016 at 7:49 PM, Knut Staring <knutst@gmail.com> wrote:

Maybe try to reinstall Chrome.

Knut

On Tuesday, July 19, 2016, Ntawuyirusha Emmanuel <ntawemma@gmail.com> >> wrote:

Thank you Bob,

I tried to use New Incognito windows and Clear browsing data but the
issue is remaining for Google Chrome , actually when we restart the server
the username and password work only once and then after the problem persist.
we are still waiting for your support.

Regards

On Mon, Jul 18, 2016 at 12:42 PM, Bob Jolliffe <bobjolliffe@gmail.com> >>> wrote:

oops, forgot users ...

---------- Forwarded message ----------
From: Bob Jolliffe <bobjolliffe@gmail.com>
Date: 18 July 2016 at 11:40
Subject: Re: [Dhis2-users] Browser not working
To: Emmanuel Ntawuyirusha <ntawemma@gmail.com>

Hi Emmanuel

If it works with firefox then it is really likely to be a chrome cache
issue. Try and login with chrome incognito mode. If that works then
you can be reasonably sure.

If so, then try ...

https://www.dhis2.org/tutorials/how-to-really-clear-browser-cache

Bob

On 18 July 2016 at 11:08, Emmanuel Ntawuyirusha <ntawemma@gmail.com> >>>> wrote:
> Deal all, we are facing the issue of using Google Chrome, when using
> username and password there is a message saying wrong username and
> password.
> But it is working well with Mozilla Firefox. We tried to clean cash
> but
> nothing improved
> Does any one know what to do to fix this problem.
>
>
> _______________________________________________
> Mailing list: https://launchpad.net/~dhis2-users
> Post to : dhis2-users@lists.launchpad.net
> Unsubscribe : https://launchpad.net/~dhis2-users
> More help : https://help.launchpad.net/ListHelp
>

_______________________________________________
Mailing list: https://launchpad.net/~dhis2-users
Post to : dhis2-users@lists.launchpad.net
Unsubscribe : https://launchpad.net/~dhis2-users
More help : https://help.launchpad.net/ListHelp

--
*Mr. Emmanuel NTAWUYIRUSHA*
HMIS/MOH
Telephone: *+250 788408772*
Email: ntawemma@gmail.com
"Do Good. Do It Well."

--
Knut Staring
Dept. of Informatics, University of Oslo
Norway: +4791880522
Skype: knutstar
http://dhis2.org

--
*Mr. Emmanuel NTAWUYIRUSHA*
HMIS/MOH
Telephone: *+250 788408772*
Email: ntawemma@gmail.com
"Do Good. Do It Well."

_______________________________________________
Mailing list: https://launchpad.net/~dhis2-users
Post to : dhis2-users@lists.launchpad.net
Unsubscribe : https://launchpad.net/~dhis2-users
More help : https://help.launchpad.net/ListHelp

Hi, I can add that I have the same problem on two different servers: logging in with Chrome (or Safari) does not work, Firefox works fine. Instances are both 2.24 build. Nginx 1.4.6 are running on both servers. Both servers have other non-2.24 instances that does not have the same problem.

To add to the problem, the DHIS 2 top menu does not work in Firefox, e.g. nothing works…Not sure if that’s a general problem or not. Again, menu works in non-24 instances.

Regards

Olav

···
  1. jul. 2016 kl. 14.41 skrev ifeanyiokoye@yahoo.com:

Dear Bob,
I am having this same issue to with Chrome. After entering the log in credentials, it opens a page with API data and does not log in. If I am lucky and have a data entry page open, then I can log in at the prompt and that works.
Our instance is set to load the dashboard as the opening page.

Have to keep struggling with it till it eventually logs in.

Thanks
Original Message
From: Bob Jolliffe
Sent: Tuesday, 19 July 2016 14:58
To: Ntawuyirusha Emmanuel
Cc: dhis2-users
Subject: Re: [Dhis2-users] Browser not working

Hi Emmanuel

I am following up on a separate thread. I’ll copy you into that.

I see it is a problem, seemingly related to chrome mishandling the
JSESSIONID cookie so even though the credentials are tested and dhis2
logs a successful authentication, the browser cookie doesn’t match the
session id in dhis and so you don’t get in. I am really not sure why
What I also don’t know is what might have changed to cause this to
happen. I am assuming you didn’t just wake up one morning and this
started to happen. There has been some change to nginx configuration
or dhis2 upgrade or something similar.

On 19 July 2016 at 14:40, Ntawuyirusha Emmanuel ntawemma@gmail.com wrote:

i tried to uninstall and reinstall it again but the issue is still
remaining, Note that this is happening to all users using Goggle Chrome as
most of them are familiar with it.

Regards

On Mon, Jul 18, 2016 at 7:49 PM, Knut Staring knutst@gmail.com wrote:

Maybe try to reinstall Chrome.

Knut

On Tuesday, July 19, 2016, Ntawuyirusha Emmanuel ntawemma@gmail.com > > > wrote:

Thank you Bob,

I tried to use New Incognito windows and Clear browsing data but the
issue is remaining for Google Chrome , actually when we restart the server
the username and password work only once and then after the problem persist.
we are still waiting for your support.

Regards

On Mon, Jul 18, 2016 at 12:42 PM, Bob Jolliffe bobjolliffe@gmail.com > > > > wrote:

oops, forgot users …

---------- Forwarded message ----------
From: Bob Jolliffe bobjolliffe@gmail.com
Date: 18 July 2016 at 11:40
Subject: Re: [Dhis2-users] Browser not working
To: Emmanuel Ntawuyirusha ntawemma@gmail.com

Hi Emmanuel

If it works with firefox then it is really likely to be a chrome cache
issue. Try and login with chrome incognito mode. If that works then
you can be reasonably sure.

If so, then try …

https://www.dhis2.org/tutorials/how-to-really-clear-browser-cache

Bob

On 18 July 2016 at 11:08, Emmanuel Ntawuyirusha ntawemma@gmail.com > > > > > wrote:

Deal all, we are facing the issue of using Google Chrome, when using
username and password there is a message saying wrong username and
password.
But it is working well with Mozilla Firefox. We tried to clean cash
but
nothing improved
Does any one know what to do to fix this problem.


Mailing list: https://launchpad.net/~dhis2-users
Post to : dhis2-users@lists.launchpad.net
Unsubscribe : https://launchpad.net/~dhis2-users
More help : https://help.launchpad.net/ListHelp


Mailing list: https://launchpad.net/~dhis2-users
Post to : dhis2-users@lists.launchpad.net
Unsubscribe : https://launchpad.net/~dhis2-users
More help : https://help.launchpad.net/ListHelp


Mr. Emmanuel NTAWUYIRUSHA
HMIS/MOH
Telephone: +250 788408772
Email: ntawemma@gmail.com
“Do Good. Do It Well.”


Knut Staring
Dept. of Informatics, University of Oslo
Norway: +4791880522
Skype: knutstar
http://dhis2.org


Mr. Emmanuel NTAWUYIRUSHA
HMIS/MOH
Telephone: +250 788408772
Email: ntawemma@gmail.com
“Do Good. Do It Well.”


Mailing list: https://launchpad.net/~dhis2-users
Post to : dhis2-users@lists.launchpad.net
Unsubscribe : https://launchpad.net/~dhis2-users
More help : https://help.launchpad.net/ListHelp


Mailing list: https://launchpad.net/~dhis2-users
Post to : dhis2-users@lists.launchpad.net
Unsubscribe : https://launchpad.net/~dhis2-users
More help : https://help.launchpad.net/ListHelp

I can confirm this as well. Neither Safari nor Chrome (51.0) function properly. I’ve tried to experimentally modify our nginx server ssl_session_cache settings and even tried turning that and all other caching off, but same problems.

···

On 19 July 2016 at 17:08, Olav Poppe olav.poppe@me.com wrote:

Hi, I can add that I have the same problem on two different servers: logging in with Chrome (or Safari) does not work, Firefox works fine. Instances are both 2.24 build. Nginx 1.4.6 are running on both servers. Both servers have other non-2.24 instances that does not have the same problem.

To add to the problem, the DHIS 2 top menu does not work in Firefox, e.g. nothing works…Not sure if that’s a general problem or not. Again, menu works in non-24 instances.

Regards

Olav

  1. jul. 2016 kl. 14.41 skrev ifeanyiokoye@yahoo.com:

Dear Bob,
I am having this same issue to with Chrome. After entering the log in credentials, it opens a page with API data and does not log in. If I am lucky and have a data entry page open, then I can log in at the prompt and that works.
Our instance is set to load the dashboard as the opening page.

Have to keep struggling with it till it eventually logs in.

Thanks
Original Message
From: Bob Jolliffe
Sent: Tuesday, 19 July 2016 14:58
To: Ntawuyirusha Emmanuel
Cc: dhis2-users

Subject: Re: [Dhis2-users] Browser not working

Hi Emmanuel

I am following up on a separate thread. I’ll copy you into that.

I see it is a problem, seemingly related to chrome mishandling the
JSESSIONID cookie so even though the credentials are tested and dhis2
logs a successful authentication, the browser cookie doesn’t match the
session id in dhis and so you don’t get in. I am really not sure why
What I also don’t know is what might have changed to cause this to
happen. I am assuming you didn’t just wake up one morning and this
started to happen. There has been some change to nginx configuration
or dhis2 upgrade or something similar.

On 19 July 2016 at 14:40, Ntawuyirusha Emmanuel ntawemma@gmail.com wrote:

i tried to uninstall and reinstall it again but the issue is still
remaining, Note that this is happening to all users using Goggle Chrome as
most of them are familiar with it.

Regards

On Mon, Jul 18, 2016 at 7:49 PM, Knut Staring knutst@gmail.com wrote:

Maybe try to reinstall Chrome.

Knut

On Tuesday, July 19, 2016, Ntawuyirusha Emmanuel ntawemma@gmail.com
wrote:

Thank you Bob,

I tried to use New Incognito windows and Clear browsing data but the
issue is remaining for Google Chrome , actually when we restart the server
the username and password work only once and then after the problem persist.
we are still waiting for your support.

Regards

On Mon, Jul 18, 2016 at 12:42 PM, Bob Jolliffe bobjolliffe@gmail.com
wrote:

oops, forgot users …

---------- Forwarded message ----------
From: Bob Jolliffe bobjolliffe@gmail.com
Date: 18 July 2016 at 11:40
Subject: Re: [Dhis2-users] Browser not working
To: Emmanuel Ntawuyirusha ntawemma@gmail.com

Hi Emmanuel

If it works with firefox then it is really likely to be a chrome cache
issue. Try and login with chrome incognito mode. If that works then
you can be reasonably sure.

If so, then try …

https://www.dhis2.org/tutorials/how-to-really-clear-browser-cache

Bob

On 18 July 2016 at 11:08, Emmanuel Ntawuyirusha ntawemma@gmail.com
wrote:

Deal all, we are facing the issue of using Google Chrome, when using
username and password there is a message saying wrong username and
password.
But it is working well with Mozilla Firefox. We tried to clean cash
but
nothing improved
Does any one know what to do to fix this problem.


Mailing list: https://launchpad.net/~dhis2-users
Post to : dhis2-users@lists.launchpad.net
Unsubscribe : https://launchpad.net/~dhis2-users
More help : https://help.launchpad.net/ListHelp


Mailing list: https://launchpad.net/~dhis2-users
Post to : dhis2-users@lists.launchpad.net
Unsubscribe : https://launchpad.net/~dhis2-users
More help : https://help.launchpad.net/ListHelp


Mr. Emmanuel NTAWUYIRUSHA
HMIS/MOH
Telephone: +250 788408772
Email: ntawemma@gmail.com
“Do Good. Do It Well.”


Knut Staring
Dept. of Informatics, University of Oslo
Norway: +4791880522
Skype: knutstar
http://dhis2.org


Mr. Emmanuel NTAWUYIRUSHA
HMIS/MOH
Telephone: +250 788408772
Email: ntawemma@gmail.com
“Do Good. Do It Well.”


Mailing list: https://launchpad.net/~dhis2-users
Post to : dhis2-users@lists.launchpad.net
Unsubscribe : https://launchpad.net/~dhis2-users
More help : https://help.launchpad.net/ListHelp


Mailing list: https://launchpad.net/~dhis2-users
Post to : dhis2-users@lists.launchpad.net
Unsubscribe : https://launchpad.net/~dhis2-users
More help : https://help.launchpad.net/ListHelp


Mailing list: https://launchpad.net/~dhis2-users

Post to : dhis2-users@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-users

More help : https://help.launchpad.net/ListHelp


Steven Uggowitzer

eSHIfT Partner Network, Entuura Ventures Ltd

Tel: +41 22 366 1920

Mob: +41 79 719 4180

Skype: fendant123

LinkedIn: http://ch.linkedin.com/in/stevenuggowitzer

I can also confirm same issue is happening in Ghana as well.The whole country can not login using (chrome) Firefox is working fine.I personally have tried it.Am currently running dhis 2.22 on the national instances.

Regards

Tony.

···

On 19 July 2016 at 17:08, Olav Poppe olav.poppe@me.com wrote:

Hi, I can add that I have the same problem on two different servers: logging in with Chrome (or Safari) does not work, Firefox works fine. Instances are both 2.24 build. Nginx 1.4.6 are running on both servers. Both servers have other non-2.24 instances that does not have the same problem.

To add to the problem, the DHIS 2 top menu does not work in Firefox, e.g. nothing works…Not sure if that’s a general problem or not. Again, menu works in non-24 instances.

Regards

Olav

  1. jul. 2016 kl. 14.41 skrev ifeanyiokoye@yahoo.com:

Dear Bob,
I am having this same issue to with Chrome. After entering the log in credentials, it opens a page with API data and does not log in. If I am lucky and have a data entry page open, then I can log in at the prompt and that works.
Our instance is set to load the dashboard as the opening page.

Have to keep struggling with it till it eventually logs in.

Thanks
Original Message
From: Bob Jolliffe
Sent: Tuesday, 19 July 2016 14:58
To: Ntawuyirusha Emmanuel
Cc: dhis2-users

Subject: Re: [Dhis2-users] Browser not working

Hi Emmanuel

I am following up on a separate thread. I’ll copy you into that.

I see it is a problem, seemingly related to chrome mishandling the
JSESSIONID cookie so even though the credentials are tested and dhis2
logs a successful authentication, the browser cookie doesn’t match the
session id in dhis and so you don’t get in. I am really not sure why
What I also don’t know is what might have changed to cause this to
happen. I am assuming you didn’t just wake up one morning and this
started to happen. There has been some change to nginx configuration
or dhis2 upgrade or something similar.

On 19 July 2016 at 14:40, Ntawuyirusha Emmanuel ntawemma@gmail.com wrote:

i tried to uninstall and reinstall it again but the issue is still
remaining, Note that this is happening to all users using Goggle Chrome as
most of them are familiar with it.

Regards

On Mon, Jul 18, 2016 at 7:49 PM, Knut Staring knutst@gmail.com wrote:

Maybe try to reinstall Chrome.

Knut

On Tuesday, July 19, 2016, Ntawuyirusha Emmanuel ntawemma@gmail.com
wrote:

Thank you Bob,

I tried to use New Incognito windows and Clear browsing data but the
issue is remaining for Google Chrome , actually when we restart the server
the username and password work only once and then after the problem persist.
we are still waiting for your support.

Regards

On Mon, Jul 18, 2016 at 12:42 PM, Bob Jolliffe bobjolliffe@gmail.com
wrote:

oops, forgot users …

---------- Forwarded message ----------
From: Bob Jolliffe bobjolliffe@gmail.com
Date: 18 July 2016 at 11:40
Subject: Re: [Dhis2-users] Browser not working
To: Emmanuel Ntawuyirusha ntawemma@gmail.com

Hi Emmanuel

If it works with firefox then it is really likely to be a chrome cache
issue. Try and login with chrome incognito mode. If that works then
you can be reasonably sure.

If so, then try …

https://www.dhis2.org/tutorials/how-to-really-clear-browser-cache

Bob

On 18 July 2016 at 11:08, Emmanuel Ntawuyirusha ntawemma@gmail.com
wrote:

Deal all, we are facing the issue of using Google Chrome, when using
username and password there is a message saying wrong username and
password.
But it is working well with Mozilla Firefox. We tried to clean cash
but
nothing improved
Does any one know what to do to fix this problem.


Mailing list: https://launchpad.net/~dhis2-users
Post to : dhis2-users@lists.launchpad.net
Unsubscribe : https://launchpad.net/~dhis2-users
More help : https://help.launchpad.net/ListHelp


Mailing list: https://launchpad.net/~dhis2-users
Post to : dhis2-users@lists.launchpad.net
Unsubscribe : https://launchpad.net/~dhis2-users
More help : https://help.launchpad.net/ListHelp


Mr. Emmanuel NTAWUYIRUSHA
HMIS/MOH
Telephone: +250 788408772
Email: ntawemma@gmail.com
“Do Good. Do It Well.”


Knut Staring
Dept. of Informatics, University of Oslo
Norway: +4791880522
Skype: knutstar
http://dhis2.org


Mr. Emmanuel NTAWUYIRUSHA
HMIS/MOH
Telephone: +250 788408772
Email: ntawemma@gmail.com
“Do Good. Do It Well.”


Mailing list: https://launchpad.net/~dhis2-users
Post to : dhis2-users@lists.launchpad.net
Unsubscribe : https://launchpad.net/~dhis2-users
More help : https://help.launchpad.net/ListHelp


Mailing list: https://launchpad.net/~dhis2-users
Post to : dhis2-users@lists.launchpad.net
Unsubscribe : https://launchpad.net/~dhis2-users
More help : https://help.launchpad.net/ListHelp


Mailing list: https://launchpad.net/~dhis2-users

Post to : dhis2-users@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-users

More help : https://help.launchpad.net/ListHelp


Steven Uggowitzer

eSHIfT Partner Network, Entuura Ventures Ltd

Tel: +41 22 366 1920

Mob: +41 79 719 4180

Skype: fendant123

LinkedIn: http://ch.linkedin.com/in/stevenuggowitzer