Breaking the glass problem

in my tracker program i have configured the program into “protected” security mode, also have given the user in the user role, the ability to search for all org. units and update TEI , however the user cannot still perform the search for a TEI in another Org. Unit that is not assigned to that particular user.
What else should i be doing to be able to break the glass???
Thank you in advance

The organisation unit selection in “search” and " data capture and maintenance" in the screenshots are not similar. Could you try selecting the top level of these, enter data then run analytics and see if you are able to search.

Hi @raju
this user has access to only one organization unit for data capturing. however i wanted to give him the ability to break the glass by being able to search a TEI in all organization units.

Hey @Haliz.t .

It seems pretty much everything in order to me. You are attempting to search for an already present TEI in the system, right?

I just set up in the DHIS 2 Demo - Sierra Leone server the TB program as protected. You can connect with admin to see how it is set up.

Then, there is a user ( tracker // District1#) which can use this breaking the glass feature. Go to TB program in Tracker Capture and search for “Jimbolinga”

I would advise to check these settings and make sure they match your server.

1 Like

HI @jaime.bosque
Thanks alot for your time and recommendation.
i indeed opened both DHIS2 Demo - Sierra Leone and my Tracker program just to follow on all program setup things and user roles … they are almost the same, however i am still having the same problem … the user cannot break the glass … the message of the TEI is not available and go to registry keeps popping up… :frowning:
What to do?

1 Like

@Markus , @mike , @Gassim ?

thanks @jaime.bosque and @raju! (:

@Haliz.t please what is the version of the dhis2 instance that you are using?

Was the TEIs registered before or after the breaking the glass configuration. Please clear the server cache from the Data Administrator app → Maintenance → ‘Clear application cache’ and ‘Reload apps.’ After that try to repeat the process in your browser’s Guest mode.

Another question I have is if you could you try to search in the Capture app (instead of the Tracker Capture app?) does it work there? If the above doesn’t work, please open the Tracker Capture app before you start the search, open the Network tab in your browser’s Dev Tools (F12) and after you perform the search, please take a screenshot of the requests being sent (if one is in red text especially click on it and take a screenshot of the request, payload, and response)

Hope this helps. Thank you!

Hi @Gassim and thank you @jaime.bosque
I am using DHIS2 version, as for the TEIs i registered them first then i started to look for how to configure breaking the glass.
so I followed these steps that you have mentioned thankfully :
1- in the Data Administration app i could not find the “Clear server Cache” as you can see, so i just performed the other “Reload apps” and “Clear application cache”

2- I performed the search from a guest mode browser and there were no errors

3- i opened the Capture app and performed search there and it did not work

4- I tried to register a new TEI, I moved to tracker app and tried to search for a TEI that is not in my data entry area…I found a strange thing…
When i searched by Registration number which is a Unique System Identifier that i have set up earlier … the search was a success with breaking the glass issue

However , when i searched by TEI attributes like first name, middle name ,last name the search failed

looking forward for your support.

1 Like

Dear @Haliz.t

Please check if these attributes are marked as searchable and if they are not then mark them and try again (you probably need to clear the cache again.)

Dear @Gassim
Thanks for your prompt reply,
My attributes are already set as searchable as shown below

I cleared the cache and performed search again… i was faced with the same problem, when i search by unique identifier , i have no problems .
However , when i search by the attributes i mentioned before I still cannot have a proper search neither breaking the glass.

@Gassim also i realized that when i break the glass and go to the other organization unit patient record, i cannot perform any data entry.
for example if a person registered in org. unit A and came to me at org. Unit B for vaccination …and i was able to break the glass… i still cannot register the patient vaccines … does this mean i have to give the authority of capturing data at all the Org. Units ???

1 Like

I don’t think so!

I’m asking for support on this case. Thanks for your patience @Haliz.t!

Hi there Haliz!

Does this mean that when searching with unique identifier, breaking the glass and opening the record works normally? What is the exact workflow when you do search with attributes? Do you search, but see no results? Do you search, see the result, but open the record without any break the glass dialog?

You had provided the search setup for your program above, but how is the tracked entity type set up? Do you have the TEType attributes as searchable as well? To be able to search across org units and programs, the TEType search attributes is used as fallback.

also i realized that when i break the glass and go to the other organization unit patient record, i cannot perform any data entry.

If you break the glass, you should be able to work with the TEI in the program that you broke the glass for, and also enroll this TEI into new programs where they are not already enrolled. No you should not have to give the capture authority for all org units, like @Gassim points out.

1 Like