Audit "Unexpected" Bahaviour on DataEntry

Hi,
I am new to DHIS2 and I am still trying to figure out how it works.
In particular, I would like to get notified through the audit mechanism about new DataValue.
So, I have entered the DataEntry app, and I was updating some values.
I noticed the following behavior.

  1. If I click on a cell and enter a value, change the focus and then double click on the first cell, I cannot see any audit in the audit list. Instead, I would expect to see at least one audit entry which tells me that I have updated the content of that cell. To actually see an audit entry I have to re-enter the first cell, modify it and then change focus and reset focus on it. And, in this case, the value shown in the audit entry is not the
    current data value, but the previous one.

  2. If, instead of changing focus after entering a new value in the cell, I double click and just do something in the dialog (for instance saving a comment, even an empty one) then the audit event is fired with value the one I have entered.

So, I was wondering if this is the expected behavior. I mean, I would expect that any time I enter a new value in a DataEntry cell, and then I change focus, an audit event is fired, without the need to enter the comment dialog with a double click on the cell and modify it in some way.
Or am I missing something?

Thank you very much for the help!

Best Regards,
Ilenia

1 Like

Hello @isalvadori and welcome to the DHIS2 Community!!

A quick one; Which DHIS2 version are you using and would you please share some test screenshots for us to understand better your use case?

Thanks,
James

Hello James,
thank you for your reply. I am using DHIS2 version 2.33.0. I am using the docker image for it, which I have set up following the instructions at https://dhis2.github.io/2019/10/dhis2-and-docker/
Here are some screenshots which illustrate the two cases I was talking about.

  1. I have entered the DataEntry app, select the OrganisationUnit, the DataSet and the period

  2. I have entered a value in the first cell and changed focus going on another cell

  3. I then have double-clicked again on the first cell and went to the audit list of the dialog, which is, as you can see empty. Here, instead, I would expect to see my first modification.

  4. Then I went to another cell and entered a value, and double-clicked there and just saved an empty comment

  5. Then I changed focus and went back to that cell, double-click and opened the audit list, which now shows my first modification to the cell.

So, at the end, what it seems weird to me is that I cannot see an audit entry when I first modify a cell without doing something in the comment/audit dialog, but I can only see it if I first make some modifications in the dialog.
I had to merge all the screenshot in one image because I am not allowed to upload more than 2 images, so apologies for the quality of the file.

Thank you very much for your help!
Best Regards,
Ilenia

2 Likes

It’s okay @isalvadori. Please try entering the test_data again and once you have finished, click on Complete under there. Try and revisit the cells to see if the audit trails are all visible or still not showing on the cell you entered data on…??

Let us know if it works.

Best,
James.

Just tried. Even if I click on Complete the audit entry does not appear.

Thanks for your time,
Ilenia

1 Like

Hey,

So I have tried it out on play demo server and the audit trail captures the previous values that the cell had. If you delete a value from the cell and replace it with a different value, the original value that was deleted shows up on the audit trail. it doesn’t just capture values entered; there has to be a modification to the cell for it to register the change on the audit trail. (for my case I had 4, then replaced it with 1 and below is my screenshot)

Check out the Documentation

Hi,

Ok, but isn`t a modification to the cell also passing from no value to a certain value?
I would expect an audit entry with value “null” (since the value in the audit is the previous one and not the current one).
If I wanted to react to changes in the cell, this means that I will never be notified from the audit list that a change has been made when I first enter a new value in a cell, but only when this value will be further modified. This seems a bit counter intuitive to me.

Thank you for your time!

Ilenia

2 Likes

Hi @isalvadori,

I share your expectations and I created a bug on your behalf in our jira. You can follow the progress here: https://jira.dhis2.org/browse/DHIS2-7959.

1 Like

Hi @Gintare,
thank you very much.

Best Regards,
Ilenia