Android-settings-app - error while starting & building

Hello Team,

Here is the issue I am facing

I could see that “android settings app” was not found in the “apps” section, therefore i tried to load it manually and followed the following steps

  1. fetched the repo from github
  2. executed yarn install
  3. executed yarn build

I get the following error

(node:16170) UnhandledPromiseRejectionWarning: TypeError: reporter.debugError is not a function
at FSWatcher. (/home/sunder/YELDI/server/android-settings-app/node_modules/@dhis2/cli-app-scripts/src/lib/compiler/compileApp.js:75:26)
at FSWatcher.emit (events.js:310:20)
at FSWatcher._handleError (/home/sunder/YELDI/server/android-settings-app/node_modules/chokidar/index.js:641:10)
at NodeFsHandler._addToNodeFs (/home/sunder/YELDI/server/android-settings-app/node_modules/chokidar/lib/nodefs-handler.js:636:18)
(node:16170) UnhandledPromiseRejectionWarning: Unhandled promise rejection. This error originated either by throwing inside of an async function without a catch block, or by rejecting a promise which was not handled with .catch(). To terminate the node process on unhandled promise rejection, use the CLI flag --unhandled-rejections=strict (see (rejection id: 1)

Before loading this app, I was able to load “app-skeleton” app just to get familiar with app making process, and it worked fine.

Here are the node versions

node - 12.16.3
npm - 6.14.4
yarn - 1…22.4

Please help.


Hi @kollyhood what version of DHIS2 are you running?
Also, it would be a good idea to check the App Hub/App Store, here some steps of how to do it:

  • Click on App Management

  • Click on App Hub/ App Store (you can find it on the side bar)

  • Scroll down until you find Android Settings App and click on Install V1.0.0

  • Now you can find the web app on the Standard App section, click on the App and it will load

I hope this can help you