Android data capture app keep loading dataset form

I am trying to use the Android Data Capture app. When I tried to open a dataset, instead of the form page to open, the page keeps loading. I tried this with several dataset and experience the same issue. The only dataset that open is the one I use to capture population with one data element. Others that have several data elements is not working.

Hi @jetisco4u .

Which version of the App are you using? If you connect to the Play instances, do you see all the Data Set with the Data Elements? I believe that this might be a misconfiguration of your server… In any case, the App should not stay in a loop. Any chance you could provide access if it is a testing server?


I am using the version of the App with

Yes I do

It’s a live server

The only dataset that open is the one I use to capture population with one data element. It seems the looping occur when there are multiple data elements in the form. I have uninstall and reinstall the App to no avail.

Is there any special configuration I am supposed to do on the server instance?

I just find out now that the issue occur when I login to the Test account I created for the Data Capture user group. When I login with admin, the forms load fine.

Is there a setting perhaps sharing that I need to do for other users apart from the admin?

If it is a live server, could you share the credentials via PM? I would like to see why this causes the loop. In any case, you are probably facing a sharing settings issue with either the dataset, the data elements, the categories, etc

1 Like

Do I need to share dataElements with the userGroup assigned to capture data for it to work on Android? On the DataEntry App and on my custom App we the group members are able to access the DE and capture data. They are only experiencing this on Android Data Capture App.

This probably resolved it. I shared the DE with the groups to capture data and resync the Android app and the section and forms are now showing.