Analytics validation - Cannot retrieve total value for data elements with skip total category combination'

When I generated the report of the dataset, an error occurred, and when I checked the catalina I found this message: Analytics validation failed, code: ‘E7134’, message: ‘Cannot retrieve total value for data elements with skip total category combination’ ( [http-nio-8080-exec-8]) ID80XPsfuWVz4YLknUjFQFx0+k6U/VaF4zYb0XYJnbi7U=

Help me fix this error. why this error happened and how to fix it as well.

The error message says that the data elements have category combinations with the option skip total enabled and the report is requesting a total so this is not possible. You need to either disable the skip total or make sure that the report doesn’t request totals.


I am tried on disabling the “skip total” option for category combination. Despite my attempts, it’s refused to disabled it.

I kindly request your assistance in providing me with instructions on how to ensure that the report does not request totals. Your expertise and advice in this matter would be greatly appreciated.

Best regards,

Please try the following step by step:

  1. Data Administration app → Maintenance → Clear analytics tables, Clear application cache, reload apps
  2. Data Administration app → Analytics Tables → Start Export
  3. Clear browser cache [might require several methods] but to make sure it’s not a cache issue perform the step below
  4. Login to the instance from your browser’s Guest mode Browse Chrome as a guest - Computer - Google Chrome Help

If the errors are not gone, please open the Network tab and Console in your DevTools (F12 → Network) before your try to disable the “skip total” and then check for errors in red text that could help us understand why it’s refusing to disable the “skip total”, select each error if there are any and take a screenshot - better if you include both request and response. Additionally, please share the complete Catalina.out log (without sensitive/authentication info) so we could double check there are no other errors.

Thank you!

I tried this method but it didn’t work unfortunately

1 Like

I have two environments which are faced the same problem. The first one has been processed successful. The second I will try later once I have time then I will return back to you.

Dear @emad
Once you have some free time, I would like to attempt the method I previously employed in my environment.

1 Like

Sorry it didn’t work.

Thank you!

Good to know @sami.oracle10g, was one of the tips above helpful or there’s another method that you tried. You are welcome to share the solution with the community please.


1 Like


Le dhis2 affiche cette erreur lors de l’analyse de données en visualiseur de données.
La solution, vous devez introduire dans l’analyse les catégories concernant le data élément. Si vous ne voulez pas que cette catégorie s’affiche, vous pouvez le mettre dans le filtre du rapport.
La deuxième solution : créer un indicateur pour ce Data élément, et vous utilisez cet indicateur comme données dans l’analyse.

Merci et bonne continuation à tous