Analytics Error: Process failed: StatementCallback; bad SQL grammar [create table analytics_event_temp_zxbjnsrdsai ("uidlevel1" character(11),"uidlevel2" character..

Dear All

I just upgraded my dhis2 instance from 2.29 to 2.30. However whenever I want to run analytics, I am getting the above error. Has anyone come
dhis.log

across this and what can I do to have it resolved. Attached is the log file

Please help.

Allan

Hi Allan,

We had a similar error and in our case it was related to this indication in the update instructions:

  • PostGIS is now a required extension for PostgreSQL. Make sure to install and enable PostGis in your database before upgrading to DHIS 2.30. Please consult the installation guide.
    Just in case is the same issue.

Cheers,

Alejandro

ยทยทยท

On Thu, Jul 26, 2018 at 12:53 PM, Allan Makunku amakunku@gmail.com wrote:

Dear All

I just upgraded my dhis2 instance from 2.29 to 2.30. However whenever I want to run analytics, I am getting the above error. Has anyone come
dhis.log

across this and what can I do to have it resolved. Attached is the log file

Please help.

Allan


Mailing list: https://launchpad.net/~dhis2-users

Post to : dhis2-users@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-users

More help : https://help.launchpad.net/ListHelp