Am failing to import GML file - DHIS2 2.36

Dear All, I have been trying to import GIS files to DHIS2 but to no avail. I have done everything possible to get this work but all my efforts seem to be in vain. Can somebody please help?

Hi @AllyMak did you check the projection (EPSG:4326) and the identifiers u are using to link DHIS2 to your shapefile, is it name, uid or code? I suggest u use code because for names sometimes you can find similar names.
Another this is that if you get the message complete, check in maps app if its not with boundaries layer.

1 Like

Hi Jean, I used EPSG:4326 as for the identifiers, I tried both the name and the UID but to no avail. Kindly clarify what you mean with regards to the maps app.

Thanks in advance.

Hi @AllyMak, I was recently struggling with this too despite it working smoothly in the past. Out of curiosity, which program did you use to create the .gml file? I noticed that the format used by Python and QGIS were not compatible with the DHIS2 importer requirements. Ultimately what worked for me was using the mygeodata converter.

Hopefully that helps!

1 Like

Hi Jordan, I will give it a try. Thanks

Hi Jordan,

Just to give feedback. I did manage to follow your advise and am glad to inform you that it worked.
Thank you.


Glad to hear it worked, @AllyMak.

1 Like