Always displays : Checking expression status

I am trying to enter program rule expression but i think it is stuck. It only displays: checking expression status.

Please can you give me solution to this. It displays the same even when its empty.

Hello @riwaj.amakomaya
Lets see how we can workout this one. Open console and or network to see whats preventing the "checking expression status to go away.

1 Like

This is the case in the console

Are you able to check why the program rule is responding with 500. I think its a permission issue. Verify the permissions, insure that the program rule you are trying to edit or required by your application have the correct permissions for the server to access and execute them. Do you have access the server side logs, this will help give a clear and concise error.

1 Like

@moses_mwale I have uploaded my file on DHIS 2 Demo - Sierra Leone

The TEA is Province , The option set is Pradesh and Option Group is Bagmati

Could you please check it?

Could you kindly check the internet quality, log out and then log in again, or try changing your browser?

The problem was incorrect declaration of variable.I have solved the issue and it works now.


@riwaj.amakomaya the Program Rule Variable that was incorrected declared, was it used in program rule expression ?

Hi @riwaj.amakomaya, I’m currently experiencing a similar issue. What did you mean by “The problem was incorrect declaration of variable”, and what was the solution?

@Joycee when we enter wrong expression or there is incorrect declaration of variable, it gets stuck. Another reason may be the software issue, if there is some issue on the program or the program is not functioning correctly. Mine was both, the program issue was there so it got stuck on the “Checking expression” when I entered wrong expression.


1 Like

I am having this issue too now on It is only for one tracker program and it means that I cannot edit existing rules or create new ones. It just says “checking expression” forever every time, even if the expression is blank or definitely valid. For all other tracker programs, when I create a new rule, it works fine (evaluates it as valid or invalid).

Anyone have any ideas why an entire tracker program might get stuck on program rules? Thanks!

Hi Natalie,

Did you check that all the program rules in the tracker program are valid and working?

My other question is if you tried using Guest mode in your browser ( Browse Chrome as a guest - Computer - Google Chrome Help) And also using a super user with ALL authority? Check if it’s still an issue when using both (Guest mode + ALL authority user), please report back. What issues do you see in the console and Network tab that are not happening when creating a program rule for the other programs?