After Dhis2 installation the default user : admin, district is not able to add new users

Good day all,
After successfully installed dhis2 on Linode server using the following guide: GitHub - dhis2/dhis2-server-tools: Tools to support installation and management of DHIS2, version 2.38.0, the default user is not able to add new users but the user is a superuser. see attached screenshot for the user

What am I missing, your help greatly appreciated
@Gassim @Quoda

Hi @arnold
If this is a fresh instance. you’ll by default have only the Superuser role. If you want to create new users, you may first have to define new roles (eg: for data entry) as you may not want to assign the Superuser role to just any user (since its a role with absolute privileges). After creating new roles, you can then create a new user with the ‘data entry’ role assigned to this new user.

Can you provide more information on what happens when you attempt to create a new user? That will be helpful. If possible share images/screenshot of what happens in an attempt to create a new user.


thanks @Quoda

After I created a new role data entry, I tried to add a new user still I am not able to save as the create user option is grayed out. See the attached photo, no error coming but the create user button is grayed out.

@arnold The save button is greyed out because you have not completed all the required fields.
You may not have completed required fields like Data capture and maintenance field, available user roles. Once you complete all required fields, the button should appear boldly.

1 Like

thank you @Quoda, it worked thank you, I didn’t have OU in the system, so the data capture and maintenance section was assigned to nothing.