2 Factor Authentication Issue

Hello Team,

I am using DHIS2 version: 2.39.3.1 and Once I try to activate or turn on two factor authentication the QR Code not showed up, and I do inspect I found the below URL for QR image but it could not be open: same happened once try use demo site on version 2.38.6: DHIS 2 Demo - Sierra Leone

QR Image source link


Could you please advise on this?

Note that my user now is blocked, and I can not access it due to turn it on at my account and at the same time I do not have take QR code to link it with google authenticator, and I have tried to to make my colleague to disable it from users app but unfortunately with no luck…

Thanks and regards,
Ayman

Hi @ayman.tuffaha

Thanks for the clearly written post. I am also facing the same issue; however, if you go to the dev instance (latest version) you will find that the whole process and UI has been upgraded and changed. You can read more about these changes here: [DHIS2-14555] - Jira

I will ask if this is going to be back ported or if people will need to upgrade to use this and then get back to you.

Thanks!

Thanks @Gassim,

It seems partially solved at dev env. as below:

  1. Using Google Authenticator is not working and shows an invalid 2FA Code message.
  2. Using Microsoft Authenticator is working perfectly as expected.

In both cases above I have successfully disabled the 2FA feature from the newly created user “Ayman”.

I understand it will be working fine with 2.42 and above right?

While I am stuck with my case any workaround to solve it at my existing version 2.39.3.1 will be much appreciated…

Kind regards,
Ayman

1 Like

Hi @ayman.tuffaha

Thank you for your post. Yes, this is a bug issue and it has been reported on Jira: [DHIS2-17428] - Jira