2.39/GeoJSON-Organization unit geometry import error

Hi, I’m trying to import the boundary my OU with the import app.
Not quite familiar with the process to be honest…here is my setup, and I cannot find any option like “catchment area” for the “Import as associated geometry”…
Not sure if there’s any error…Should I configure some GIS setup first?
I cannot start the dry run nor the import…


Hi @kateshih

The two options “match GeoJSON property” and the option to “import as associated geometry” are optional and you don’t need to select them

Hi @Gassim
Thanks for this tip (didn’t know they are optional)!
Yet…when I unticked them, the error still exists and prevents me from starting dry run :sweat_smile:
(I have tried my GeoJSON file on the Play instance and it worked…)

1 Like

Which version of play instance did you try? What is the complete version of the instance you are trying?

I tried the 2.39.2.1 Play and my instance is “2.39.3-SNAPSHOT” (using Ubuntu installation, not computer science background myself and trying to figure out release differences now :sweat_smile:)
However, I have again tried with:

  1. creating an attribute e.g. boundary for OU with value type GeoJSON as instructed in the Imported app here
  2. ticked both of them
    Fortunately, it worked!!! I found the attribute assigned here is needed for the map layer selection?
    (Just happy to dig around the DHIS2 as a new DHIS2 user and getting familiar with everything…)
1 Like

Thanks for sharing the info @kateshih!

Please revert back to the latest stable release as SNAPSHOT is not the stable release. Thanks!

1 Like

Got it! Will revert to a stable release!!!
Thanks so much!

1 Like

You’re welcome!

If you still face an issue in the stable release please share the steps to reproduce the issue so it’s possible to figure out what is causing the issue.

Please do update us on how it goes. Thanks!

Hi @Gassim,
In the stable release environment, it works as you said! Both are optional! Thanks for tips!!!

1 Like

Hi @kateshih

I’m following on posts, I’m wondering which post here provided you with the solution. Would you mark the post as solved?

Thank you!

1 Like

This problem seems to be on the DHIS2 2.40