Tomcat 8.5.50 or later will be required for DHIS 2.34

Hi all,

this is a heads-up that minimum required Tomcat version will be 8.5.50 for DHIS version 2.34.

The main reason for this change is Tomcat 7.0 and 8.0 having several issues with certain application development frameworks (most importantly Jackson, used for JSON and XML serialization) used internally by DHIS 2. As part of our effort to keep DHIS 2 secure, we continuously upgrade such frameworks to receive security fixes and this lead to an incompatibility with older Tomcat versions.

All supported DHIS 2 versions are well-tested with Tomcat 8.5 and so we recommend implementors to upgrade their Tomcat version at their earliest convenience.

best regards,

DHIS 2 dev team

7 Likes

Thank you very much for your update.

Best Regards

Fatema

1 Like

Thank you for the timely update

best regards,

Matthew

1 Like

Happy new year 2020.
Thank you for the information.

Regards,

1 Like

@Lars

Is the RelaxedQueryChars parameter in Tomcat’s server.xml configuration file still required for DHIS2, or is it no longer required?

Background: When the problem related to Tomcat no longer supporting the use of square brackets in queries initially popped up, you stated that using that parameter was a temporary measure until the core DHIS2 code had been updated accordingly.

Regards
Calle

3 Likes

Thank you

1 Like

thanks for this information,

warm regards

Amza

1 Like

Setting the RelaxedQueryChars attribute is still required, this change is not related. It will still take a while before we can upgrade all DHIS 2 web apps.

1 Like

Thank you so much for the latest update

1 Like

Thanks Lars

1 Like