Dataset - Not accessible to users

Hi all,

Checking if anyone has experienced this before - Recently migrated metadata from our development environment, version 2.34 to production version 2.36.7. Our users can not access datasets in the data entry app, yet we have the same exact settings as would be in version 2.36.7. At first thought, it was an issue to do with user groups and roles since the SysAdmins can access everything. However, I did note that when I took out the category combination (dimension - Attribute) from the affected datasets, then it becomes accessible to the users.

Wondering if there is an issue/bug with 2.36.7 specically with category combinations and datasets or am missing something.


1 Like

Strange, Are you getting any logs in catalina.out ?

You have the below last line relaxedQueryChars in server.xml right

<Connector port="8080" protocol="HTTP/1.1"
 relaxedQueryChars="[]" />


Thanks @mykbitz! We really need more info from the logs to find out what the issue is. I will try to give you a detailed approach to diagnose the issue from the browser.

Please try the following, choose a user, make sure that the category combinations as well as the categories are all with the sharing setting ‘can edit and view’ to this user (the orgunit should be assigned to this user too, of course). After that, please use the Browser App Cache cleaner , and using incognito login to this user’s account.

When you are there navigate to the data entry app, and before selecting the org unit open the Network tab in the browser’s developer tools (F12 → Network). Finally, while the Network tab is open, select the orgunit and if you see any red text, select it an take a screenshot. This response from the server will help us understand the issue. (And as @jthomas mentioned we might need to see if there are errors in the logs catalina.out)

Hope this helps us getting started! (: Thanks!


Thanks all for your responses

@jthomas Not getting anything useful from the logs, I have also made the modification on server.xml, but still won’t work.

@Gassim Please see attached screen shot

Please note:

  • The sharing settings in both categories and category combos are configured as needed - ‘can edit and view’
  • Everything works well when user is assigned super privileges/sysadmin role.


Hi @mykbitz,
It might help if we can see the other requests instead of the Wasm?

1 Like

Hello @Gassim this solution by @Stephan_Mestach fixed it!

Seems that whereas the categories and category combos were configured appropriately, I still needed to configure access for categoryoptions i.e “rwrw----”

Thanks all!


It’s great to know, thanks for sharing!

I would like to know please if the steps mentioned by @Calle_Hedberg didn’t work because this is supposed to work from the Maintenance app:

Thank you! (:

1 Like

@Gassim that’s how had done it, but for some ‘strange’ reason users still couldn’t access the tools. It’s happened on two separate instances of version 2.36.*. Not sure if it is a bug in 2.36, that fails to write the permissions correctly/or not reading permissions correctly. Eventually, the solution by @Stephan_Mestach fixed it.


1 Like