Yes/No values are dissapearing from the Event Capture and Analytics (2.15)

Hi all,

we are capturing Event Data using the Event Capture app. Everything seemed to be ok, but I noted that a few minutes later enetering the data, all yes/no values dissapear (also in the analytics) as showed in the following 2 images. Any ideas? We are using 2.15 (build revision 15123)Thanks

Image 1: Event app with Yes/No values

Image 2: Without yes/no values (few minutes later)

Hi Jose,

I will check into it. But it is a bit strange. Can you tell me more when you say “…I noted that a few minutes later entering the data, all yes/no values disappear (also in the analytics)…”?

Are you saying the data was there, saved … but then disappeared? Have you run any operation in between the appearance and disappearance of the data?

···

Thank you,

Abyot.

On Thu, Aug 28, 2014 at 9:45 AM, Jose Garcia Muñoz josemp10@gmail.com wrote:

Hi all,

we are capturing Event Data using the Event Capture app. Everything seemed to be ok, but I noted that a few minutes later enetering the data, all yes/no values dissapear (also in the analytics) as showed in the following 2 images. Any ideas? We are using 2.15 (build revision 15123)Thanks

Image 1: Event app with Yes/No values

Image 2: Without yes/no values (few minutes later)


Mailing list: https://launchpad.net/~dhis2-devs

Post to : dhis2-devs@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-devs

More help : https://help.launchpad.net/ListHelp

if you reload the event capture app (like 10 minutes later the data was entered) all Yes/No data are not listed in the table (as showed in the previous screen shot), instead you can only see a blank field (Although we previously introduced all the values). Also when we ran the analytics all Yes/No values are not there (pivots).

I think is a problem of the cache maybe? It seems that the data was not introduced in the database. I will try to replicate the problem in our development server and, as you have access (I think), you can take a look.

Many thanks

Jose

···

On Thu, Aug 28, 2014 at 10:56 AM, Abyot Gizaw abyota@gmail.com wrote:

Hi Jose,

I will check into it. But it is a bit strange. Can you tell me more when you say “…I noted that a few minutes later entering the data, all yes/no values disappear (also in the analytics)…”?

Are you saying the data was there, saved … but then disappeared? Have you run any operation in between the appearance and disappearance of the data?


Thank you,

Abyot.

On Thu, Aug 28, 2014 at 9:45 AM, Jose Garcia Muñoz josemp10@gmail.com wrote:

Hi all,

we are capturing Event Data using the Event Capture app. Everything seemed to be ok, but I noted that a few minutes later enetering the data, all yes/no values dissapear (also in the analytics) as showed in the following 2 images. Any ideas? We are using 2.15 (build revision 15123)Thanks

Image 1: Event app with Yes/No values

Image 2: Without yes/no values (few minutes later)


Mailing list: https://launchpad.net/~dhis2-devs

Post to : dhis2-devs@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-devs

More help : https://help.launchpad.net/ListHelp

Hi Jose,

It was bug. I just made a fix for both 2.15 and 2.16. Trunk will also be fixed.

···

Thank you,

Abyot.

On Thu, Aug 28, 2014 at 1:03 PM, Jose Garcia Muñoz josemp10@gmail.com wrote:

if you reload the event capture app (like 10 minutes later the data was entered) all Yes/No data are not listed in the table (as showed in the previous screen shot), instead you can only see a blank field (Although we previously introduced all the values). Also when we ran the analytics all Yes/No values are not there (pivots).

I think is a problem of the cache maybe? It seems that the data was not introduced in the database. I will try to replicate the problem in our development server and, as you have access (I think), you can take a look.

Many thanks

Jose

On Thu, Aug 28, 2014 at 10:56 AM, Abyot Gizaw abyota@gmail.com wrote:

Hi Jose,

I will check into it. But it is a bit strange. Can you tell me more when you say “…I noted that a few minutes later entering the data, all yes/no values disappear (also in the analytics)…”?

Are you saying the data was there, saved … but then disappeared? Have you run any operation in between the appearance and disappearance of the data?


Thank you,

Abyot.

On Thu, Aug 28, 2014 at 9:45 AM, Jose Garcia Muñoz josemp10@gmail.com wrote:

Hi all,

we are capturing Event Data using the Event Capture app. Everything seemed to be ok, but I noted that a few minutes later enetering the data, all yes/no values dissapear (also in the analytics) as showed in the following 2 images. Any ideas? We are using 2.15 (build revision 15123)Thanks

Image 1: Event app with Yes/No values

Image 2: Without yes/no values (few minutes later)


Mailing list: https://launchpad.net/~dhis2-devs

Post to : dhis2-devs@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-devs

More help : https://help.launchpad.net/ListHelp

Thanks Abyot

···

On Thu, Aug 28, 2014 at 1:37 PM, Abyot Gizaw abyota@gmail.com wrote:

Hi Jose,

It was bug. I just made a fix for both 2.15 and 2.16. Trunk will also be fixed.


Thank you,

Abyot.

On Thu, Aug 28, 2014 at 1:03 PM, Jose Garcia Muñoz josemp10@gmail.com wrote:

if you reload the event capture app (like 10 minutes later the data was entered) all Yes/No data are not listed in the table (as showed in the previous screen shot), instead you can only see a blank field (Although we previously introduced all the values). Also when we ran the analytics all Yes/No values are not there (pivots).

I think is a problem of the cache maybe? It seems that the data was not introduced in the database. I will try to replicate the problem in our development server and, as you have access (I think), you can take a look.

Many thanks

Jose

On Thu, Aug 28, 2014 at 10:56 AM, Abyot Gizaw abyota@gmail.com wrote:

Hi Jose,

I will check into it. But it is a bit strange. Can you tell me more when you say “…I noted that a few minutes later entering the data, all yes/no values disappear (also in the analytics)…”?

Are you saying the data was there, saved … but then disappeared? Have you run any operation in between the appearance and disappearance of the data?


Thank you,

Abyot.

On Thu, Aug 28, 2014 at 9:45 AM, Jose Garcia Muñoz josemp10@gmail.com wrote:

Hi all,

we are capturing Event Data using the Event Capture app. Everything seemed to be ok, but I noted that a few minutes later enetering the data, all yes/no values dissapear (also in the analytics) as showed in the following 2 images. Any ideas? We are using 2.15 (build revision 15123)Thanks

Image 1: Event app with Yes/No values

Image 2: Without yes/no values (few minutes later)


Mailing list: https://launchpad.net/~dhis2-devs

Post to : dhis2-devs@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-devs

More help : https://help.launchpad.net/ListHelp