Version upgrade from 28 to 29 problem with tracker: metadata is not loading

Dear All experts

We are upgrading to version 29 from 28 and facing some problem with Tracker/Event Capture which we are trying to resolve for last 2 days with no success. Earlier during test upgrade (last month) we have some issue with tracker but that was solved by removing new ‘TrackedEntityType’ created by the upgrade script.

Now we have that problem as well as as new one. During ‘alter table’ startup routine somehow ‘programstage_dataelements’ table was dropped. The result is metadata loading error and event capture and tracker capture are not loading at all. I tried from last two days with three different war files version and three data bases with same outcome. If we have alter table and create table scripts that might help us to locate the problem

In this instance we have tracker data as well as aggregated data and total size is 151 GB. Requesting immediate help.



Muhammad Abdul Hannan Khan

Team Leader

DHIS2 Support to the National HMIS

MIS, Directorate General of Health Services

Ministry of Health and Family Welfare

T +880-2- 58816459, 58816412 ext 118

F +88 02 58813 875

M+88 01819 239 241

M+88 01534 312 066


S hannan.khan.dhaka