URGENT HELP Needed: Server throws "Failed to fetch events from the server" error


All of a sudden our production server throws the below error, when we try open a TEI dashboard. And then it does not show any data:

Failed to fetch events from the server
No enum constant org.hisp.dhis.event.EventStatus.completed

When I tried CTRL+SHIFT+J (Chrome), I found the following error:

TypeError: Cannot read property ‘displayName’ of undefined

We are in the process of closing our quarterly data entry and now we are stuck. Any help to resolve this issue very quickly is really appreciated.


Hi @MSP, someone from @dhis2-platform will check it out and get back to you.

(@Stian / @Markus - would you know who is available today that can support @MSP? Thank you.)


Hi @MSP,

did you recently update your DHIS2 server version?

1 Like

No Mr. @Stian. We did not do anything. It was working fine until today morning our clients started complaining.

1 Like

Then there might be an issue with your data. Based on the messages you pasted here, it seems the event status is stored as “completed” in lower case, instead of “COMPLETED” in uppercase which is the default.

Could you verify for me whether this is the case or not? The solution would then be to update the rows containing “completed” with “COMPLETED”


Great. It worked like a charm.:grinning: Thank you very much :pray: