Unable to view/edit some records - tracker covid

We have an issue with Palestine tracker instance running covid-19 where in some cases we aren’t able to click to view/edit/update an existing record.

We were running version 2.33.3 and when we noticed the issue we upgraded to the newer patch 2.33.8 but we are still facing the same issue.

We thought it could be an issue with privileges; however, we tried the use-case with different user (standard and superadmin) but same result. The same users are able to view/edit/update other records even within the same org unit structure. At this point we’re not sure if its an issue with the record itself, a bug, a setting we missed, limit of days or something else.

This is the error we get:
{httpStatus: “Not Found”, httpStatusCode: 404, status: “ERROR”,…}

  1.    httpStatus: "Not Found"
  2.    httpStatusCode: 404
  3.    message: "The key 'igzVC0djJVn' was not found in the namespace 'trackerCaptureGridColumns'."
  4.    status: "ERROR"

Har File from dev tools result:
jquery-migrate.min.js:2 JQMIGRATE: Migrate is installed, version 3.0.0
index.js:26 Initializing Header Bar v28.0.3
logo_banner:1 Failed to load resource: the server responded with a status of 404 ()
dhis2.angular.directives.js:20 on outree
dhis2.angular.directives.js:31 Finished loading orgunit tree
tracker-capture.js?=c5442b13701c9ac6934b:142 Loading required meta-data
=c5442b13701c9ac6934b:256 in programs…
tracker-capture.js?_=c5442b13701c9ac6934b:172 Finished loading meta-data
/covid19prod/api/30/userDataStore/trackerCaptureGridColumns/igzVC0djJVn:1 Failed to load resource: the server responded with a status of 404 ()
DevTools failed to load SourceMap: Could not load content for https://hmis.moh.ps/covid19prod/dhis-web-core-resource/rxjs/4.1.0/rx.lite.map: HTTP error: status code 404, net::ERR_HTTP_RESPONSE_CODE_FAILURE
angular.js:9866 GET https://hmis.moh.ps/covid19prod/api/30/trackedEntityInstances/A5M3t89A1I1.json?program=igzVC0djJVn&fields=* 500
(anonymous) @ angular.js:9866
n @ angular.js:9667
f @ angular.js:9383
(anonymous) @ angular.js:13248
$eval @ angular.js:14466
$digest @ angular.js:14282
$apply @ angular.js:14571
(anonymous) @ angular.js:21571
dispatch @ jquery.js:5206
elemData.handle @ jquery.js:5014

We appreciate if you can help since we are unable to update records in the covid-19 surveillance system. Thank you.

Thank you
@hanin.saadah @mbaniode @ayman.tuffaha @ataallah @Marwa_Qadadha @Alaa.AbuAisheh

@Yousef thank you for your patience! Are you still facing this issue? Were you able to solve it? Thank you for sharing with the community!

I found a Jira issue similar to yours and the user was able to solve the issue, DHIS2-2931 | Tracker Capture app does not load correctly

First suggestion by @Markus in the Jira issue above:

And @hendrik found it useful to:

I recommend you check out the Jira issue, and please let me know if you still need further support. Thank you!