Tracker Access

HI Friends,

I wonder if this a known problem; I have configured a tracker program. Created a user role - with access to the tracker app. Added a user with tracker capturer privileges. When I test the user, I get the response I have screen grabbed below:

I have gone back to adjust the program stage access, and ensured that the user role and user are properly assigned. I have also cleared cache on the server. What could the problem be? I am running 2.35. Many thanks in advance for your help.


PS: I find that when I upgrade the user role to superuser the user then gets normal access to the full program. I do not want to give superuser access willy nilly, is this a known problem?

Hi @Jerome.S , thank you for your question! May I ask you to take screenshots for the authorities for the role you are giving the user; additionally, the sharing settings for the tracked entity type person. Thank you! (:

Hello Al-Gassim,

Please see below:
Sharing Permissions for Person Attribute

Tracker Capturer Role:

As I said before when I give the user role Superuser level access, they can see the full tracker program, many thanks for your help.

1 Like

Hello @Jerome.S , Did you check “Can capture and View” under “Data” in “Public access” ?

1 Like

Hey Mamadou Bonjour,

Can you describe this process in a little more detail please, Where do I find “Can capture and View” under “Data”?


1 Like

Bonjour :sunglasses:,

On your first screenshot (person tracker entity type sharing settings) you have Public access, click on the Pencil :pencil2: you will see METADATA and DATA section, under DATA section you have to check “Can capture and view”.

1 Like

Yes! Thank you so much @didate! I took a screenshot:

@Jerome.S thanks for the screenshots, and please mark as solved if it did. You can mark the post by @didate if it solved it :+1: Please let us know!

Hey Al-Gassim and Didate,

Many thanks for your support. So, activating the “can edit and view” enables my tracker user to register and enroll clients on the program, however, the tracker program that loads as default on the tracker is not the needed program, for some reason a program with NO PUBLIC ACCESS loads and is the only program that loads. I am still troubleshoot but will appreciate any other suggestions you might have (see screen grab)

You’re welcome! Would you check the sharing settings of the other programs as well?

Additionally, I would like to request from you to take a screenshot by first opening the Network tab in the Console (F12) and then loading the app to see the programs - are there any errors? Please take a screenshot!

Would it be possible to reproduce this in the version 2.35.6? (Maybe consider updating your 2.35.*?) Thanks!