Title of Data Set Report not appear (Downlaod as XLS)

Hello colleagues,

I attempted to download the report dataset as an XLS file, but unfortunately, the title is displaying as “ span> strong>”. Could someone please assist me in resolving this issue? Your prompt attention to this matter would be greatly appreciated.

Thank you.

Hi @sami.oracle10g

Is the dataset using a custom design? If yes then please use basic HTML for the report to appear properly. For example, instead of <strong> use <b> and if this change removes “strong” from the report, keep on modifying the template until it appears properly.

Hope it works! Please feel free to post with an update on how it goes.


Dear @Gassim,

I didn’t start with your suggested solution because new problems have appeared. When I tried to download it, there was a message that appeared saying, “datasetReport.json couldn’t download - something went wrong. Please try again or contact your organization.”

Best regards,

In addition, I have tried to apply your solution, but unfortunately, it was unsuccessful. Please see the attached photo.
NB: I replaced all “strong” words with “b”. Is it right or you meant something different?

1 Like

Apologies for the delay. Would you please share the HTML code so we might find out if there’s something breaking it?

Thank you! :slight_smile:

An error occurred: Body is limited to 32000 characters; you entered 62091.

Please give me your email to send it or any appropriate method you prefer.

Alright, thanks! Please send it as PM here

sent please check it.

1 Like

Thanks! I am able to reproduce the issue by adding Arabic text to a simple table without any additional HTML. Just changing an English text to Arabic in a table that prints as PDF well when the text in English, but the Arabic text doesn’t appear:

Would you like to create a jira bug issue in Projects - Jira using your account with steps to reproduce the issue?

The code for the table above is:

<table align="left" border="1" cellpadding="1" cellspacing="1" dir="rtl" lang="ar" style="width:500px;" summary="Summary">
			<th scope="row">Heading</th>
			<th scope="col">Heading</th>
			<th lang="ar" scope="row">متوقع</th>
			<td><input id="h0xKKjijTdI-HllvX50cXC0-val" name="entryfield" title="Expected pregnancies" value="[ Expected pregnancies ]" /></td>
			<th lang="ar" scope="row">نسبة</th>
			<td><input id="vg6pdjObxsm-HllvX50cXC0-val" name="entryfield" title="Population of women of child bearing age (WRA)" value="[ Population of women of child bearing age (WRA) ]" /></td>
			<th lang="ar" scope="row">اجمالي</th>
			<td><input id="WUg3MYWQ7pt-HllvX50cXC0-val" name="entryfield" title="Total Population" value="[ Total Population ]" /></td>
			<th lang="ar" scope="row">اجمالي اقل من سنة</th>
			<td><input id="DTVRnCGamkV-HllvX50cXC0-val" name="entryfield" title="Total population &lt; 1 year" value="[ Total population &lt; 1 year ]" /></td>
			<th lang="ar" scope="row">اجمالي اقل من خمس سنين</th>
			<td><input id="DTtCy7Nx5jH-HllvX50cXC0-val" name="entryfield" title="Total population &lt; 5 years" value="[ Total population &lt; 5 years ]" /></td>

You can see I was trying to add lang="ar" but that didn’t work either.

If you create the bug issue, please share it here so it’s easily found by other community members.