(some) indicators in custom forms not working

Hello,
experiencing some trouble with indicators in custom forms. There are two datasets where the indicators have suddenly stopped working/become inactive (in one form, none are working, in the other the first 10 or so are working while the rest does not work).

So far, I have tried
- adding and removing some of the indicators in the custom form editor
- removed all indicators from the dataset, saved, then added them back
- using different browsers (after deleting cache/history) and different servers
- editing some of the indicators that is not working
- looked in the custom forms source code to see if there is anything there that could indicate why some are working and others are not
- checked that the indicator id's in the form code are the same as those in the database
- deleted the hibernate cache

Also tried a database dump from a few days back, and everything is working there. Since then, we have been deleting and editing some indicator groups, but not any indicators. Even tried copying the custom form source code back from the backup, but the same problem persist.

Any good ideas for what I can try?

Thanks
Olav