*Solved* Issue with installing custom applications

I came across a head scratcher when using the app management app to install a custom application. I managed to resolve it so decided to post here for others’ benefit.

The process seems to work and it says the app was installed, though it reported an error with the icon…
…but the app 404s when I try access it from the app menu.

Also, while in the app management app, I noted that it reported there was an update for the app management app itself, so I decided to try installing that update, but that then broke the app management app itself. Whenever I try access it, I get a 404. I tried deploying an updated WAR file ( but still the app management app is 404’ing.

I see the filestore.container setting in the config file points to a directory under config on my system: /home/dhis/config/files
All files and directories there appear to be intact and have the correct rights. I decided to try changing that setting to a relative value instead, so instead of:
filestore.container = /home/dhis/config/files
I now have:
filestore.container = files

After a server restart, that solved it.

1 Like

Resolution is in the opening post