Program Rules not Work on first Stage on Android App

Hi All,

I am implementing a DHIS2 Tracker for a Case Based Malaria program.
I have set two stages but i realize that program rules applied on the first stage are not working.
The message “Adjusting” form is shown when we start entering data.
@jaime.bosque we have already talk about it last week in Accra.

Note: I am running on 2.29 Version


1 Like

Dear @amadoungone12

Thanks for sharing this, can you share what the rule is intended to do? Also try to turn it off and see if thats the cause of not loading, adjusting the form is loading the form and executing the rules.

Also check on sharing setting of the stage


Hi @amadoungone12.

Is there a chance you could create a testing account in the server and share the details with me in private? This message usually comes with a misconfiguration on the program rules.

Also note that 2.29 is not supported and in case you have not implemented yet it might be a good idea to upgrade first your version of DHIS 2.

Let me know. Cheers!

Dear @prosper Thank you for your quick response.
We have about 20 program rules for this stage we tried to use it on by one with different scenarios but still.
This happened in all our programs now we use the alternative to have the first stage without Program rules.
We checked the sharing setting as well.

Hi @jaime.bosque Thank you.
I will do it asap.


Thank you @jaime.bosque
The issue is now solved.

1 Like