Problem with user account creation.

I have a number of steps in the bug, so I am putting in here on the list with screen shots (which don’t work so well on launchpad).

Scenario: Create a new user.

Steps to reproduce:

  1. On the demo server, login as “admin/district” (R21919, 2.22)

  2. Go to user management and add a new user. Here is the one I added. image

Users last name and first name were specified as “John Doe”.

Note I am logged in as “admin” still.

When I check the newly created user in the next dialog, I see the following

image

Seems strange, since the Surname and Firstname do not appear.

  1. Log out and log back in as the user you created, in this case “admin3”. Go to profile

image

You will now see that the Firstname and Last name are the user which created the user, but not the user themselves.

  1. If I exit this dialog, and load it again, I see this

image

which now gives me the “Full name” instead of the blank surname and first name.

Not sure if this is a bug, but seems a bit weird.

​Regards,

Jason

···

Jason P. Pickering
email: jason.p.pickering@gmail.com
tel:+46764147049

Yes, I observed the same behaviour. Any thoughts on this?

image

···

On Wed, Mar 16, 2016 at 4:27 PM, Jason Pickering jason.p.pickering@gmail.com wrote:

I have a number of steps in the bug, so I am putting in here on the list with screen shots (which don’t work so well on launchpad).

Scenario: Create a new user.

Steps to reproduce:

  1. On the demo server, login as “admin/district” (R21919, 2.22)
  1. Go to user management and add a new user. Here is the one I added.

Users last name and first name were specified as “John Doe”.

Note I am logged in as “admin” still.

When I check the newly created user in the next dialog, I see the following

Seems strange, since the Surname and Firstname do not appear.

  1. Log out and log back in as the user you created, in this case “admin3”. Go to profile

You will now see that the Firstname and Last name are the user which created the user, but not the user themselves.

  1. If I exit this dialog, and load it again, I see this

which now gives me the “Full name” instead of the blank surname and first name.

Not sure if this is a bug, but seems a bit weird.

​Regards,

Jason


Jason P. Pickering
email: jason.p.pickering@gmail.com
tel:+46764147049


Mailing list: https://launchpad.net/~dhis2-devs

Post to : dhis2-devs@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-devs

More help : https://help.launchpad.net/ListHelp

Archana Chillala
Application Developer
Email
archanac@thoughtworks.com
Telephone
+91 9100960533
ThoughtWorks