problem with to upgrade from Dhis 2.10 to 2.11

Hi,

We upgrade from Dhis 2.10 to the version 2.11, but to sign in displays an error that can not continue, in a second attempt display other error related with a column organisati1_.uuid.

I should clarify that my partner marko previously reported the drawbacks to upgrade from version 2.10 to 2.12 and he was recommended upgrade to version 2.11 first.

attached screen print.

Helder Castrillon

Secretaria Departamental de Salud del Cauca

Colombia.

image

image

···


@Heldersoft

Hello Helder,

can you please check in your hibernate.properties file that this line is present without any blank spaces at the end?

hibernate.hbm2ddl.auto = update

Also, can you please provide us with some more information, like

Also, can you check that your database user has permissions to create tables in your database? Just make your database user a superuser for debugging porposes and try again.

regards,

Lars

···

On Wed, Jun 19, 2013 at 12:23 AM, Helder Yesid Castrillon Cobo heldersoft@gmail.com wrote:

Hi,

We upgrade from Dhis 2.10 to the version 2.11, but to sign in displays an error that can not continue, in a second attempt display other error related with a column organisati1_.uuid.

I should clarify that my partner marko previously reported the drawbacks to upgrade from version 2.10 to 2.12 and he was recommended upgrade to version 2.11 first.

attached screen print.

Helder Castrillon

Secretaria Departamental de Salud del Cauca

Colombia.


@Heldersoft


Mailing list: https://launchpad.net/~dhis2-users

Post to : dhis2-users@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-users

More help : https://help.launchpad.net/ListHelp

Hello Helder,

in version 2.12 there is no need to run data mart anymore.

Instead you should run the analytics tables. You can do this ad-hoc from the reports module, and schedule it to run automatically at night from data administration module → scheduling. Make sure you have full rights (ALL).

The difference between the data mart and the analytics tables is that the former is a pre-aggregated data table while the latter are denormalized data tables which are used as basis for on-the-fly aggregation.

Lars

···

On Wed, Jul 24, 2013 at 1:00 AM, Helder Yesid Castrillon Cobo heldersoft@gmail.com wrote:

Hi,

We have upgraded from dhis 2.10 to 2.11 and 2.12, the problem was caused by a duplicate key error, which we solved with help of Knut ( to see https://lists.launchpad.net/dhis2-users/msg02468.html).

Now we have another problem in version 2.12, after that we upgrade does not show all information in SIG and data visualizer, even so to try again after exporting to datamart.

this problem we will report in another post, more detailed.

regards.

Helder and Marko.

Secretaria departamental de salud del cauca.

Colombia.

2013/6/19 Lars Helge Øverland larshelge@gmail.com

Hello Helder,

can you please check in your hibernate.properties file that this line is present without any blank spaces at the end?

hibernate.hbm2ddl.auto = update

Also, can you please provide us with some more information, like

  • what you are doing when this error happens
  • output of your tomcat log

Also, can you check that your database user has permissions to create tables in your database? Just make your database user a superuser for debugging porposes and try again.

regards,

Lars


@Heldersoft

On Wed, Jun 19, 2013 at 12:23 AM, Helder Yesid Castrillon Cobo heldersoft@gmail.com wrote:

Hi,

We upgrade from Dhis 2.10 to the version 2.11, but to sign in displays an error that can not continue, in a second attempt display other error related with a column organisati1_.uuid.

I should clarify that my partner marko previously reported the drawbacks to upgrade from version 2.10 to 2.12 and he was recommended upgrade to version 2.11 first.

attached screen print.

Helder Castrillon

Secretaria Departamental de Salud del Cauca

Colombia.


@Heldersoft


Mailing list: https://launchpad.net/~dhis2-users

Post to : dhis2-users@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-users

More help : https://help.launchpad.net/ListHelp

Well, then I only should run analytics tables.

I could to solve the problem (https://lists.launchpad.net/dhis2-users/msg02671.html), But now I have one doubt. If not necessary to run datamart then why it appears even?, when should I run datamart? and why analytics tables and datamart has been separated.

Thanks.

···

2013/7/24 Lars Helge Øverland larshelge@gmail.com

Hello Helder,

in version 2.12 there is no need to run data mart anymore.

Instead you should run the analytics tables. You can do this ad-hoc from the reports module, and schedule it to run automatically at night from data administration module → scheduling. Make sure you have full rights (ALL).

The difference between the data mart and the analytics tables is that the former is a pre-aggregated data table while the latter are denormalized data tables which are used as basis for on-the-fly aggregation.

Lars


@Heldersoft

On Wed, Jul 24, 2013 at 1:00 AM, Helder Yesid Castrillon Cobo heldersoft@gmail.com wrote:

Hi,

We have upgraded from dhis 2.10 to 2.11 and 2.12, the problem was caused by a duplicate key error, which we solved with help of Knut ( to see https://lists.launchpad.net/dhis2-users/msg02468.html).

Now we have another problem in version 2.12, after that we upgrade does not show all information in SIG and data visualizer, even so to try again after exporting to datamart.

this problem we will report in another post, more detailed.

regards.

Helder and Marko.

Secretaria departamental de salud del cauca.

Colombia.

2013/6/19 Lars Helge Øverland larshelge@gmail.com

Hello Helder,

can you please check in your hibernate.properties file that this line is present without any blank spaces at the end?

hibernate.hbm2ddl.auto = update

Also, can you please provide us with some more information, like

  • what you are doing when this error happens
  • output of your tomcat log

Also, can you check that your database user has permissions to create tables in your database? Just make your database user a superuser for debugging porposes and try again.

regards,

Lars


@Heldersoft

On Wed, Jun 19, 2013 at 12:23 AM, Helder Yesid Castrillon Cobo heldersoft@gmail.com wrote:

Hi,

We upgrade from Dhis 2.10 to the version 2.11, but to sign in displays an error that can not continue, in a second attempt display other error related with a column organisati1_.uuid.

I should clarify that my partner marko previously reported the drawbacks to upgrade from version 2.10 to 2.12 and he was recommended upgrade to version 2.11 first.

attached screen print.

Helder Castrillon

Secretaria Departamental de Salud del Cauca

Colombia.


@Heldersoft


Mailing list: https://launchpad.net/~dhis2-users

Post to : dhis2-users@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-users

More help : https://help.launchpad.net/ListHelp

We have kept the data mart since there are a lot of SQL-based reports out there which are linked to the data mart tables - we don’t want to make upgrading dhis version to be a big hassle. Data mart tables can also be more convenient to query directly than analytics tables so they can be used if you prefer it. But as said, they are not required by dhis anymore.

···

On Wed, Jul 24, 2013 at 3:25 PM, Helder Yesid Castrillon Cobo heldersoft@gmail.com wrote:

Well, then I only should run analytics tables.

I could to solve the problem (https://lists.launchpad.net/dhis2-users/msg02671.html), But now I have one doubt. If not necessary to run datamart then why it appears even?, when should I run datamart? and why analytics tables and datamart has been separated.

Thanks.

2013/7/24 Lars Helge Øverland larshelge@gmail.com

Hello Helder,

in version 2.12 there is no need to run data mart anymore.

Instead you should run the analytics tables. You can do this ad-hoc from the reports module, and schedule it to run automatically at night from data administration module → scheduling. Make sure you have full rights (ALL).

The difference between the data mart and the analytics tables is that the former is a pre-aggregated data table while the latter are denormalized data tables which are used as basis for on-the-fly aggregation.

Lars


@Heldersoft

On Wed, Jul 24, 2013 at 1:00 AM, Helder Yesid Castrillon Cobo heldersoft@gmail.com wrote:

Hi,

We have upgraded from dhis 2.10 to 2.11 and 2.12, the problem was caused by a duplicate key error, which we solved with help of Knut ( to see https://lists.launchpad.net/dhis2-users/msg02468.html).

Now we have another problem in version 2.12, after that we upgrade does not show all information in SIG and data visualizer, even so to try again after exporting to datamart.

this problem we will report in another post, more detailed.

regards.

Helder and Marko.

Secretaria departamental de salud del cauca.

Colombia.

2013/6/19 Lars Helge Øverland larshelge@gmail.com

Hello Helder,

can you please check in your hibernate.properties file that this line is present without any blank spaces at the end?

hibernate.hbm2ddl.auto = update

Also, can you please provide us with some more information, like

  • what you are doing when this error happens
  • output of your tomcat log

Also, can you check that your database user has permissions to create tables in your database? Just make your database user a superuser for debugging porposes and try again.

regards,

Lars


@Heldersoft

On Wed, Jun 19, 2013 at 12:23 AM, Helder Yesid Castrillon Cobo heldersoft@gmail.com wrote:

Hi,

We upgrade from Dhis 2.10 to the version 2.11, but to sign in displays an error that can not continue, in a second attempt display other error related with a column organisati1_.uuid.

I should clarify that my partner marko previously reported the drawbacks to upgrade from version 2.10 to 2.12 and he was recommended upgrade to version 2.11 first.

attached screen print.

Helder Castrillon

Secretaria Departamental de Salud del Cauca

Colombia.


@Heldersoft


Mailing list: https://launchpad.net/~dhis2-users

Post to : dhis2-users@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-users

More help : https://help.launchpad.net/ListHelp

well, we currently haven’t SQL-based reports, thanks for clearing my doubts.

···

2013/7/25 Lars Helge Øverland larshelge@gmail.com

We have kept the data mart since there are a lot of SQL-based reports out there which are linked to the data mart tables - we don’t want to make upgrading dhis version to be a big hassle. Data mart tables can also be more convenient to query directly than analytics tables so they can be used if you prefer it. But as said, they are not required by dhis anymore.


@Heldersoft

On Wed, Jul 24, 2013 at 3:25 PM, Helder Yesid Castrillon Cobo heldersoft@gmail.com wrote:

Well, then I only should run analytics tables.

I could to solve the problem (https://lists.launchpad.net/dhis2-users/msg02671.html), But now I have one doubt. If not necessary to run datamart then why it appears even?, when should I run datamart? and why analytics tables and datamart has been separated.

Thanks.

2013/7/24 Lars Helge Øverland larshelge@gmail.com

Hello Helder,

in version 2.12 there is no need to run data mart anymore.

Instead you should run the analytics tables. You can do this ad-hoc from the reports module, and schedule it to run automatically at night from data administration module → scheduling. Make sure you have full rights (ALL).

The difference between the data mart and the analytics tables is that the former is a pre-aggregated data table while the latter are denormalized data tables which are used as basis for on-the-fly aggregation.

Lars


@Heldersoft

On Wed, Jul 24, 2013 at 1:00 AM, Helder Yesid Castrillon Cobo heldersoft@gmail.com wrote:

Hi,

We have upgraded from dhis 2.10 to 2.11 and 2.12, the problem was caused by a duplicate key error, which we solved with help of Knut ( to see https://lists.launchpad.net/dhis2-users/msg02468.html).

Now we have another problem in version 2.12, after that we upgrade does not show all information in SIG and data visualizer, even so to try again after exporting to datamart.

this problem we will report in another post, more detailed.

regards.

Helder and Marko.

Secretaria departamental de salud del cauca.

Colombia.

2013/6/19 Lars Helge Øverland larshelge@gmail.com

Hello Helder,

can you please check in your hibernate.properties file that this line is present without any blank spaces at the end?

hibernate.hbm2ddl.auto = update

Also, can you please provide us with some more information, like

  • what you are doing when this error happens
  • output of your tomcat log

Also, can you check that your database user has permissions to create tables in your database? Just make your database user a superuser for debugging porposes and try again.

regards,

Lars


@Heldersoft

On Wed, Jun 19, 2013 at 12:23 AM, Helder Yesid Castrillon Cobo heldersoft@gmail.com wrote:

Hi,

We upgrade from Dhis 2.10 to the version 2.11, but to sign in displays an error that can not continue, in a second attempt display other error related with a column organisati1_.uuid.

I should clarify that my partner marko previously reported the drawbacks to upgrade from version 2.10 to 2.12 and he was recommended upgrade to version 2.11 first.

attached screen print.

Helder Castrillon

Secretaria Departamental de Salud del Cauca

Colombia.


@Heldersoft


Mailing list: https://launchpad.net/~dhis2-users

Post to : dhis2-users@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-users

More help : https://help.launchpad.net/ListHelp