PostgreSQL version 9.6 required for DHIS version 2.31


(Lars Øverland) #1

Heads up: for DHIS 2 version 2.31 we will require PostgreSQL version 9.6 or higher.

This is in order to take advantage of certain SQL features introduced in that version. The current required version is 9.4.

If you plan to upgrade your PostgreSQL version we recommend going straight to version 10, as it contains several great features and performance improvements. Also, we will eventually require this version and so going directly to version 10 will avoid multiple successive upgrades.


postgresql version 9.6 required for dhis version 2.31
(Stephen Ocaya) #2

Thanks Lars.

Just to be clear, Is that the minimum requirements for PostgreSQL?

···

Lars Helge Øverland

Technical lead, DHIS 2

University of Oslo

lars@dhis2.org

https://www.dhis2.org


(Calle Hedberg) #3

Lars,

With postgresql version 11 out - are there any specific reasons for NOT using pg 11? Many of the key features introduced in 10 - like table partitioning - have been further enhanced in 11.

Regards

Calle

···

Calle Hedberg

46D Alma Road, 7700 Rosebank, SOUTH AFRICA

Tel/fax (home): +27-21-685-6472

Cell: +27-82-853-5352

Iridium SatPhone: +8816-315-19119

Email: calle.hedberg@gmail.com

Skype: calle_hedberg



(Calle Hedberg) #4

Hi,

With regard to minimum pg requirements: Bjorn, what is the minimum version requirement for Postgis, and what is the recommended version? Again, postGIS 2.5 was released recently, so if people need to upgrade anyhow it makes sense to upgrade to the latest, tested version…

Regards

Calle

···

Calle Hedberg

46D Alma Road, 7700 Rosebank, SOUTH AFRICA

Tel/fax (home): +27-21-685-6472

Cell: +27-82-853-5352

Iridium SatPhone: +8816-315-19119

Email: calle.hedberg@gmail.com

Skype: calle_hedberg



(Bjørn Sandvik) #5

Hi,

PostGIS requirement is 2.2 or later.

AFAIK, this will still be the case for 2.31.

Regards,

Bjørn

···

Bjørn Sandvik

GIS developer, DHIS 2

University of Oslo

www.dhis2.org

Bjørn Sandvik

GIS developer, DHIS 2

University of Oslo

www.dhis2.org


(moses mwale) #6

Sorry just to interject, so dhis2 does not work with Postgres 9.5?

···

developer_lusaka_systems


(Lars Øverland) #7

Lars,

With postgresql version 11 out - are there any specific reasons for NOT using pg 11? Many of the key features introduced in 10 - like table partitioning - have been further enhanced in 11.

No reason that I am aware of and it will likely work fine.

The reason for recommending 10 is that DHIS 2 is well tested on that version as the developers are using it and I am aware of many prod installations using it.

regards,

Lars

···

Lars Helge Øverland

Technical lead, DHIS 2

University of Oslo

lars@dhis2.org

https://www.dhis2.org


(Lars Øverland) #8

Thanks Lars.

Just to be clear, Is that the minimum requirements for PostgreSQL?

Correct. Version 9.6 or higher.

regards,

Lars

···

Lars Helge Øverland

Technical lead, DHIS 2

University of Oslo

lars@dhis2.org

https://www.dhis2.org


(Lars Øverland) #9

Sorry just to interject, so dhis2 does not work with Postgres 9.5?

PostgreSQL 9.5 will work up to DHIS 2 version 2.30.

For DHIS 2.31 you will need PostgreSQL 9.6 or higher.

regards,

Lars

···

Lars Helge Øverland

Technical lead, DHIS 2

University of Oslo

lars@dhis2.org

https://www.dhis2.org


(Bob Jolliffe) #10

Version 2.31 will not

···

On Wed, 31 Oct 2018, 09:00 moses mwale, isoftcom.ic@gmail.com wrote:

Sorry just to interject, so dhis2 does not work with Postgres 9.5?

On Wed, 31 Oct 2018 at 9:58 AM, Bjørn Sandvik bjorn@dhis2.org wrote:

Hi,

PostGIS requirement is 2.2 or later.

AFAIK, this will still be the case for 2.31.

Regards,

Bjørn


Bjørn Sandvik

GIS developer, DHIS 2

University of Oslo

www.dhis2.org

On Wed, Oct 31, 2018 at 8:18 AM Calle Hedberg calle.hedberg@gmail.com wrote:

Hi,

With regard to minimum pg requirements: Bjorn, what is the minimum version requirement for Postgis, and what is the recommended version? Again, postGIS 2.5 was released recently, so if people need to upgrade anyhow it makes sense to upgrade to the latest, tested version…

Regards

Calle

On Wed, 31 Oct 2018 at 09:15, Calle Hedberg calle.hedberg@gmail.com wrote:

Lars,

With postgresql version 11 out - are there any specific reasons for NOT using pg 11? Many of the key features introduced in 10 - like table partitioning - have been further enhanced in 11.

Regards

Calle

On Wed, 31 Oct 2018 at 08:04, stephocay@gmail.com stephocay@gmail.com wrote:

Thanks Lars.

Just to be clear, Is that the minimum requirements for PostgreSQL?

Sent from my HTC

----- Reply message -----
From: “Lars Helge Øverland” lars@dhis2.org
To: “DHIS 2 Users list” dhis2-users@lists.launchpad.net, “DHIS 2 Developers list” dhis2-devs@lists.launchpad.net
Subject: [Dhis2-users] postgresql version 9.6 required for dhis version 2.31
Date: Tue, Oct 30, 2018 23:33

Hi all,

heads up: for DHIS 2 version 2.31 we will require PostgreSQL version 9.6.

This is in order to take advantage of certain SQL features introduced in that version. The current required version is 9.4.

If you plan to upgrade your PostgreSQL version we recommend going straight to version 10, as it contains several great features and performance improvements. Also, we will eventually require this version and so going directly to version 10 will avoid multiple successive upgrades.

best regards,

Lars

Lars Helge Øverland

Technical lead, DHIS 2

University of Oslo

lars@dhis2.org

https://www.dhis2.org


Mailing list: https://launchpad.net/~dhis2-devs

Post to : dhis2-devs@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-devs

More help : https://help.launchpad.net/ListHelp


Calle Hedberg

46D Alma Road, 7700 Rosebank, SOUTH AFRICA

Tel/fax (home): +27-21-685-6472

Cell: +27-82-853-5352

Iridium SatPhone: +8816-315-19119

Email: calle.hedberg@gmail.com

Skype: calle_hedberg



Calle Hedberg

46D Alma Road, 7700 Rosebank, SOUTH AFRICA

Tel/fax (home): +27-21-685-6472

Cell: +27-82-853-5352

Iridium SatPhone: +8816-315-19119

Email: calle.hedberg@gmail.com

Skype: calle_hedberg



Bjørn Sandvik

GIS developer, DHIS 2

University of Oslo

www.dhis2.org


Mailing list: https://launchpad.net/~dhis2-devs

Post to : dhis2-devs@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-devs

More help : https://help.launchpad.net/ListHelp


developer_lusaka_systems


Mailing list: https://launchpad.net/~dhis2-devs

Post to : dhis2-devs@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-devs

More help : https://help.launchpad.net/ListHelp


(Adedayo Adeyomoye) #11

Beautiful.

Many thanks for sharing.

Kindest regards,

Adedayo

Untitled (242 Bytes)

···

Sent from Yahoo Mail on Android

On Tue, 30 Oct 2018 at 22:34, Lars Helge Øverland > lars@dhis2.org wrote:

Hi all,

heads up: for DHIS 2 version 2.31 we will require PostgreSQL version 9.6.

This is in order to take advantage of certain SQL features introduced in that version. The current required version is 9.4.

If you plan to upgrade your PostgreSQL version we recommend going straight to version 10, as it contains several great features and performance improvements. Also, we will eventually require this version and so going directly to version 10 will avoid multiple successive upgrades.

best regards,

Lars

Lars Helge Øverland

Technical lead, DHIS 2

University of Oslo

lars@dhis2.org

https://www.dhis2.org


Mailing list: https://launchpad.net/~dhis2-users
Post to : dhis2-users@lists.launchpad.net
Unsubscribe : https://launchpad.net/~dhis2-users
More help : https://help.launchpad.net/ListHelp