Performance and data issues deploying 2.33 to windows

Hello, We are new to DHIS2 and just starting to explore. We have played with demo on the play.dhis2 site with Siera Leone demo data. However, we are having issues deploying and setting up same in our environment to be able to explore more.

We downloaded the latest 2.33 package and sample database from DHIS2 download and deployed as per the instructions for the windows installation instructions (http://dhis-2.blogspot.com/2015/06/dhis2-local-installation-guide-for.html). Installation includes latest version of Java 8 JRE, Tomcat 7 and PostgreSQL 12. Our system environment specification is exceeds the server specification in DHIS2 implementation guide. Server has 16GB memory and 4-core CPU. Only one user is accessing the deployed site for the verification.

Although initial startup, login page comes up fine. But loading the dashboard after login as well as launching apps (data visualizer, data administration, pivot table, etc.) take significant amount of time (sometimes over a minute) to come up. It often hangs and requires restarting the service (Tomcat).
Also the dashboards show “No Data” because analytics tables are not loaded. So running “Generate Analytics Tables” from Data Administration app never completes after running for hours.

We also tried going back to some earlier versions (2.30 and 2.28). 2.30 had the same performance issue. 2.28 works lot better but cannot find a way to generate analytics tables since there is no Analytics option under the Reports app as described here: https://docs.dhis2.org/2.28/en/user/html/generate_analytics_tables.html

We have tried few combinations of JAVA_OPTS to increase memory but that hasn’t helped resolve the issue. Also tried deploying to a standalone laptop with adquate specification but having the same issue.

It will be great if someone can point to any blog/guidance regarding addressing these issues so we can move forward. Thanks.

1 Like

Please disregard. It was issue with Tomcat configuration since it was using default memory settings and not from JAVA_OPTS that I was setting. Changed the Tomcat configuration directly to increase memory and that solved all performance issues with 2.33.

I am still not sure why there wasn’t any option to update Analytics Tables in 2.28 but no need to go back to that version now. Thanks.

1 Like