Password not working when creating Users through API

Dear Devs,

We made several users by Posting to “…/api/Users” endpooint.

Eg payload-

{“firstName”:“harsh”,“surname”:“harsh”,“email”:“harsh”,
“userCredentials”: {“username”:“harsh”,“password”:“harsh”,“userRoles”:[{“id”:“yrB6vc5Ip3r”}]},

“organisationUnits”:[{“id”:“WBFNadSm5EQ”}],“userGroups”:[]}

The users were created all right but the given password didn’t work. So we had to change the password through application…

Is there something we missed when creating user through API? Please help.

DHIS2 version - 2.23

Thank You

harsh

Hi Harsh

Try with a valid password, something like Harsh123

···

On Thu, Aug 18, 2016 at 10:41 AM, Harsh Atal harsh.atal@gmail.com wrote:

Dear Devs,

We made several users by Posting to “…/api/Users” endpooint.

Eg payload-

“userCredentials”: {“username”:“harsh”,“password”:“harsh”,“userRoles”:[{“id”:“yrB6vc5Ip3r”}]},

“organisationUnits”:[{“id”:“WBFNadSm5EQ”}],“userGroups”:[]}

The users were created all right but the given password didn’t work. So we had to change the password through application…

Is there something we missed when creating user through API? Please help.

DHIS2 version - 2.23

Thank You

harsh

{“firstName”:“harsh”,“surname”:“harsh”,“email”:“harsh”,


Mailing list: https://launchpad.net/~dhis2-devs

Post to : dhis2-devs@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-devs

More help : https://help.launchpad.net/ListHelp

Morten Olav Hansen

Senior Engineer, DHIS 2

University of Oslo

http://www.dhis2.org

Hi Morten

Tried with a valid password(District1234), same issue. Password doesn’t work, everything else is created fine.

Version:
2.23
Build revision:
23016
Build date:
2016-06-20 17:48

Could it be a bug?

Regards

harsh

···

On 18 August 2016 at 14:17, Morten Olav Hansen morten@dhis2.org wrote:

Hi Harsh

Try with a valid password, something like Harsh123

Morten Olav Hansen

Senior Engineer, DHIS 2

University of Oslo

http://www.dhis2.org

On Thu, Aug 18, 2016 at 10:41 AM, Harsh Atal harsh.atal@gmail.com wrote:

Dear Devs,

We made several users by Posting to “…/api/Users” endpooint.

Eg payload-

“userCredentials”: {“username”:“harsh”,“password”:“harsh”,“userRoles”:[{“id”:“yrB6vc5Ip3r”}]},

“organisationUnits”:[{“id”:“WBFNadSm5EQ”}],“userGroups”:[]}

The users were created all right but the given password didn’t work. So we had to change the password through application…

Is there something we missed when creating user through API? Please help.

DHIS2 version - 2.23

Thank You

harsh

{“firstName”:“harsh”,“surname”:“harsh”,“email”:“harsh”,


Mailing list: https://launchpad.net/~dhis2-devs

Post to : dhis2-devs@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-devs

More help : https://help.launchpad.net/ListHelp