Organisational units missmatch

Hi All,

I recently updated my org units, it worked fine for a couple of hours. Our data entry team used those org unit to enter demo data the previous day. Surprisingly now i can’t find these units in data entry and capture modules but are present in data outputs and analysis modules. See screenshot below.

As a result all recently created dashboards are empty.

Thanks for any help,

Bayoh.

This sounds strange, but I guess it is related to caching. Try to clear both browser cache (there is an app for that) and server cache under Data Administration -> Cache Statistics.

Then go to Data Administration -> Resource Tables and regenerate them.

You can also try another browser or incognito mode in Chrome.

Let us know how it goes.

···

On Thu, Feb 25, 2016 at 10:33 AM, ibrahim bayoh ibrahim.bayoh@sl.ehealthafrica.org wrote:

Hi All,

I recently updated my org units, it worked fine for a couple of hours. Our data entry team used those org unit to enter demo data the previous day. Surprisingly now i can’t find these units in data entry and capture modules but are present in data outputs and analysis modules. See screenshot below.

As a result all recently created dashboards are empty.

Thanks for any help,

Bayoh.


Mailing list: https://launchpad.net/~dhis2-users

Post to : dhis2-users@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-users

More help : https://help.launchpad.net/ListHelp

Knut Staring

Dept. of Informatics, University of Oslo

Norway: +4791880522

Skype: knutstar

http://dhis2.org

Thank Knut for the swift response, i have tried out clearing the cache and using different browsers with incognito as suggested, but nothing seems to change.
I checked the browser console and resource logs; i found this.

Thanks,

Bayoh.

···

On Thu, Feb 25, 2016 at 9:39 AM, Knut Staring knutst@gmail.com wrote:

This sounds strange, but I guess it is related to caching. Try to clear both browser cache (there is an app for that) and server cache under Data Administration -> Cache Statistics.

Then go to Data Administration -> Resource Tables and regenerate them.

You can also try another browser or incognito mode in Chrome.

Let us know how it goes.

On Thu, Feb 25, 2016 at 10:33 AM, ibrahim bayoh ibrahim.bayoh@sl.ehealthafrica.org wrote:

Hi All,

I recently updated my org units, it worked fine for a couple of hours. Our data entry team used those org unit to enter demo data the previous day. Surprisingly now i can’t find these units in data entry and capture modules but are present in data outputs and analysis modules. See screenshot below.

As a result all recently created dashboards are empty.

Thanks for any help,

Bayoh.


Mailing list: https://launchpad.net/~dhis2-users

Post to : dhis2-users@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-users

More help : https://help.launchpad.net/ListHelp

Knut Staring

Dept. of Informatics, University of Oslo

Norway: +4791880522

Skype: knutstar

http://dhis2.org

Ibrahim Rashid Bayoh
Information Systems Coordinator,

eHealth Africa(Sierra Leone)

117 Wilkinson Rd, Freetown, Sierra Leone

Mobile: +232 88-765-638

ibrahim.bayoh@sl.ehealthafrica.org

http://ehealthafrica.org/

Hopefully others will have more insight, but another suggestion would be to go to Reports -> Analytics and rerun your analytics.

Knut

···

On Thu, Feb 25, 2016 at 11:15 AM, Ibrahim Bayoh ibrahim.bayoh@sl.ehealthafrica.org wrote:

Thank Knut for the swift response, i have tried out clearing the cache and using different browsers with incognito as suggested, but nothing seems to change.
I checked the browser console and resource logs; i found this.

Thanks,

Bayoh.

On Thu, Feb 25, 2016 at 9:39 AM, Knut Staring knutst@gmail.com wrote:

This sounds strange, but I guess it is related to caching. Try to clear both browser cache (there is an app for that) and server cache under Data Administration -> Cache Statistics.

Then go to Data Administration -> Resource Tables and regenerate them.

You can also try another browser or incognito mode in Chrome.

Let us know how it goes.

Ibrahim Rashid Bayoh
Information Systems Coordinator,

eHealth Africa(Sierra Leone)

117 Wilkinson Rd, Freetown, Sierra Leone

Mobile: +232 88-765-638

ibrahim.bayoh@sl.ehealthafrica.org

http://ehealthafrica.org/

On Thu, Feb 25, 2016 at 10:33 AM, ibrahim bayoh ibrahim.bayoh@sl.ehealthafrica.org wrote:

Hi All,

I recently updated my org units, it worked fine for a couple of hours. Our data entry team used those org unit to enter demo data the previous day. Surprisingly now i can’t find these units in data entry and capture modules but are present in data outputs and analysis modules. See screenshot below.

As a result all recently created dashboards are empty.

Thanks for any help,

Bayoh.


Mailing list: https://launchpad.net/~dhis2-users

Post to : dhis2-users@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-users

More help : https://help.launchpad.net/ListHelp

Knut Staring

Dept. of Informatics, University of Oslo

Norway: +4791880522

Skype: knutstar

http://dhis2.org

Knut Staring

Dept. of Informatics, University of Oslo

Norway: +4791880522

Skype: knutstar

http://dhis2.org

Hi Ibrahim,

Generating Resource Tables fixed a similar issue for me in the past.

You may want to try that…
Apps >> Data Administration >> Resource Tables >> Generate tables

-Ese

···

On Thu, Feb 25, 2016 at 11:18 AM, Knut Staring knutst@gmail.com wrote:

Knut

Hopefully others will have more insight, but another suggestion would be to go to Reports -> Analytics and rerun your analytics.


Mailing list: https://launchpad.net/~dhis2-users

Post to : dhis2-users@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-users

More help : https://help.launchpad.net/ListHelp

On Thu, Feb 25, 2016 at 11:15 AM, Ibrahim Bayoh ibrahim.bayoh@sl.ehealthafrica.org wrote:

Thank Knut for the swift response, i have tried out clearing the cache and using different browsers with incognito as suggested, but nothing seems to change.
I checked the browser console and resource logs; i found this.

Thanks,

Bayoh.


Knut Staring

Dept. of Informatics, University of Oslo

Norway: +4791880522

Skype: knutstar

http://dhis2.org

On Thu, Feb 25, 2016 at 9:39 AM, Knut Staring knutst@gmail.com wrote:

This sounds strange, but I guess it is related to caching. Try to clear both browser cache (there is an app for that) and server cache under Data Administration -> Cache Statistics.

Then go to Data Administration -> Resource Tables and regenerate them.

You can also try another browser or incognito mode in Chrome.

Let us know how it goes.

Ibrahim Rashid Bayoh
Information Systems Coordinator,

eHealth Africa(Sierra Leone)

117 Wilkinson Rd, Freetown, Sierra Leone

Mobile: +232 88-765-638

ibrahim.bayoh@sl.ehealthafrica.org

http://ehealthafrica.org/

On Thu, Feb 25, 2016 at 10:33 AM, ibrahim bayoh ibrahim.bayoh@sl.ehealthafrica.org wrote:

Hi All,

I recently updated my org units, it worked fine for a couple of hours. Our data entry team used those org unit to enter demo data the previous day. Surprisingly now i can’t find these units in data entry and capture modules but are present in data outputs and analysis modules. See screenshot below.

As a result all recently created dashboards are empty.

Thanks for any help,

Bayoh.


Mailing list: https://launchpad.net/~dhis2-users

Post to : dhis2-users@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-users

More help : https://help.launchpad.net/ListHelp

Knut Staring

Dept. of Informatics, University of Oslo

Norway: +4791880522

Skype: knutstar

http://dhis2.org

Hi All,
I tried your suggestions, but still faced with the same issue. I have even tried your suggestions on a different computer. I keep getting the console log :

  1. {httpStatus: “Conflict”, httpStatusCode: 409, status: “ERROR”,…}
  2. httpStatus: “Conflict”
  3. httpStatusCode: 409
  4. message: “User: admin is not allowed to view org unit: TWzjG3VaW4c”
  5. status: “ERROR”

There seems to be some conflict with org unit state above. Is there a way we can plunge/delete all org unit, may that will help.

Thanks All for your help,

Bayoh.

···

On Thu, Feb 25, 2016 at 2:24 PM, Ese Egerega egerega@gmail.com wrote:

Hi Ibrahim,

Generating Resource Tables fixed a similar issue for me in the past.

You may want to try that…
Apps >> Data Administration >> Resource Tables >> Generate tables

-Ese

On Thu, Feb 25, 2016 at 11:18 AM, Knut Staring knutst@gmail.com wrote:

Knut

Hopefully others will have more insight, but another suggestion would be to go to Reports -> Analytics and rerun your analytics.


Mailing list: https://launchpad.net/~dhis2-users

Post to : dhis2-users@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-users

More help : https://help.launchpad.net/ListHelp

On Thu, Feb 25, 2016 at 11:15 AM, Ibrahim Bayoh ibrahim.bayoh@sl.ehealthafrica.org wrote:

Thank Knut for the swift response, i have tried out clearing the cache and using different browsers with incognito as suggested, but nothing seems to change.
I checked the browser console and resource logs; i found this.

Thanks,

Bayoh.


Knut Staring

Dept. of Informatics, University of Oslo

Norway: +4791880522

Skype: knutstar

http://dhis2.org

On Thu, Feb 25, 2016 at 9:39 AM, Knut Staring knutst@gmail.com wrote:

This sounds strange, but I guess it is related to caching. Try to clear both browser cache (there is an app for that) and server cache under Data Administration -> Cache Statistics.

Then go to Data Administration -> Resource Tables and regenerate them.

You can also try another browser or incognito mode in Chrome.

Let us know how it goes.

Ibrahim Rashid Bayoh
Information Systems Coordinator,

eHealth Africa(Sierra Leone)

117 Wilkinson Rd, Freetown, Sierra Leone

Mobile: +232 88-765-638

ibrahim.bayoh@sl.ehealthafrica.org

http://ehealthafrica.org/

On Thu, Feb 25, 2016 at 10:33 AM, ibrahim bayoh ibrahim.bayoh@sl.ehealthafrica.org wrote:

Hi All,

I recently updated my org units, it worked fine for a couple of hours. Our data entry team used those org unit to enter demo data the previous day. Surprisingly now i can’t find these units in data entry and capture modules but are present in data outputs and analysis modules. See screenshot below.

As a result all recently created dashboards are empty.

Thanks for any help,

Bayoh.


Mailing list: https://launchpad.net/~dhis2-users

Post to : dhis2-users@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-users

More help : https://help.launchpad.net/ListHelp

Knut Staring

Dept. of Informatics, University of Oslo

Norway: +4791880522

Skype: knutstar

http://dhis2.org

Ibrahim Rashid Bayoh
Information Systems Coordinator,

eHealth Africa(Sierra Leone)

117 Wilkinson Rd, Freetown, Sierra Leone

Mobile: +232 88-765-638

ibrahim.bayoh@sl.ehealthafrica.org

http://ehealthafrica.org/

Hi Ibrahim,

From the console log this seems to be about access permissions. To find the offending orgunit, please add this to your URL:

/api/organisationUnits/TWzjG3VaW4c.json?fields=name

Or directly in the database:

select name from organisationunit where uid= ‘TWzjG3VaW4c’

···

Knut

On Thu, Feb 25, 2016 at 4:37 PM, Ibrahim Bayoh ibrahim.bayoh@sl.ehealthafrica.org wrote:

Hi All,
I tried your suggestions, but still faced with the same issue. I have even tried your suggestions on a different computer. I keep getting the console log :

  1. {httpStatus: “Conflict”, httpStatusCode: 409, status: “ERROR”,…}
  2. httpStatus: “Conflict”
  3. httpStatusCode: 409
  4. message: “User: admin is not allowed to view org unit: TWzjG3VaW4c”
  5. status: “ERROR”

There seems to be some conflict with org unit state above. Is there a way we can plunge/delete all org unit, may that will help.

Thanks All for your help,

Bayoh.


Knut Staring

Dept. of Informatics, University of Oslo

Norway: +4791880522

Skype: knutstar

http://dhis2.org

On Thu, Feb 25, 2016 at 2:24 PM, Ese Egerega egerega@gmail.com wrote:

Hi Ibrahim,

Generating Resource Tables fixed a similar issue for me in the past.

You may want to try that…
Apps >> Data Administration >> Resource Tables >> Generate tables

-Ese


Ibrahim Rashid Bayoh
Information Systems Coordinator,

eHealth Africa(Sierra Leone)

117 Wilkinson Rd, Freetown, Sierra Leone

Mobile: +232 88-765-638

ibrahim.bayoh@sl.ehealthafrica.org

http://ehealthafrica.org/

On Thu, Feb 25, 2016 at 11:18 AM, Knut Staring knutst@gmail.com wrote:

Knut

Hopefully others will have more insight, but another suggestion would be to go to Reports -> Analytics and rerun your analytics.


Mailing list: https://launchpad.net/~dhis2-users

Post to : dhis2-users@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-users

More help : https://help.launchpad.net/ListHelp

On Thu, Feb 25, 2016 at 11:15 AM, Ibrahim Bayoh ibrahim.bayoh@sl.ehealthafrica.org wrote:

Thank Knut for the swift response, i have tried out clearing the cache and using different browsers with incognito as suggested, but nothing seems to change.
I checked the browser console and resource logs; i found this.

Thanks,

Bayoh.


Knut Staring

Dept. of Informatics, University of Oslo

Norway: +4791880522

Skype: knutstar

http://dhis2.org

On Thu, Feb 25, 2016 at 9:39 AM, Knut Staring knutst@gmail.com wrote:

This sounds strange, but I guess it is related to caching. Try to clear both browser cache (there is an app for that) and server cache under Data Administration -> Cache Statistics.

Then go to Data Administration -> Resource Tables and regenerate them.

You can also try another browser or incognito mode in Chrome.

Let us know how it goes.

Ibrahim Rashid Bayoh
Information Systems Coordinator,

eHealth Africa(Sierra Leone)

117 Wilkinson Rd, Freetown, Sierra Leone

Mobile: +232 88-765-638

ibrahim.bayoh@sl.ehealthafrica.org

http://ehealthafrica.org/

On Thu, Feb 25, 2016 at 10:33 AM, ibrahim bayoh ibrahim.bayoh@sl.ehealthafrica.org wrote:

Hi All,

I recently updated my org units, it worked fine for a couple of hours. Our data entry team used those org unit to enter demo data the previous day. Surprisingly now i can’t find these units in data entry and capture modules but are present in data outputs and analysis modules. See screenshot below.

As a result all recently created dashboards are empty.

Thanks for any help,

Bayoh.


Mailing list: https://launchpad.net/~dhis2-users

Post to : dhis2-users@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-users

More help : https://help.launchpad.net/ListHelp

Knut Staring

Dept. of Informatics, University of Oslo

Norway: +4791880522

Skype: knutstar

http://dhis2.org