Missing DataValues when we add 'Categories' dimenssion in the layout

Dear all,

in pivot tables when we add the ‘Categories’ dimenssion to the layouts, the values are not showed. I have tested it in Sierra Leone Demo.

Without categories

image

With categories

image

Am I missing something? or do we have a bug here?

Thanks

Jose

Hi guys,

any feedback on this?

Regards

Jose

image

image

···

On Sat, Jul 12, 2014 at 12:36 PM, Jose Garcia Muñoz josemp10@gmail.com wrote:

Dear all,

in pivot tables when we add the ‘Categories’ dimenssion to the layouts, the values are not showed. I have tested it in Sierra Leone Demo.

Without categories

With categories

Am I missing something? or do we have a bug here?

Thanks

Jose

Hi Jose

While trying to duplicate the error mentioned in your previous email I found that the current version 2.16 in https://apps.dhis2.org/demo is not displaying the list of data elements if details is selected and there are no dimensions in table layout, I tested with both chrome and firefox. Can you check and confirm?

Best regards,

JM

···

On Sat, Jul 12, 2014 at 12:36 PM, Jose Garcia Muñoz josemp10@gmail.com wrote:

Dear all,

in pivot tables when we add the ‘Categories’ dimenssion to the layouts, the values are not showed. I have tested it in Sierra Leone Demo.

Without categories

<image.png>

With categories

<image.png>

Am I missing something? or do we have a bug here?

Thanks

Jose

Yes Juan Manuel, you are right. I confirm the same issues.

···

On Thu, Jul 31, 2014 at 3:30 PM, Juan Manuel Alcantara Acosta jmalcantara1@gmail.com wrote:

Hi Jose
While trying to duplicate the error mentioned in your previous email I found that the current version 2.16 in https://apps.dhis2.org/demo is not displaying the list of data elements if details is selected and there are no dimensions in table layout, I tested with both chrome and firefox. Can you check and confirm?

Best regards,

JM

El 31/07/2014, a las 04:54, Jose Garcia Muñoz josemp10@gmail.com escribió:

Hi guys,

any feedback on this?

Regards

Jose


Mailing list: https://launchpad.net/~dhis2-devs
Post to : dhis2-devs@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-devs
More help : https://help.launchpad.net/ListHelp

On Sat, Jul 12, 2014 at 12:36 PM, Jose Garcia Muñoz josemp10@gmail.com wrote:

Dear all,

in pivot tables when we add the ‘Categories’ dimenssion to the layouts, the values are not showed. I have tested it in Sierra Leone Demo.

Without categories

<image.png>

With categories

<image.png>

Am I missing something? or do we have a bug here?

Thanks

Jose

Will be fixed shortly. Thanks for reporting.

···

On Thu, Jul 31, 2014 at 3:30 PM, Juan Manuel Alcantara Acosta jmalcantara1@gmail.com wrote:

Hi Jose
While trying to duplicate the error mentioned in your previous email I found that the current version 2.16 in https://apps.dhis2.org/demo is not displaying the list of data elements if details is selected and there are no dimensions in table layout, I tested with both chrome and firefox. Can you check and confirm?

Best regards,

JM

El 31/07/2014, a las 04:54, Jose Garcia Muñoz josemp10@gmail.com escribió:

Hi guys,

any feedback on this?

Regards

Jose


Mailing list: https://launchpad.net/~dhis2-devs
Post to : dhis2-devs@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-devs
More help : https://help.launchpad.net/ListHelp

On Sat, Jul 12, 2014 at 12:36 PM, Jose Garcia Muñoz josemp10@gmail.com wrote:

Dear all,

in pivot tables when we add the ‘Categories’ dimenssion to the layouts, the values are not showed. I have tested it in Sierra Leone Demo.

Without categories

<image.png>

With categories

<image.png>

Am I missing something? or do we have a bug here?

Thanks

Jose

Hi, this is now fixed in trunk and 2.16. Will have a look at 2.15 as well.

···

On Thu, Jul 31, 2014 at 7:27 PM, Jan Henrik Øverland janhenrik.overland@gmail.com wrote:

Will be fixed shortly. Thanks for reporting.

On Jul 31, 2014 5:20 PM, “Jose Garcia Muñoz” josemp10@gmail.com wrote:

Yes Juan Manuel, you are right. I confirm the same issues.


Mailing list: https://launchpad.net/~dhis2-devs

Post to : dhis2-devs@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-devs

More help : https://help.launchpad.net/ListHelp

On Thu, Jul 31, 2014 at 3:30 PM, Juan Manuel Alcantara Acosta jmalcantara1@gmail.com wrote:

Hi Jose
While trying to duplicate the error mentioned in your previous email I found that the current version 2.16 in https://apps.dhis2.org/demo is not displaying the list of data elements if details is selected and there are no dimensions in table layout, I tested with both chrome and firefox. Can you check and confirm?

Best regards,

JM

El 31/07/2014, a las 04:54, Jose Garcia Muñoz josemp10@gmail.com escribió:

Hi guys,

any feedback on this?

Regards

Jose


Mailing list: https://launchpad.net/~dhis2-devs
Post to : dhis2-devs@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-devs
More help : https://help.launchpad.net/ListHelp

On Sat, Jul 12, 2014 at 12:36 PM, Jose Garcia Muñoz josemp10@gmail.com wrote:

Dear all,

in pivot tables when we add the ‘Categories’ dimenssion to the layouts, the values are not showed. I have tested it in Sierra Leone Demo.

Without categories

<image.png>

With categories

<image.png>

Am I missing something? or do we have a bug here?

Thanks

Jose

Fixed in 2.15.

···

On Tue, Aug 12, 2014 at 10:35 AM, Jan Henrik Øverland janhenrik.overland@gmail.com wrote:

Hi, this is now fixed in trunk and 2.16. Will have a look at 2.15 as well.

On Thu, Jul 31, 2014 at 7:27 PM, Jan Henrik Øverland janhenrik.overland@gmail.com wrote:

Will be fixed shortly. Thanks for reporting.

On Jul 31, 2014 5:20 PM, “Jose Garcia Muñoz” josemp10@gmail.com wrote:

Yes Juan Manuel, you are right. I confirm the same issues.


Mailing list: https://launchpad.net/~dhis2-devs

Post to : dhis2-devs@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-devs

More help : https://help.launchpad.net/ListHelp

On Thu, Jul 31, 2014 at 3:30 PM, Juan Manuel Alcantara Acosta jmalcantara1@gmail.com wrote:

Hi Jose
While trying to duplicate the error mentioned in your previous email I found that the current version 2.16 in https://apps.dhis2.org/demo is not displaying the list of data elements if details is selected and there are no dimensions in table layout, I tested with both chrome and firefox. Can you check and confirm?

Best regards,

JM

El 31/07/2014, a las 04:54, Jose Garcia Muñoz josemp10@gmail.com escribió:

Hi guys,

any feedback on this?

Regards

Jose


Mailing list: https://launchpad.net/~dhis2-devs
Post to : dhis2-devs@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-devs
More help : https://help.launchpad.net/ListHelp

On Sat, Jul 12, 2014 at 12:36 PM, Jose Garcia Muñoz josemp10@gmail.com wrote:

Dear all,

in pivot tables when we add the ‘Categories’ dimenssion to the layouts, the values are not showed. I have tested it in Sierra Leone Demo.

Without categories

<image.png>

With categories

<image.png>

Am I missing something? or do we have a bug here?

Thanks

Jose

Thank you!

JM

···

On Tue, Aug 12, 2014 at 10:35 AM, Jan Henrik Øverland janhenrik.overland@gmail.com wrote:

Hi, this is now fixed in trunk and 2.16. Will have a look at 2.15 as well.

On Thu, Jul 31, 2014 at 7:27 PM, Jan Henrik Øverland janhenrik.overland@gmail.com wrote:

Will be fixed shortly. Thanks for reporting.

On Jul 31, 2014 5:20 PM, “Jose Garcia Muñoz” josemp10@gmail.com wrote:

Yes Juan Manuel, you are right. I confirm the same issues.


Mailing list: https://launchpad.net/~dhis2-devs

Post to : dhis2-devs@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-devs

More help : https://help.launchpad.net/ListHelp

On Thu, Jul 31, 2014 at 3:30 PM, Juan Manuel Alcantara Acosta jmalcantara1@gmail.com wrote:

Hi Jose
While trying to duplicate the error mentioned in your previous email I found that the current version 2.16 in https://apps.dhis2.org/demo is not displaying the list of data elements if details is selected and there are no dimensions in table layout, I tested with both chrome and firefox. Can you check and confirm?

Best regards,

JM

<No dimensions in DHIS2 v 2.16.jpg>

El 31/07/2014, a las 04:54, Jose Garcia Muñoz josemp10@gmail.com escribió:

Hi guys,

any feedback on this?

Regards

Jose


Mailing list: https://launchpad.net/~dhis2-devs
Post to : dhis2-devs@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-devs
More help : https://help.launchpad.net/ListHelp

On Sat, Jul 12, 2014 at 12:36 PM, Jose Garcia Muñoz josemp10@gmail.com wrote:

Dear all,

in pivot tables when we add the ‘Categories’ dimenssion to the layouts, the values are not showed. I have tested it in Sierra Leone Demo.

Without categories

<image.png>

With categories

<image.png>

Am I missing something? or do we have a bug here?

Thanks

Jose

Hi this problem got sorted for 2.15 (at least I know it works for Build revision: 15196 / 2014-07-25 02:06), but seems to be back on 2.16. I just tested at https://apps.dhis2.org/demo/ and observed the same problem that Jose originally reported - the details don’t show.
I’m having this problem in the following servers

  • PSI staging: v2.16: Build revision: 16320 / 2014-08-16 02:04

  • EH: v2.16 Build revision: 16320 / 2014-08-16 02:04

image

image

···

Rodolfo Meliá

*Principal | *rmelia@knowming.com

Skype: rod.melia | +44 777 576 4090 | +1 708 872 7636

www.knowming.com

On Thu, Jul 31, 2014 at 10:54 AM, Jose Garcia Muñoz josemp10@gmail.com wrote:

Hi guys,

any feedback on this?

Regards

Jose

On Sat, Jul 12, 2014 at 12:36 PM, Jose Garcia Muñoz josemp10@gmail.com wrote:

Dear all,

in pivot tables when we add the ‘Categories’ dimenssion to the layouts, the values are not showed. I have tested it in Sierra Leone Demo.

Without categories

With categories

Am I missing something? or do we have a bug here?

Thanks

Jose

Hi Rodolfo

I tested this in https://apps.dhis2.org/demo/ and it works but it takes around 15 seconds to load the list of data elements when you select details, it certainly gives the impression that it doesn’t work.

By the way, the update of www and dev2 is still pending, we should be running build #130 dated August 13, 2014

Best regards,

JM

···

Rodolfo Meliá

*Principal | *rmelia@knowming.com

Skype: rod.melia | +44 777 576 4090 | +1 708 872 7636

www.knowming.com

On Thu, Jul 31, 2014 at 10:54 AM, Jose Garcia Muñoz josemp10@gmail.com wrote:

Hi guys,

any feedback on this?

Regards

Jose

On Sat, Jul 12, 2014 at 12:36 PM, Jose Garcia Muñoz josemp10@gmail.com wrote:

Dear all,

in pivot tables when we add the ‘Categories’ dimenssion to the layouts, the values are not showed. I have tested it in Sierra Leone Demo.

Without categories

<image.png>

With categories

<image.png>

Am I missing something? or do we have a bug here?

Thanks

Jose

Hi - I just tested again.
It does take a while to load (6-10secs) But the issue that I’m reporting is that that the pivot table doesn’t populate with data. See images below

···

Rodolfo Meliá

*Principal | *rmelia@knowming.com

Skype: rod.melia | +44 777 576 4090 | +1 708 872 7636

www.knowming.com

On Tue, Aug 19, 2014 at 4:31 AM, Juan Manuel Alcantara Acosta jmalcantara1@gmail.com wrote:

Hi Rodolfo
I tested this in https://apps.dhis2.org/demo/ and it works but it takes around 15 seconds to load the list of data elements when you select details, it certainly gives the impression that it doesn’t work.

By the way, the update of www and dev2 is still pending, we should be running build #130 dated August 13, 2014

Best regards,

JM
El 18/08/2014, a las 19:13, Rodolfo Melia rmelia@knowming.com escribió:

Hi this problem got sorted for 2.15 (at least I know it works for Build revision: 15196 / 2014-07-25 02:06), but seems to be back on 2.16. I just tested at https://apps.dhis2.org/demo/ and observed the same problem that Jose originally reported - the details don’t show.
I’m having this problem in the following servers

  • PSI staging: v2.16: Build revision: 16320 / 2014-08-16 02:04
  • EH: v2.16 Build revision: 16320 / 2014-08-16 02:04

Mailing list: https://launchpad.net/~dhis2-devs
Post to : dhis2-devs@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-devs
More help : https://help.launchpad.net/ListHelp

Rodolfo Meliá

*Principal | *rmelia@knowming.com

Skype: rod.melia | +44 777 576 4090 | +1 708 872 7636

www.knowming.com

On Thu, Jul 31, 2014 at 10:54 AM, Jose Garcia Muñoz josemp10@gmail.com wrote:

Hi guys,

any feedback on this?

Regards

Jose

On Sat, Jul 12, 2014 at 12:36 PM, Jose Garcia Muñoz josemp10@gmail.com wrote:

Dear all,

in pivot tables when we add the ‘Categories’ dimenssion to the layouts, the values are not showed. I have tested it in Sierra Leone Demo.

Without categories

<image.png>

With categories

<image.png>

Am I missing something? or do we have a bug here?

Thanks

Jose

Hi, there has been som changes to the api wrt data element operands. Small fix, will do it shortly.

···

On Tue, Aug 19, 2014 at 11:13 AM, Rodolfo Melia rmelia@knowming.com wrote:

Hi - I just tested again.
It does take a while to load (6-10secs) But the issue that I’m reporting is that that the pivot table doesn’t populate with data. See images below

Rodolfo Meliá

*Principal | *rmelia@knowming.com

Skype: rod.melia | +44 777 576 4090 | +1 708 872 7636

www.knowming.com

On Tue, Aug 19, 2014 at 4:31 AM, Juan Manuel Alcantara Acosta jmalcantara1@gmail.com wrote:

Hi Rodolfo
I tested this in https://apps.dhis2.org/demo/ and it works but it takes around 15 seconds to load the list of data elements when you select details, it certainly gives the impression that it doesn’t work.

By the way, the update of www and dev2 is still pending, we should be running build #130 dated August 13, 2014

Best regards,

JM
El 18/08/2014, a las 19:13, Rodolfo Melia rmelia@knowming.com escribió:

Hi this problem got sorted for 2.15 (at least I know it works for Build revision: 15196 / 2014-07-25 02:06), but seems to be back on 2.16. I just tested at https://apps.dhis2.org/demo/ and observed the same problem that Jose originally reported - the details don’t show.
I’m having this problem in the following servers

  • PSI staging: v2.16: Build revision: 16320 / 2014-08-16 02:04
  • EH: v2.16 Build revision: 16320 / 2014-08-16 02:04

Mailing list: https://launchpad.net/~dhis2-devs
Post to : dhis2-devs@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-devs
More help : https://help.launchpad.net/ListHelp

Rodolfo Meliá

*Principal | *rmelia@knowming.com

Skype: rod.melia | +44 777 576 4090 | +1 708 872 7636

www.knowming.com

On Thu, Jul 31, 2014 at 10:54 AM, Jose Garcia Muñoz josemp10@gmail.com wrote:

Hi guys,

any feedback on this?

Regards

Jose

On Sat, Jul 12, 2014 at 12:36 PM, Jose Garcia Muñoz josemp10@gmail.com wrote:

Dear all,

in pivot tables when we add the ‘Categories’ dimenssion to the layouts, the values are not showed. I have tested it in Sierra Leone Demo.

Without categories

<image.png>

With categories

<image.png>

Am I missing something? or do we have a bug here?

Thanks

Jose

Ah! I see what you mean. I was able to get a result using the data element (total) and assigned categories in columns but selecting a specific data element with cat combination in details doesn’t render the data, yes this is new.

Best regards,

JM

···

Rodolfo Meliá

*Principal | *rmelia@knowming.com

Skype: rod.melia | +44 777 576 4090 | +1 708 872 7636

www.knowming.com

On Tue, Aug 19, 2014 at 4:31 AM, Juan Manuel Alcantara Acosta jmalcantara1@gmail.com wrote:

Hi Rodolfo
I tested this in https://apps.dhis2.org/demo/ and it works but it takes around 15 seconds to load the list of data elements when you select details, it certainly gives the impression that it doesn’t work.

By the way, the update of www and dev2 is still pending, we should be running build #130 dated August 13, 2014

Best regards,

JM
El 18/08/2014, a las 19:13, Rodolfo Melia rmelia@knowming.com escribió:

Hi this problem got sorted for 2.15 (at least I know it works for Build revision: 15196 / 2014-07-25 02:06), but seems to be back on 2.16. I just tested at https://apps.dhis2.org/demo/ and observed the same problem that Jose originally reported - the details don’t show.
I’m having this problem in the following servers

  • PSI staging: v2.16: Build revision: 16320 / 2014-08-16 02:04
  • EH: v2.16 Build revision: 16320 / 2014-08-16 02:04

Mailing list: https://launchpad.net/~dhis2-devs
Post to : dhis2-devs@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-devs
More help : https://help.launchpad.net/ListHelp

Rodolfo Meliá

*Principal | *rmelia@knowming.com

Skype: rod.melia | +44 777 576 4090 | +1 708 872 7636

www.knowming.com

On Thu, Jul 31, 2014 at 10:54 AM, Jose Garcia Muñoz josemp10@gmail.com wrote:

Hi guys,

any feedback on this?

Regards

Jose

On Sat, Jul 12, 2014 at 12:36 PM, Jose Garcia Muñoz josemp10@gmail.com wrote:

Dear all,

in pivot tables when we add the ‘Categories’ dimenssion to the layouts, the values are not showed. I have tested it in Sierra Leone Demo.

Without categories

<image.png>

With categories

<image.png>

Am I missing something? or do we have a bug here?

Thanks

Jose

Hi, this is now fixed in the affected versions.

···

On Tue, Aug 19, 2014 at 3:47 PM, Juan Manuel Alcantara Acosta jmalcantara1@gmail.com wrote:

Ah! I see what you mean. I was able to get a result using the data element (total) and assigned categories in columns but selecting a specific data element with cat combination in details doesn’t render the data, yes this is new.
Best regards,

JM

El 19/08/2014, a las 04:13, Rodolfo Melia rmelia@knowming.com escribió:

Hi - I just tested again.
It does take a while to load (6-10secs) But the issue that I’m reporting is that that the pivot table doesn’t populate with data. See images below

<Screen Shot 2014-08-19 at 10.08.24.png>

<Screen Shot 2014-08-19 at 10.09.19.png>

Rodolfo Meliá

*Principal | *rmelia@knowming.com

Skype: rod.melia | +44 777 576 4090 | +1 708 872 7636

www.knowming.com

On Tue, Aug 19, 2014 at 4:31 AM, Juan Manuel Alcantara Acosta jmalcantara1@gmail.com wrote:

Hi Rodolfo
I tested this in https://apps.dhis2.org/demo/ and it works but it takes around 15 seconds to load the list of data elements when you select details, it certainly gives the impression that it doesn’t work.

By the way, the update of www and dev2 is still pending, we should be running build #130 dated August 13, 2014

Best regards,

JM
El 18/08/2014, a las 19:13, Rodolfo Melia rmelia@knowming.com escribió:

Hi this problem got sorted for 2.15 (at least I know it works for Build revision: 15196 / 2014-07-25 02:06), but seems to be back on 2.16. I just tested at https://apps.dhis2.org/demo/ and observed the same problem that Jose originally reported - the details don’t show.
I’m having this problem in the following servers

  • PSI staging: v2.16: Build revision: 16320 / 2014-08-16 02:04
  • EH: v2.16 Build revision: 16320 / 2014-08-16 02:04

Mailing list: https://launchpad.net/~dhis2-devs
Post to : dhis2-devs@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-devs
More help : https://help.launchpad.net/ListHelp

Rodolfo Meliá

*Principal | *rmelia@knowming.com

Skype: rod.melia | +44 777 576 4090 | +1 708 872 7636

www.knowming.com

On Thu, Jul 31, 2014 at 10:54 AM, Jose Garcia Muñoz josemp10@gmail.com wrote:

Hi guys,

any feedback on this?

Regards

Jose

On Sat, Jul 12, 2014 at 12:36 PM, Jose Garcia Muñoz josemp10@gmail.com wrote:

Dear all,

in pivot tables when we add the ‘Categories’ dimenssion to the layouts, the values are not showed. I have tested it in Sierra Leone Demo.

Without categories

<image.png>

With categories

<image.png>

Am I missing something? or do we have a bug here?

Thanks

Jose

I have also added load masks on the “available” panel for indicators, data elements etc.

···

On Wed, Aug 20, 2014 at 12:17 PM, Jan Henrik Øverland janhenrik.overland@gmail.com wrote:

Hi, this is now fixed in the affected versions.

On Tue, Aug 19, 2014 at 3:47 PM, Juan Manuel Alcantara Acosta jmalcantara1@gmail.com wrote:

Ah! I see what you mean. I was able to get a result using the data element (total) and assigned categories in columns but selecting a specific data element with cat combination in details doesn’t render the data, yes this is new.
Best regards,

JM

El 19/08/2014, a las 04:13, Rodolfo Melia rmelia@knowming.com escribió:

Hi - I just tested again.
It does take a while to load (6-10secs) But the issue that I’m reporting is that that the pivot table doesn’t populate with data. See images below

<Screen Shot 2014-08-19 at 10.08.24.png>

<Screen Shot 2014-08-19 at 10.09.19.png>

Rodolfo Meliá

*Principal | *rmelia@knowming.com

Skype: rod.melia | +44 777 576 4090 | +1 708 872 7636

www.knowming.com

On Tue, Aug 19, 2014 at 4:31 AM, Juan Manuel Alcantara Acosta jmalcantara1@gmail.com wrote:

Hi Rodolfo
I tested this in https://apps.dhis2.org/demo/ and it works but it takes around 15 seconds to load the list of data elements when you select details, it certainly gives the impression that it doesn’t work.

By the way, the update of www and dev2 is still pending, we should be running build #130 dated August 13, 2014

Best regards,

JM
El 18/08/2014, a las 19:13, Rodolfo Melia rmelia@knowming.com escribió:

Hi this problem got sorted for 2.15 (at least I know it works for Build revision: 15196 / 2014-07-25 02:06), but seems to be back on 2.16. I just tested at https://apps.dhis2.org/demo/ and observed the same problem that Jose originally reported - the details don’t show.
I’m having this problem in the following servers

  • PSI staging: v2.16: Build revision: 16320 / 2014-08-16 02:04
  • EH: v2.16 Build revision: 16320 / 2014-08-16 02:04

Mailing list: https://launchpad.net/~dhis2-devs
Post to : dhis2-devs@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-devs
More help : https://help.launchpad.net/ListHelp

Rodolfo Meliá

*Principal | *rmelia@knowming.com

Skype: rod.melia | +44 777 576 4090 | +1 708 872 7636

www.knowming.com

On Thu, Jul 31, 2014 at 10:54 AM, Jose Garcia Muñoz josemp10@gmail.com wrote:

Hi guys,

any feedback on this?

Regards

Jose

On Sat, Jul 12, 2014 at 12:36 PM, Jose Garcia Muñoz josemp10@gmail.com wrote:

Dear all,

in pivot tables when we add the ‘Categories’ dimenssion to the layouts, the values are not showed. I have tested it in Sierra Leone Demo.

Without categories

<image.png>

With categories

<image.png>

Am I missing something? or do we have a bug here?

Thanks

Jose

Jan - thanks so much.
I’ve tested with latest 2.16 and details columns now render data.

···

Rodolfo Meliá

*Principal | *rmelia@knowming.com

Skype: rod.melia | +44 777 576 4090 | +1 708 872 7636

www.knowming.com

On Wed, Aug 20, 2014 at 2:22 PM, Jan Henrik Øverland janhenrik.overland@gmail.com wrote:

I have also added load masks on the “available” panel for indicators, data elements etc.

On Wed, Aug 20, 2014 at 12:17 PM, Jan Henrik Øverland janhenrik.overland@gmail.com wrote:

Hi, this is now fixed in the affected versions.

On Tue, Aug 19, 2014 at 3:47 PM, Juan Manuel Alcantara Acosta jmalcantara1@gmail.com wrote:

Ah! I see what you mean. I was able to get a result using the data element (total) and assigned categories in columns but selecting a specific data element with cat combination in details doesn’t render the data, yes this is new.
Best regards,

JM

El 19/08/2014, a las 04:13, Rodolfo Melia rmelia@knowming.com escribió:

Hi - I just tested again.
It does take a while to load (6-10secs) But the issue that I’m reporting is that that the pivot table doesn’t populate with data. See images below

<Screen Shot 2014-08-19 at 10.08.24.png>

<Screen Shot 2014-08-19 at 10.09.19.png>

Rodolfo Meliá

*Principal | *rmelia@knowming.com

Skype: rod.melia | +44 777 576 4090 | +1 708 872 7636

www.knowming.com

On Tue, Aug 19, 2014 at 4:31 AM, Juan Manuel Alcantara Acosta jmalcantara1@gmail.com wrote:

Hi Rodolfo
I tested this in https://apps.dhis2.org/demo/ and it works but it takes around 15 seconds to load the list of data elements when you select details, it certainly gives the impression that it doesn’t work.

By the way, the update of www and dev2 is still pending, we should be running build #130 dated August 13, 2014

Best regards,

JM
El 18/08/2014, a las 19:13, Rodolfo Melia rmelia@knowming.com escribió:

Hi this problem got sorted for 2.15 (at least I know it works for Build revision: 15196 / 2014-07-25 02:06), but seems to be back on 2.16. I just tested at https://apps.dhis2.org/demo/ and observed the same problem that Jose originally reported - the details don’t show.
I’m having this problem in the following servers

  • PSI staging: v2.16: Build revision: 16320 / 2014-08-16 02:04
  • EH: v2.16 Build revision: 16320 / 2014-08-16 02:04

Mailing list: https://launchpad.net/~dhis2-devs
Post to : dhis2-devs@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-devs
More help : https://help.launchpad.net/ListHelp

Rodolfo Meliá

*Principal | *rmelia@knowming.com

Skype: rod.melia | +44 777 576 4090 | +1 708 872 7636

www.knowming.com

On Thu, Jul 31, 2014 at 10:54 AM, Jose Garcia Muñoz josemp10@gmail.com wrote:

Hi guys,

any feedback on this?

Regards

Jose

On Sat, Jul 12, 2014 at 12:36 PM, Jose Garcia Muñoz josemp10@gmail.com wrote:

Dear all,

in pivot tables when we add the ‘Categories’ dimenssion to the layouts, the values are not showed. I have tested it in Sierra Leone Demo.

Without categories

<image.png>

With categories

<image.png>

Am I missing something? or do we have a bug here?

Thanks

Jose