Metadata import DHIS2 2.30 issue

I want to modify metadata name by adding prefix RES_

So I import csv file with name update :

This is the result after import :

But nothing is changed

Someone could expain what is the problem ?

1 Like

Hi @Zoely!

A quick one as other users help out; have you tried generating the resource tables and see if anything changes?

@Zoely it looks like your data elements are named ATU KIT TRIAGE…, which you are prepending with RES_; so, your data elements should be RES_ATU KIT TRIAGE…, but your search shows RES_KIT TRIAGE, which would not not find anything. Have you tried searching for RES_ATU KIT TRIAGE instead?

1 Like

Great observation @Vladimer_Shioshvili! - @Zoely - kindly check and confirm with us please.


Thanks for the observation @Vladimer_Shioshvili,
Searching with RES_ATU KIT TRIAGE, the result is :

and With ATU KIT TRIAGE, the result is :

So they are no change.

1 Like

@Zoely can you share the settings you are using when importing? Your screenshot cuts off at the file name; do you have “Dry run” set at Yes?

1 Like

@Vladimer_Shioshvili below

@Zoely - you should set “Dry run” to No when importing. When it is set to “Yes” it only validates the import file. It is useful to check if your import file can be processed, but it does not actually save it. Try importing with “Dry run” set to No, unless there is something else, that should solve it.


Thanks @Vladimer_Shioshvili
It’s OK

1 Like

Great job @Vladimer_Shioshvili! We need more of you in the community :smile: