Legend Set - Issue with start and end values

Hi,

We are using DHIS 2.25. We have created a legend set and created 5 legends automatically by specifying the start and end values as 20 and 120 respectively. And then saved it. But when we open it again, we see that the start and end values show 0 and 100 respectively. They are always reset to 0 and 100. Is this a bug?

Please see the screenshot attached with the mail.

Cheers,

···

Archana Chillala
Application Developer
Email
archanac@thoughtworks.com
Telephone
+91 9100960533
ThoughtWorks

Hi Archana,

I was testing this on the demo instance and it seems to work well there. Are you able to reproduce this on the demo?

regards,

Lars

···

On Fri, Nov 4, 2016 at 1:40 PM, Archana Chillala archanac@thoughtworks.com wrote:

Hi,

We are using DHIS 2.25. We have created a legend set and created 5 legends automatically by specifying the start and end values as 20 and 120 respectively. And then saved it. But when we open it again, we see that the start and end values show 0 and 100 respectively. They are always reset to 0 and 100. Is this a bug?

Please see the screenshot attached with the mail.

Cheers,

Archana Chillala
Application Developer
Email
archanac@thoughtworks.com
Telephone
+91 9100960533
ThoughtWorks


Mailing list: https://launchpad.net/~dhis2-devs

Post to : dhis2-devs@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-devs

More help : https://help.launchpad.net/ListHelp

Lars Helge Øverland

Lead developer, DHIS 2

University of Oslo

Skype: larshelgeoverland

lars@dhis2.org

http://www.dhis2.org

Hi again,

if you are referring to the “start value” and “end value” fields above the “create legend items” button - those are used only to generate the legends, which are shown in the table below. They are not part of the legend set itself, rather used to generate legends. So this is expected.

regards,

Lars

···

On Fri, Nov 4, 2016 at 2:51 PM, Lars Helge Øverland lars@dhis2.org wrote:

Hi Archana,

I was testing this on the demo instance and it seems to work well there. Are you able to reproduce this on the demo?

regards,

Lars

On Fri, Nov 4, 2016 at 1:40 PM, Archana Chillala archanac@thoughtworks.com wrote:

Hi,

We are using DHIS 2.25. We have created a legend set and created 5 legends automatically by specifying the start and end values as 20 and 120 respectively. And then saved it. But when we open it again, we see that the start and end values show 0 and 100 respectively. They are always reset to 0 and 100. Is this a bug?

Please see the screenshot attached with the mail.

Cheers,

Archana Chillala
Application Developer
Email
archanac@thoughtworks.com
Telephone
+91 9100960533
ThoughtWorks


Mailing list: https://launchpad.net/~dhis2-devs

Post to : dhis2-devs@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-devs

More help : https://help.launchpad.net/ListHelp

Lars Helge Øverland

Lead developer, DHIS 2

University of Oslo

Skype: larshelgeoverland

lars@dhis2.org

http://www.dhis2.org

Lars Helge Øverland

Lead developer, DHIS 2

University of Oslo

Skype: larshelgeoverland

lars@dhis2.org

http://www.dhis2.org

Okay. Thanks for the information, Lars.

···

On Fri, Nov 4, 2016 at 7:36 PM, Lars Helge Øverland lars@dhis2.org wrote:

Hi again,

if you are referring to the “start value” and “end value” fields above the “create legend items” button - those are used only to generate the legends, which are shown in the table below. They are not part of the legend set itself, rather used to generate legends. So this is expected.

regards,

Lars

Archana Chillala
Application Developer
Email
archanac@thoughtworks.com
Telephone
+91 9100960533
ThoughtWorks

On Fri, Nov 4, 2016 at 2:51 PM, Lars Helge Øverland lars@dhis2.org wrote:

Hi Archana,

I was testing this on the demo instance and it seems to work well there. Are you able to reproduce this on the demo?

regards,

Lars


Lars Helge Øverland

Lead developer, DHIS 2

University of Oslo

Skype: larshelgeoverland

lars@dhis2.org

http://www.dhis2.org

On Fri, Nov 4, 2016 at 1:40 PM, Archana Chillala archanac@thoughtworks.com wrote:

Hi,

We are using DHIS 2.25. We have created a legend set and created 5 legends automatically by specifying the start and end values as 20 and 120 respectively. And then saved it. But when we open it again, we see that the start and end values show 0 and 100 respectively. They are always reset to 0 and 100. Is this a bug?

Please see the screenshot attached with the mail.

Cheers,

Archana Chillala
Application Developer
Email
archanac@thoughtworks.com
Telephone
+91 9100960533
ThoughtWorks


Mailing list: https://launchpad.net/~dhis2-devs

Post to : dhis2-devs@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-devs

More help : https://help.launchpad.net/ListHelp

Lars Helge Øverland

Lead developer, DHIS 2

University of Oslo

Skype: larshelgeoverland

lars@dhis2.org

http://www.dhis2.org