Infrastructural data

Hello,

Whenever I use facility layer and when display data element info (Infrastructural data) some data element values appears as “NaN”

Please see the photo below on the right

Can anyone help

Thanks in advance

Hi Nami,

I will have a look at this and get back to you.

Jan

···

On Tue, Jun 9, 2015 at 10:00 AM, Nami Ghadri nami_ghadri@hotmail.com wrote:

Hello,

Whenever I use facility layer and when display data element info (Infrastructural data) some data element values appears as “NaN”

Please see the photo below on the right

Can anyone help

Thanks in advance


Mailing list: https://launchpad.net/~dhis2-users

Post to : dhis2-users@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-users

More help : https://help.launchpad.net/ListHelp

It seems that any dataelement that has test type is appears like that and number type appears correctly and also dataelement with date type does appears at all

Thanks in advance

···

From: Jan Henrik Øverland [mailto:janhenrik.overland@gmail.com]
Sent: Tuesday, June 9, 2015 11:35 AM
To: Nami Ghadri
Cc: DHIS 2 Users list
Subject: Re: [Dhis2-users] Infrastructural data

Hi Nami,

I will have a look at this and get back to you.

Jan

On Tue, Jun 9, 2015 at 10:00 AM, Nami Ghadri nami_ghadri@hotmail.com wrote:

Hello,

Whenever I use facility layer and when display data element info (Infrastructural data) some data element values appears as “NaN”

Please see the photo below on the right

Can anyone help

Thanks in advance


Mailing list: https://launchpad.net/~dhis2-users
Post to : dhis2-users@lists.launchpad.net
Unsubscribe : https://launchpad.net/~dhis2-users
More help : https://help.launchpad.net/ListHelp

Hi Name,

This is now fixed in trunk and 2.19. Let me know if there is anything else.

Jan

···

On Tue, Jun 9, 2015 at 10:51 AM, Nami Ghadri nami_ghadri@hotmail.com wrote:

It seems that any dataelement that has test type is appears like that and number type appears correctly and also dataelement with date type does appears at all

Thanks in advance

From: Jan Henrik Øverland [mailto:janhenrik.overland@gmail.com]
Sent: Tuesday, June 9, 2015 11:35 AM
To: Nami Ghadri
Cc: DHIS 2 Users list
Subject: Re: [Dhis2-users] Infrastructural data

Hi Nami,

I will have a look at this and get back to you.

Jan

On Tue, Jun 9, 2015 at 10:00 AM, Nami Ghadri nami_ghadri@hotmail.com wrote:

Hello,

Whenever I use facility layer and when display data element info (Infrastructural data) some data element values appears as “NaN”

Please see the photo below on the right

Can anyone help

Thanks in advance


Mailing list: https://launchpad.net/~dhis2-users
Post to : dhis2-users@lists.launchpad.net
Unsubscribe : https://launchpad.net/~dhis2-users
More help : https://help.launchpad.net/ListHelp

Dears

So now I have to re-download the WAR file?

And then use it the new one ?

Thanks

···

From: Jan Henrik Øverland [mailto:janhenrik.overland@gmail.com]
Sent: Tuesday, June 9, 2015 7:57 PM
To: Nami Ghadri
Cc: DHIS 2 Users list
Subject: Re: [Dhis2-users] Infrastructural data

Hi Name,

This is now fixed in trunk and 2.19. Let me know if there is anything else.

Jan

On Tue, Jun 9, 2015 at 10:51 AM, Nami Ghadri nami_ghadri@hotmail.com wrote:

It seems that any dataelement that has test type is appears like that and number type appears correctly and also dataelement with date type does appears at all

Thanks in advance

From: Jan Henrik Øverland [mailto:janhenrik.overland@gmail.com]
Sent: Tuesday, June 9, 2015 11:35 AM
To: Nami Ghadri
Cc: DHIS 2 Users list
Subject: Re: [Dhis2-users] Infrastructural data

Hi Nami,

I will have a look at this and get back to you.

Jan

On Tue, Jun 9, 2015 at 10:00 AM, Nami Ghadri nami_ghadri@hotmail.com wrote:

Hello,

Whenever I use facility layer and when display data element info (Infrastructural data) some data element values appears as “NaN”

Please see the photo below on the right

Can anyone help

Thanks in advance


Mailing list: https://launchpad.net/~dhis2-users
Post to : dhis2-users@lists.launchpad.net
Unsubscribe : https://launchpad.net/~dhis2-users
More help : https://help.launchpad.net/ListHelp

That is how it works, unless you want to build it from source code (but that will also take long time the first time).

Knut

···

On Wed, Jun 10, 2015 at 8:31 AM, Nami Ghadri nami_ghadri@hotmail.com wrote:

Dears

So now I have to re-download the WAR file?

And then use it the new one ?

Thanks

From: Jan Henrik Øverland [mailto:janhenrik.overland@gmail.com]
Sent: Tuesday, June 9, 2015 7:57 PM

To: Nami Ghadri
Cc: DHIS 2 Users list
Subject: Re: [Dhis2-users] Infrastructural data

Hi Name,

This is now fixed in trunk and 2.19. Let me know if there is anything else.

Jan

On Tue, Jun 9, 2015 at 10:51 AM, Nami Ghadri nami_ghadri@hotmail.com wrote:

It seems that any dataelement that has test type is appears like that and number type appears correctly and also dataelement with date type does appears at all

Thanks in advance

From: Jan Henrik Øverland [mailto:janhenrik.overland@gmail.com]
Sent: Tuesday, June 9, 2015 11:35 AM
To: Nami Ghadri
Cc: DHIS 2 Users list
Subject: Re: [Dhis2-users] Infrastructural data

Hi Nami,

I will have a look at this and get back to you.

Jan

On Tue, Jun 9, 2015 at 10:00 AM, Nami Ghadri nami_ghadri@hotmail.com wrote:

Hello,

Whenever I use facility layer and when display data element info (Infrastructural data) some data element values appears as “NaN”

Please see the photo below on the right

Can anyone help

Thanks in advance


Mailing list: https://launchpad.net/~dhis2-users
Post to : dhis2-users@lists.launchpad.net
Unsubscribe : https://launchpad.net/~dhis2-users
More help : https://help.launchpad.net/ListHelp


Mailing list: https://launchpad.net/~dhis2-users

Post to : dhis2-users@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-users

More help : https://help.launchpad.net/ListHelp

Knut Staring

Dept. of Informatics, University of Oslo

Norway: +4791880522

Skype: knutstar

http://dhis2.org

That’s ok but I downloaded the war file again and run it but noting changed

Still have the issue

The bellow is the revision number and build date I use now

Build revision:

19209

Build date:

2015-06-10 05:38

Best regards,

···

From: Knut Staring [mailto:knutst@gmail.com]
Sent: Wednesday, June 10, 2015 9:44 AM
To: Nami Ghadri
Cc: Jan Henrik Øverland; DHIS 2 Users list
Subject: Re: [Dhis2-users] Infrastructural data

That is how it works, unless you want to build it from source code (but that will also take long time the first time).

Knut

On Wed, Jun 10, 2015 at 8:31 AM, Nami Ghadri <nami_ghadri@hotmail.com> wrote:

Dears

So now I have to re-download the WAR file?

And then use it the new one ?

Thanks

From: Jan Henrik Øverland [mailto:janhenrik.overland@gmail.com]
Sent: Tuesday, June 9, 2015 7:57 PM

Hello,

Kindly If I may check if there is any update regarding the bellow

Thanks in advance

···

From: Nami Ghadri [mailto:nami_ghadri@hotmail.com]
Sent: Wednesday, June 10, 2015 9:50 AM
To: 'Knut Staring'
Cc: 'Jan Henrik Øverland'; 'DHIS 2 Users list'
Subject: RE: [Dhis2-users] Infrastructural data

That’s ok but I downloaded the war file again and run it but noting changed

Still have the issue

The bellow is the revision number and build date I use now

Build revision:

19209

Build date:

2015-06-10 05:38

Best regards,

From: Knut Staring [mailto:knutst@gmail.com]
Sent: Wednesday, June 10, 2015 9:44 AM
To: Nami Ghadri
Cc: Jan Henrik Øverland; DHIS 2 Users list
Subject: Re: [Dhis2-users] Infrastructural data

That is how it works, unless you want to build it from source code (but that will also take long time the first time).

Knut

On Wed, Jun 10, 2015 at 8:31 AM, Nami Ghadri <nami_ghadri@hotmail.com> wrote:

Dears

So now I have to re-download the WAR file?

And then use it the new one ?

Thanks

From: Jan Henrik Øverland [mailto:janhenrik.overland@gmail.com]
Sent: Tuesday, June 9, 2015 7:57 PM

Hi Nami,

Can you please open the Chrome console (F12) and click on the Network tab. Then try to load the values and you should see an “analytics.json” request in the console. Can you please send me the response of this request?

Jan

···

On Thu, Jun 11, 2015 at 2:17 PM, Nami Ghadri nami_ghadri@hotmail.com wrote:

Hello,

Kindly If I may check if there is any update regarding the bellow

Thanks in advance

From: Nami Ghadri [mailto:nami_ghadri@hotmail.com]
Sent: Wednesday, June 10, 2015 9:50 AM
To: ‘Knut Staring’
Cc: ‘Jan Henrik Øverland’; ‘DHIS 2 Users list’
Subject: RE: [Dhis2-users] Infrastructural data

That’s ok but I downloaded the war file again and run it but noting changed

Still have the issue

The bellow is the revision number and build date I use now

Build revision:

19209

Build date:

2015-06-10 05:38

Best regards,

From: Knut Staring [mailto:knutst@gmail.com]
Sent: Wednesday, June 10, 2015 9:44 AM
To: Nami Ghadri
Cc: Jan Henrik Øverland; DHIS 2 Users list

Subject: Re: [Dhis2-users] Infrastructural data

That is how it works, unless you want to build it from source code (but that will also take long time the first time).

Knut

On Wed, Jun 10, 2015 at 8:31 AM, Nami Ghadri nami_ghadri@hotmail.com wrote:

Dears

So now I have to re-download the WAR file?

And then use it the new one ?

Thanks

From: Jan Henrik Øverland [mailto:janhenrik.overland@gmail.com]
Sent: Tuesday, June 9, 2015 7:57 PM

To: Nami Ghadri
Cc: DHIS 2 Users list
Subject: Re: [Dhis2-users] Infrastructural data

Hi Name,

This is now fixed in trunk and 2.19. Let me know if there is anything else.

Jan

On Tue, Jun 9, 2015 at 10:51 AM, Nami Ghadri nami_ghadri@hotmail.com wrote:

It seems that any dataelement that has test type is appears like that and number type appears correctly and also dataelement with date type does appears at all

Thanks in advance

From: Jan Henrik Øverland [mailto:janhenrik.overland@gmail.com]
Sent: Tuesday, June 9, 2015 11:35 AM
To: Nami Ghadri
Cc: DHIS 2 Users list
Subject: Re: [Dhis2-users] Infrastructural data

Hi Nami,

I will have a look at this and get back to you.

Jan

On Tue, Jun 9, 2015 at 10:00 AM, Nami Ghadri nami_ghadri@hotmail.com wrote:

Hello,

Whenever I use facility layer and when display data element info (Infrastructural data) some data element values appears as “NaN”

Please see the photo below on the right

Can anyone help

Thanks in advance


Mailing list: https://launchpad.net/~dhis2-users
Post to : dhis2-users@lists.launchpad.net
Unsubscribe : https://launchpad.net/~dhis2-users
More help : https://help.launchpad.net/ListHelp


Mailing list: https://launchpad.net/~dhis2-users
Post to : dhis2-users@lists.launchpad.net
Unsubscribe : https://launchpad.net/~dhis2-users
More help : https://help.launchpad.net/ListHelp

Knut Staring

Dept. of Informatics, University of Oslo

Norway: +4791880522

Skype: knutstar

http://dhis2.org

Dear

Please see the attached that I hope is what you requested

The data 1 file is from header preview

Regards,

···

From: Jan Henrik Øverland [mailto:janhenrik.overland@gmail.com]
Sent: Thursday, June 11, 2015 4:03 PM
To: Nami Ghadri
Cc: Knut Staring; DHIS 2 Users list
Subject: Re: [Dhis2-users] Infrastructural data

Hi Nami,

Can you please open the Chrome console (F12) and click on the Network tab. Then try to load the values and you should see an "analytics.json" request in the console. Can you please send me the response of this request?

Jan

On Thu, Jun 11, 2015 at 2:17 PM, Nami Ghadri <nami_ghadri@hotmail.com> wrote:

Hello,

Kindly If I may check if there is any update regarding the bellow

Thanks in advance

From: Nami Ghadri [mailto:nami_ghadri@hotmail.com]
Sent: Wednesday, June 10, 2015 9:50 AM
To: 'Knut Staring'
Cc: 'Jan Henrik Øverland'; 'DHIS 2 Users list'
Subject: RE: [Dhis2-users] Infrastructural data

That’s ok but I downloaded the war file again and run it but noting changed

Still have the issue

The bellow is the revision number and build date I use now

Build revision:

19209

Build date:

2015-06-10 05:38

Best regards,

From: Knut Staring [mailto:knutst@gmail.com]
Sent: Wednesday, June 10, 2015 9:44 AM
To: Nami Ghadri
Cc: Jan Henrik Øverland; DHIS 2 Users list

Subject: Re: [Dhis2-users] Infrastructural data

That is how it works, unless you want to build it from source code (but that will also take long time the first time).

Knut

On Wed, Jun 10, 2015 at 8:31 AM, Nami Ghadri <nami_ghadri@hotmail.com> wrote:

Dears

So now I have to re-download the WAR file?

And then use it the new one ?

Thanks

From: Jan Henrik Øverland [mailto:janhenrik.overland@gmail.com]
Sent: Tuesday, June 9, 2015 7:57 PM

Hi Nemi,

Thanks. It is fixed now. Just triggered a 2.19 build: https://apps.dhis2.org/ci/

Jan

···

On Thu, Jun 11, 2015 at 3:54 PM, Nami Ghadri nami_ghadri@hotmail.com wrote:

Dear

Please see the attached that I hope is what you requested

The data 1 file is from header preview

Regards,

From: Jan Henrik Øverland [mailto:janhenrik.overland@gmail.com]
Sent: Thursday, June 11, 2015 4:03 PM
To: Nami Ghadri
Cc: Knut Staring; DHIS 2 Users list

Subject: Re: [Dhis2-users] Infrastructural data

Hi Nami,

Can you please open the Chrome console (F12) and click on the Network tab. Then try to load the values and you should see an “analytics.json” request in the console. Can you please send me the response of this request?

Jan

On Thu, Jun 11, 2015 at 2:17 PM, Nami Ghadri nami_ghadri@hotmail.com wrote:

Hello,

Kindly If I may check if there is any update regarding the bellow

Thanks in advance

From: Nami Ghadri [mailto:nami_ghadri@hotmail.com]
Sent: Wednesday, June 10, 2015 9:50 AM
To: ‘Knut Staring’
Cc: ‘Jan Henrik Øverland’; ‘DHIS 2 Users list’
Subject: RE: [Dhis2-users] Infrastructural data

That’s ok but I downloaded the war file again and run it but noting changed

Still have the issue

The bellow is the revision number and build date I use now

Build revision:

19209

Build date:

2015-06-10 05:38

Best regards,

From: Knut Staring [mailto:knutst@gmail.com]
Sent: Wednesday, June 10, 2015 9:44 AM
To: Nami Ghadri
Cc: Jan Henrik Øverland; DHIS 2 Users list

Subject: Re: [Dhis2-users] Infrastructural data

That is how it works, unless you want to build it from source code (but that will also take long time the first time).

Knut

On Wed, Jun 10, 2015 at 8:31 AM, Nami Ghadri nami_ghadri@hotmail.com wrote:

Dears

So now I have to re-download the WAR file?

And then use it the new one ?

Thanks

From: Jan Henrik Øverland [mailto:janhenrik.overland@gmail.com]
Sent: Tuesday, June 9, 2015 7:57 PM

To: Nami Ghadri
Cc: DHIS 2 Users list
Subject: Re: [Dhis2-users] Infrastructural data

Hi Name,

This is now fixed in trunk and 2.19. Let me know if there is anything else.

Jan

On Tue, Jun 9, 2015 at 10:51 AM, Nami Ghadri nami_ghadri@hotmail.com wrote:

It seems that any dataelement that has test type is appears like that and number type appears correctly and also dataelement with date type does appears at all

Thanks in advance

From: Jan Henrik Øverland [mailto:janhenrik.overland@gmail.com]
Sent: Tuesday, June 9, 2015 11:35 AM
To: Nami Ghadri
Cc: DHIS 2 Users list
Subject: Re: [Dhis2-users] Infrastructural data

Hi Nami,

I will have a look at this and get back to you.

Jan

On Tue, Jun 9, 2015 at 10:00 AM, Nami Ghadri nami_ghadri@hotmail.com wrote:

Hello,

Whenever I use facility layer and when display data element info (Infrastructural data) some data element values appears as “NaN”

Please see the photo below on the right

Can anyone help

Thanks in advance


Mailing list: https://launchpad.net/~dhis2-users
Post to : dhis2-users@lists.launchpad.net
Unsubscribe : https://launchpad.net/~dhis2-users
More help : https://help.launchpad.net/ListHelp


Mailing list: https://launchpad.net/~dhis2-users
Post to : dhis2-users@lists.launchpad.net
Unsubscribe : https://launchpad.net/~dhis2-users
More help : https://help.launchpad.net/ListHelp

Knut Staring

Dept. of Informatics, University of Oslo

Norway: +4791880522

Skype: knutstar

http://dhis2.org

Dears,

It’s ok now

Thanks very much for great respond

Regards,

···

From: Jan Henrik Øverland [mailto:janhenrik.overland@gmail.com]
Sent: Thursday, June 11, 2015 5:48 PM
To: Nami Ghadri
Cc: Knut Staring; DHIS 2 Users list
Subject: Re: [Dhis2-users] Infrastructural data

Hi Nemi,

Thanks. It is fixed now. Just triggered a 2.19 build: https://apps.dhis2.org/ci/

Jan

On Thu, Jun 11, 2015 at 3:54 PM, Nami Ghadri <nami_ghadri@hotmail.com> wrote:

Dear

Please see the attached that I hope is what you requested

The data 1 file is from header preview

Regards,

From: Jan Henrik Øverland [mailto:janhenrik.overland@gmail.com]
Sent: Thursday, June 11, 2015 4:03 PM
To: Nami Ghadri
Cc: Knut Staring; DHIS 2 Users list

Subject: Re: [Dhis2-users] Infrastructural data

Hi Nami,

Can you please open the Chrome console (F12) and click on the Network tab. Then try to load the values and you should see an "analytics.json" request in the console. Can you please send me the response of this request?

Jan

On Thu, Jun 11, 2015 at 2:17 PM, Nami Ghadri <nami_ghadri@hotmail.com> wrote:

Hello,

Kindly If I may check if there is any update regarding the bellow

Thanks in advance

From: Nami Ghadri [mailto:nami_ghadri@hotmail.com]
Sent: Wednesday, June 10, 2015 9:50 AM
To: 'Knut Staring'
Cc: 'Jan Henrik Øverland'; 'DHIS 2 Users list'
Subject: RE: [Dhis2-users] Infrastructural data

That’s ok but I downloaded the war file again and run it but noting changed

Still have the issue

The bellow is the revision number and build date I use now

Build revision:

19209

Build date:

2015-06-10 05:38

Best regards,

From: Knut Staring [mailto:knutst@gmail.com]
Sent: Wednesday, June 10, 2015 9:44 AM
To: Nami Ghadri
Cc: Jan Henrik Øverland; DHIS 2 Users list

Subject: Re: [Dhis2-users] Infrastructural data

That is how it works, unless you want to build it from source code (but that will also take long time the first time).

Knut

On Wed, Jun 10, 2015 at 8:31 AM, Nami Ghadri <nami_ghadri@hotmail.com> wrote:

Dears

So now I have to re-download the WAR file?

And then use it the new one ?

Thanks

From: Jan Henrik Øverland [mailto:janhenrik.overland@gmail.com]
Sent: Tuesday, June 9, 2015 7:57 PM

Dears,

It’s ok now

Thanks very much for great respond

Regards,

···

From: Jan Henrik Øverland [mailto:janhenrik.overland@gmail.com]
Sent: Thursday, June 11, 2015 5:48 PM
To: Nami Ghadri
Cc: Knut Staring; DHIS 2 Users list
Subject: Re: [Dhis2-users] Infrastructural data

Hi Nemi,

Thanks. It is fixed now. Just triggered a 2.19 build: https://apps.dhis2.org/ci/

Jan

On Thu, Jun 11, 2015 at 3:54 PM, Nami Ghadri <nami_ghadri@hotmail.com> wrote:

Dear

Please see the attached that I hope is what you requested

The data 1 file is from header preview

Regards,

From: Jan Henrik Øverland [mailto:janhenrik.overland@gmail.com]
Sent: Thursday, June 11, 2015 4:03 PM
To: Nami Ghadri
Cc: Knut Staring; DHIS 2 Users list

Subject: Re: [Dhis2-users] Infrastructural data

Hi Nami,

Can you please open the Chrome console (F12) and click on the Network tab. Then try to load the values and you should see an "analytics.json" request in the console. Can you please send me the response of this request?

Jan

On Thu, Jun 11, 2015 at 2:17 PM, Nami Ghadri <nami_ghadri@hotmail.com> wrote:

Hello,

Kindly If I may check if there is any update regarding the bellow

Thanks in advance

From: Nami Ghadri [mailto:nami_ghadri@hotmail.com]
Sent: Wednesday, June 10, 2015 9:50 AM
To: 'Knut Staring'
Cc: 'Jan Henrik Øverland'; 'DHIS 2 Users list'
Subject: RE: [Dhis2-users] Infrastructural data

That’s ok but I downloaded the war file again and run it but noting changed

Still have the issue

The bellow is the revision number and build date I use now

Build revision:

19209

Build date:

2015-06-10 05:38

Best regards,

From: Knut Staring [mailto:knutst@gmail.com]
Sent: Wednesday, June 10, 2015 9:44 AM
To: Nami Ghadri
Cc: Jan Henrik Øverland; DHIS 2 Users list

Subject: Re: [Dhis2-users] Infrastructural data

That is how it works, unless you want to build it from source code (but that will also take long time the first time).

Knut

On Wed, Jun 10, 2015 at 8:31 AM, Nami Ghadri <nami_ghadri@hotmail.com> wrote:

Dears

So now I have to re-download the WAR file?

And then use it the new one ?

Thanks

From: Jan Henrik Øverland [mailto:janhenrik.overland@gmail.com]
Sent: Tuesday, June 9, 2015 7:57 PM