Help Regarding Translation

Hi,

Can anybody please explain how to Use Translate functionality in DHIS2.

I tried to add local language, but in User Settings when I changed to that local language it is not effecting. Still it is displaying in English only.

···

Regards,
Bharath Kumar. Ch

Can somebody please tell Translate functionality is working or not, if it is working how to use it?

···

On Sat, Sep 19, 2009 at 11:50 AM, bharath kumar chbharathk@gmail.com wrote:

Hi,

Can anybody please explain how to Use Translate functionality in DHIS2.

I tried to add local language, but in User Settings when I changed to that local language it is not effecting. Still it is displaying in English only.

Regards,
Bharath Kumar. Ch

Regards,
Bharath Kumar. Ch

Hi Bharath,

I tested just now, and can confirm your observations:

Adding a new locale (country code + language code) works quite nicely, and translations made get stored.

However, changing Database Language in Settings seems to have no effect - English is the only language available. This is a major bug which should be fixed urgently.

Knut

···

On Thu, Sep 24, 2009 at 10:06 AM, bharath kumar chbharathk@gmail.com wrote:

Can somebody please tell Translate functionality is working or not, if it is working how to use it?

On Sat, Sep 19, 2009 at 11:50 AM, bharath kumar chbharathk@gmail.com wrote:

Hi,

Can anybody please explain how to Use Translate functionality in DHIS2.

I tried to add local language, but in User Settings when I changed to that local language it is not effecting. Still it is displaying in English only.

Regards,
Bharath Kumar. Ch

Regards,
Bharath Kumar. Ch


Mailing list: https://launchpad.net/~dhis2-devs

Post to : dhis2-devs@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-devs

More help : https://help.launchpad.net/ListHelp


Cheers,
Knut Staring

Bharath, I suggest you have a look at it… That code was made by a student some time back and i don’t know it too well… Have a look in dhis-i18n-db.

Lars

···

On Thu, Sep 24, 2009 at 10:24 AM, Knut Staring knutst@gmail.com wrote:

Hi Bharath,

I tested just now, and can confirm your observations:

Adding a new locale (country code + language code) works quite nicely, and translations made get stored.

However, changing Database Language in Settings seems to have no effect - English is the only language available. This is a major bug which should be fixed urgently.

Knut

Bharath, did you have any time to look into what goes wrong - why the database language setting is not working or just ignored?

Knut

···

2009/9/24 Lars Helge Øverland larshelge@gmail.com

On Thu, Sep 24, 2009 at 10:24 AM, Knut Staring knutst@gmail.com wrote:

Hi Bharath,

I tested just now, and can confirm your observations:

Adding a new locale (country code + language code) works quite nicely, and translations made get stored.

However, changing Database Language in Settings seems to have no effect - English is the only language available. This is a major bug which should be fixed urgently.

Knut

Bharath, I suggest you have a look at it… That code was made by a student some time back and i don’t know it too well… Have a look in dhis-i18n-db.

Lars


Cheers,
Knut Staring

Will look into it.

···

2009/10/16 Knut Staring knutst@gmail.com

Bharath, did you have any time to look into what goes wrong - why the database language setting is not working or just ignored?

Knut

2009/9/24 Lars Helge Øverland larshelge@gmail.com

On Thu, Sep 24, 2009 at 10:24 AM, Knut Staring knutst@gmail.com wrote:

Hi Bharath,

I tested just now, and can confirm your observations:

Adding a new locale (country code + language code) works quite nicely, and translations made get stored.

However, changing Database Language in Settings seems to have no effect - English is the only language available. This is a major bug which should be fixed urgently.

Knut

Bharath, I suggest you have a look at it… That code was made by a student some time back and i don’t know it too well… Have a look in dhis-i18n-db.

Lars


Cheers,
Knut Staring

Regards,
Bharath Kumar. Ch