GIS plugin not working for 2.25 (Missing libraries above 2.22)

Hi All,

I am referring to documentation link: https://docs.dhis2.org/master/en/developer/html/dhis2_developer_manual_full.html#d9624e8068

I am trying to fetch a GIS Map using DHIS plugin from a favourite and getting following errors:

When I use: 221 libraries :

<script src="[https://dhis2-cdn.org/v221/openlayers/OpenLayers.js](https://dhis2-cdn.org/v221/openlayers/OpenLayers.js)"></script>
<script src="[https://dhis2-cdn.org/v221/plugin/map.js](https://dhis2-cdn.org/v221/plugin/map.js)"></script>
<script async defer src="[https://maps.googleapis.com/maps/api/js?key=YOUR_API_KEY&callback=initMap](https://maps.googleapis.com/maps/api/js?key=YOUR_API_KEY&callback=initMap)"
        type="text/javascript"></script>
<link rel="stylesheet" href="//[dhis2-cdn.org/v221/ext/resources/css/ext-plugin-gray.css](http://dhis2-cdn.org/v221/ext/resources/css/ext-plugin-gray.css)" />
  • Uncaught ReferenceError: gis is not defined*
  • at success (map.js:1)*
  • at Object.callback (ext-all.js:1)*
  • at m.onComplete (ext-all.js:1)*
  • at m.onStateChange (ext-all.js:1)*
  • at XMLHttpRequest. (ext-all.js:1) *

While using 2.22 libraries:

Uncaught ReferenceError: DHIS is not defined

  • at generateHtmlReport.action:237*
  • at ext-all.js:1*
  • at b (ext-all.js:1)*

Can anybody share latest libraries for 2.25 as I am not able to get any, Even in the demo application if i try to share a favourite gis it shows libraries as:

But in actual there is no library exist for v225.

Thanks,

ยทยทยท

Savita Dabral