Event Report not loading

I am using DHIS 2.30. when I try to run the event report and visualizer app, it doesn’t load. can anyone have any idea on why this is happening?
Thanks,
Derebe

1 Like

Hi @Derebe,

Can you share a screenshot of what your browser is showing when you try to run the report and visualizer app please? also; have you done a recent upgrade to 2.30?

I’m also thinking this might have something to do with your user roles; Kindly request your admin to recheck the user authorities set in the user roles you have been granted access to.

Best,
James.

Hi@ James,
Here is the screen. it even does the same if I login using the admin credentials.
Thank you,
Derebe

1 Like

1 Like

HI @Derebe erebe

Try using this trick here… URGENT: Pivot tables, Event reports (All analytics) are not working

Let me know if this helps.

Best,
James.

Hi @ James,
It works for one time and then the problem persists. should I do this every time I need the event report?
Thank you,
Derebe

1 Like

Hi @Derebe

I see that your screen is showing bubbles (loading). I have seen this many times and I would say this is normal for DHIS2 and very annoying for us.

Generally, my Event Report app works fine when I access from the office where the DHIS2 server is hosted. My users, located distantly, always face this issue. The workaround is, click the “refresh” icon/button of the browser every 15 seconds until the Event Report is loaded. Funny, isn’t. But this is what we do and mostly it works. At first, I thought the issue is related to the internet speed but experience shows that this issue can happen at any time, anywhere - whether you are near the server or miles away from the server.

Please try the workaround and let me know. Maybe we should raise this as a bug to @DEV.

* Please tick the “Solution” box below if my post helps to resolve your issue.

1 Like

@ James,
I tried but is stays loading fro ever. please help

1 Like

@ James,
when was the recent upgrade on 2.30 and how can I update mine for that? I am not an IT person by the way.
Thanks,
Derebe

1 Like

Thank you Silvaraaj, How are you doing in Botswana?
regards,
Derebe

1 Like

Thanks @Derebe. I am doing good and hope the same from you.

BTW, is your issue solved (at least after refreshing a couple of times)?

1 Like