Email server settings

I am having challenges setting up SMTP Setting on DHIS System I can’t send a test message to verify if it is sending a message and actually working. I have used my domain SMTP setting and ISP Setting but can’t have it working. Please can someone assist me on this?. @stephocay

https://docs.dhis2.org/2.27/en/user/html/system_email_settings.html

Below is DHIS Version I use.

Web API:

Browse it here

Current user:

Prosper.jorram@tnc.org

Version:

2.29

Build revision:

53cb506

Build date:

2018-11-04 02:20

Jasper reports version:

6.3.1

User agent:

Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/71.0.3578.98 Safari/537.36

Server date:

2019-01-21 12:08

Last analytics table generation:

2018-12-05 10:51

Time since last analytics table generation:

1129 h, 16 m, 46 s

Last analytics table runtime:

10 s

Environment variable:

DHIS2_HOME

External configuration directory:

/opt/devtnc

File store provider:

filesystem

Node ID:

Cache provider:

ehcache

Database type:

DhisPostgres

Database name:

Database user:

Read replica count:

0

Java opts:

Java version:

1.8.0_111

Java vendor:

Oracle Corporation

OS name:

Linux

OS architecture:

amd64

OS version:

4.14.77-70.59.amzn1.x86_64

Server memory:

Mem Total in JVM: 482 Free in JVM: 200 Max Limit: 738

CPU cores:

4

1 Like

Hi,
Have u checked your SMTP settings? It should work if settings are fine. Please refer the image below for setting up a Gmail account. (If you are using Gmail you may require to login using browser initially to go through Google security validations though).
And also do you get any errors in server logs.

1 Like