Email configuration failing

Hey there! I’m trying to set up emails in order to be able to send email notifications for tracker programs.

I’m using GMAIL address and I’m getting this response on the logs - that the email sending on the server has failed

Caused by: javax.mail.AuthenticationFailedException: 534-5.7.9 Application-specific password required. Learn more at
534 5.7.9 y12-20020adffa4c000000b0031f5f0d0be0sm4922809wrr.31 - gsmtp

        at com.sun.mail.smtp.SMTPTransport$Authenticator.authenticate(
        at com.sun.mail.smtp.SMTPTransport.authenticate(
        at com.sun.mail.smtp.SMTPTransport.protocolConnect(
        at javax.mail.Service.connect(
        at javax.mail.Service.connect(
        at javax.mail.Service.connect(
        at javax.mail.Transport.send0(
        at javax.mail.Transport.send(
        at org.apache.commons.mail.Email.sendMimeMessage(
        ... 165 more
 ( [http-nio-8080-exec-7]) IDt2/Wmc4afztCHe4xYLxMs/YF2V/tl7yz8itHaZbkhTg=

This is my configuration. Am I missing something?


It says that you need to have an application specific password, please did you configure that? Please have a look at the resource below:

What does the Network request say when you click on ‘Send a test email’?


Thank you! It turns out it was creating an application specific password which I ended up configuring! It worked seamlessly after!

1 Like

Hey @Gassim

I’ve got the same issue and this still not working for me, I keep getting this Error: “Email not sent: Sending the email to the following server failed:”, What might be the problem?

Have you set up an app-specific password?

Yes I did, but the problem persists

Hi @David

The settings might be a bit different whether you are using a personal account or a workspace; either way, please have a look at this reference: Send email from a printer, scanner, or app - Google Workspace Admin Help

If you followed all the steps in the docs mentioned in the previous post, it’s not clear why you’d see that error message. Please see if there’s any additional information you could share that might help with research what’s causing an issue connecting to the smtp.


Thank you so much @Gassim and @lillian1n2 , my problem has been solved, I don’t know what exactly was the problem but I repeated the process with a different account and now everything is fine.

Thank you.