Difficulty in deleting dataset in version 2.34.2


I have been trying to delete a dataset but it does not seem to work both with gui (even with first deleting the form and then trying to delete dataset) and console.
Console example:
curl -X DELETE -u username:password “https://serverURL/api/dataSets/dataSetUID

“username”, “password”, “serverURL”, “dataSetUID” are replaced with actual terms in actual query.

I get the following error:

{“httpStatus”:“Internal Server Error”,“httpStatusCode”:500,“status”:“ERROR”,“message”:“could not execute statement”}

It worked just fine with an earlier version - example 2.26.

Does anyone else has similar issues? Thanks in advance for any suggestions.


Hey I created a dataset in play.dhis2.org/2.34.6 and then deleted it using API and it was deleted. Could you try to do the same on play? What error do you get? Make sure you get the correct Api Url from the dataset details in the Maintenance app!

I saw a number of curl statements that had the username and password at the end like this:
curl -X DELETE “https://serverURL/api/dataSets/dataSetUID” -u username:password

Hope this helps! No worries, please feel free to post again if the issue is not solved so that I ask for further support. It would be great if you share the log as well! ( :
Do you think it would make a difference?