DHIS Import Log?

Hi,

I am importing all metadata from one instance of DHIS2 to another. The import process seems to be hanging on the Importing Users section (see attached screenshot).

Is there an import log that I can check to see what is happening?

Edwin

image

I would recommend looking at logs/catalina.out (assuming you are running tomcat)

···


Morten

On Mon, Dec 16, 2013 at 1:31 PM, Edwin Mulwa eddiemu@gmail.com wrote:

Hi,

I am importing all metadata from one instance of DHIS2 to another. The import process seems to be hanging on the Importing Users section (see attached screenshot).

Is there an import log that I can check to see what is happening?

Edwin


Mailing list: https://launchpad.net/~dhis2-devs

Post to : dhis2-devs@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-devs

More help : https://help.launchpad.net/ListHelp

Ok, thanks. Yes I am…

···

On Mon, Dec 16, 2013 at 3:37 PM, Morten Olav Hansen mortenoh@gmail.com wrote:

I would recommend looking at logs/catalina.out (assuming you are running tomcat)


Morten

On Mon, Dec 16, 2013 at 1:31 PM, Edwin Mulwa eddiemu@gmail.com wrote:

Hi,

I am importing all metadata from one instance of DHIS2 to another. The import process seems to be hanging on the Importing Users section (see attached screenshot).

Is there an import log that I can check to see what is happening?

Edwin


Mailing list: https://launchpad.net/~dhis2-devs

Post to : dhis2-devs@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-devs

More help : https://help.launchpad.net/ListHelp

Hi Morten,

You pointed me in the right direction. Thanks.

Taking a look at the log, it shows that there is a NULL value in surname field when its trying to insert a record in the userinfo table. I checked the source metadata.xml file and ensured that all surname entries have a value. I still get the same error.

See attached log snippet.

Any thoughts on why this is persisting even in the absence of NULL values?

Edwin

DHIS_Import_Log.log (9.2 KB)

···

On Mon, Dec 16, 2013 at 4:59 AM, Edwin Mulwa eddiemu@gmail.com wrote:

Ok, thanks. Yes I am…

On Mon, Dec 16, 2013 at 3:37 PM, Morten Olav Hansen mortenoh@gmail.com wrote:

I would recommend looking at logs/catalina.out (assuming you are running tomcat)


Morten

On Mon, Dec 16, 2013 at 1:31 PM, Edwin Mulwa eddiemu@gmail.com wrote:

Hi,

I am importing all metadata from one instance of DHIS2 to another. The import process seems to be hanging on the Importing Users section (see attached screenshot).

Is there an import log that I can check to see what is happening?

Edwin


Mailing list: https://launchpad.net/~dhis2-devs

Post to : dhis2-devs@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-devs

More help : https://help.launchpad.net/ListHelp

Hi Edwin,

I’m not really sure… if you know your way around a text-editor, you can try and remove all user but a few… and see if it still fails, there might be a few users in there that have some errors

···


Morten

On Mon, Dec 16, 2013 at 2:52 PM, Edwin Mulwa eddiemu@gmail.com wrote:

Hi Morten,

You pointed me in the right direction. Thanks.

Taking a look at the log, it shows that there is a NULL value in surname field when its trying to insert a record in the userinfo table. I checked the source metadata.xml file and ensured that all surname entries have a value. I still get the same error.

See attached log snippet.

Any thoughts on why this is persisting even in the absence of NULL values?

Edwin

On Mon, Dec 16, 2013 at 4:59 AM, Edwin Mulwa eddiemu@gmail.com wrote:

Ok, thanks. Yes I am…

On Mon, Dec 16, 2013 at 3:37 PM, Morten Olav Hansen mortenoh@gmail.com wrote:

I would recommend looking at logs/catalina.out (assuming you are running tomcat)


Morten

On Mon, Dec 16, 2013 at 1:31 PM, Edwin Mulwa eddiemu@gmail.com wrote:

Hi,

I am importing all metadata from one instance of DHIS2 to another. The import process seems to be hanging on the Importing Users section (see attached screenshot).

Is there an import log that I can check to see what is happening?

Edwin


Mailing list: https://launchpad.net/~dhis2-devs

Post to : dhis2-devs@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-devs

More help : https://help.launchpad.net/ListHelp

Hi All,

An interesting update is as follows:

I removed ALL the users in the XML file and managed to import everything. This of course didn’t really solve my problem because I eventually needed to import users as well.

After importation, I encountered a new problem:

When I tried to do data entry, the Data Sets combo box was not loading with data. Checking the log, I found the following message:

_* ERROR 2013-12-17 01:00:56,744 Resource table dataelementcategoryoptioncomboname does not exist, please generate it (HibernateDataElementStore.java [http-bio-8080-exec-9])

I found, from checking previous posts, that I needed to create resource tables from Maintenance->Data Administration; which I did. Then I decided to try and import all my metadata afresh, including the users (ensuring that all users have firstname and surname defined) and the import WORKED!!

What this means is that the error I was getting telling me that the surname should not be null AFTER I had rectified the source XML file was not an accurately reported error. The error must have been something to do with missing resource tables. I think this is a potential bug in DHIS that should be investigated.

Edwin

···

On Mon, Dec 16, 2013 at 5:03 PM, Morten Olav Hansen mortenoh@gmail.com wrote:

Hi Edwin,

I’m not really sure… if you know your way around a text-editor, you can try and remove all user but a few… and see if it still fails, there might be a few users in there that have some errors


Morten

On Mon, Dec 16, 2013 at 2:52 PM, Edwin Mulwa eddiemu@gmail.com wrote:

Hi Morten,

You pointed me in the right direction. Thanks.

Taking a look at the log, it shows that there is a NULL value in surname field when its trying to insert a record in the userinfo table. I checked the source metadata.xml file and ensured that all surname entries have a value. I still get the same error.

See attached log snippet.

Any thoughts on why this is persisting even in the absence of NULL values?

Edwin

On Mon, Dec 16, 2013 at 4:59 AM, Edwin Mulwa eddiemu@gmail.com wrote:

Ok, thanks. Yes I am…

On Mon, Dec 16, 2013 at 3:37 PM, Morten Olav Hansen mortenoh@gmail.com wrote:

I would recommend looking at logs/catalina.out (assuming you are running tomcat)


Morten

On Mon, Dec 16, 2013 at 1:31 PM, Edwin Mulwa eddiemu@gmail.com wrote:

Hi,

I am importing all metadata from one instance of DHIS2 to another. The import process seems to be hanging on the Importing Users section (see attached screenshot).

Is there an import log that I can check to see what is happening?

Edwin


Mailing list: https://launchpad.net/~dhis2-devs

Post to : dhis2-devs@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-devs

More help : https://help.launchpad.net/ListHelp

Hi Edwin,

there is no link between resource tables and meta-data import so I don’t think that’s significant. Since the logs says surname cannot be null I think that was the source of the problem - there might be a problem with the export function not including surnames, or some database integrity issues with the source database.

Lars

···

On Tue, Dec 17, 2013 at 11:10 AM, Edwin Mulwa eddiemu@gmail.com wrote:

Hi All,

An interesting update is as follows:

I removed ALL the users in the XML file and managed to import everything. This of course didn’t really solve my problem because I eventually needed to import users as well.

After importation, I encountered a new problem:

When I tried to do data entry, the Data Sets combo box was not loading with data. Checking the log, I found the following message:

_* ERROR 2013-12-17 01:00:56,744 Resource table dataelementcategoryoptioncomboname does not exist, please generate it (HibernateDataElementStore.java [http-bio-8080-exec-9])

I found, from checking previous posts, that I needed to create resource tables from Maintenance->Data Administration; which I did. Then I decided to try and import all my metadata afresh, including the users (ensuring that all users have firstname and surname defined) and the import WORKED!!

What this means is that the error I was getting telling me that the surname should not be null AFTER I had rectified the source XML file was not an accurately reported error. The error must have been something to do with missing resource tables. I think this is a potential bug in DHIS that should be investigated.

Edwin


Mailing list: https://launchpad.net/~dhis2-devs

Post to : dhis2-devs@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-devs

More help : https://help.launchpad.net/ListHelp

On Mon, Dec 16, 2013 at 5:03 PM, Morten Olav Hansen mortenoh@gmail.com wrote:

Hi Edwin,

I’m not really sure… if you know your way around a text-editor, you can try and remove all user but a few… and see if it still fails, there might be a few users in there that have some errors


Morten

On Mon, Dec 16, 2013 at 2:52 PM, Edwin Mulwa eddiemu@gmail.com wrote:

Hi Morten,

You pointed me in the right direction. Thanks.

Taking a look at the log, it shows that there is a NULL value in surname field when its trying to insert a record in the userinfo table. I checked the source metadata.xml file and ensured that all surname entries have a value. I still get the same error.

See attached log snippet.

Any thoughts on why this is persisting even in the absence of NULL values?

Edwin

On Mon, Dec 16, 2013 at 4:59 AM, Edwin Mulwa eddiemu@gmail.com wrote:

Ok, thanks. Yes I am…

On Mon, Dec 16, 2013 at 3:37 PM, Morten Olav Hansen mortenoh@gmail.com wrote:

I would recommend looking at logs/catalina.out (assuming you are running tomcat)


Morten

On Mon, Dec 16, 2013 at 1:31 PM, Edwin Mulwa eddiemu@gmail.com wrote:

Hi,

I am importing all metadata from one instance of DHIS2 to another. The import process seems to be hanging on the Importing Users section (see attached screenshot).

Is there an import log that I can check to see what is happening?

Edwin


Mailing list: https://launchpad.net/~dhis2-devs

Post to : dhis2-devs@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-devs

More help : https://help.launchpad.net/ListHelp

Hi Lars,

That could indeed be the case though the interesting thing is that it was only after I created the resources tables that the import went through - using the same dataset that had failed initially when I did not do the resource tables creation. I tested this multiple times just to be sure. A caveat to that is I haven’t tested this process again since I managed to make my DHIS installation use an actual database instead of an in-memory database. Will make time to test that and see what happens.

Edwin

···

On Wed, Dec 18, 2013 at 6:23 PM, Lars Helge Øverland larshelge@gmail.com wrote:

Hi Edwin,

there is no link between resource tables and meta-data import so I don’t think that’s significant. Since the logs says surname cannot be null I think that was the source of the problem - there might be a problem with the export function not including surnames, or some database integrity issues with the source database.

Lars

On Tue, Dec 17, 2013 at 11:10 AM, Edwin Mulwa eddiemu@gmail.com wrote:

Hi All,

An interesting update is as follows:

I removed ALL the users in the XML file and managed to import everything. This of course didn’t really solve my problem because I eventually needed to import users as well.

After importation, I encountered a new problem:

When I tried to do data entry, the Data Sets combo box was not loading with data. Checking the log, I found the following message:

_* ERROR 2013-12-17 01:00:56,744 Resource table dataelementcategoryoptioncomboname does not exist, please generate it (HibernateDataElementStore.java [http-bio-8080-exec-9])

I found, from checking previous posts, that I needed to create resource tables from Maintenance->Data Administration; which I did. Then I decided to try and import all my metadata afresh, including the users (ensuring that all users have firstname and surname defined) and the import WORKED!!

What this means is that the error I was getting telling me that the surname should not be null AFTER I had rectified the source XML file was not an accurately reported error. The error must have been something to do with missing resource tables. I think this is a potential bug in DHIS that should be investigated.

Edwin


Mailing list: https://launchpad.net/~dhis2-devs

Post to : dhis2-devs@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-devs

More help : https://help.launchpad.net/ListHelp

On Mon, Dec 16, 2013 at 5:03 PM, Morten Olav Hansen mortenoh@gmail.com wrote:

Hi Edwin,

I’m not really sure… if you know your way around a text-editor, you can try and remove all user but a few… and see if it still fails, there might be a few users in there that have some errors


Morten

On Mon, Dec 16, 2013 at 2:52 PM, Edwin Mulwa eddiemu@gmail.com wrote:

Hi Morten,

You pointed me in the right direction. Thanks.

Taking a look at the log, it shows that there is a NULL value in surname field when its trying to insert a record in the userinfo table. I checked the source metadata.xml file and ensured that all surname entries have a value. I still get the same error.

See attached log snippet.

Any thoughts on why this is persisting even in the absence of NULL values?

Edwin

On Mon, Dec 16, 2013 at 4:59 AM, Edwin Mulwa eddiemu@gmail.com wrote:

Ok, thanks. Yes I am…

On Mon, Dec 16, 2013 at 3:37 PM, Morten Olav Hansen mortenoh@gmail.com wrote:

I would recommend looking at logs/catalina.out (assuming you are running tomcat)


Morten

On Mon, Dec 16, 2013 at 1:31 PM, Edwin Mulwa eddiemu@gmail.com wrote:

Hi,

I am importing all metadata from one instance of DHIS2 to another. The import process seems to be hanging on the Importing Users section (see attached screenshot).

Is there an import log that I can check to see what is happening?

Edwin


Mailing list: https://launchpad.net/~dhis2-devs

Post to : dhis2-devs@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-devs

More help : https://help.launchpad.net/ListHelp

Okay thank you Edwin…

Lars

···

On Thu, Dec 19, 2013 at 9:16 AM, Edwin Mulwa eddiemu@gmail.com wrote:

Hi Lars,

That could indeed be the case though the interesting thing is that it was only after I created the resources tables that the import went through - using the same dataset that had failed initially when I did not do the resource tables creation. I tested this multiple times just to be sure. A caveat to that is I haven’t tested this process again since I managed to make my DHIS installation use an actual database instead of an in-memory database. Will make time to test that and see what happens.

Edwin

On Wed, Dec 18, 2013 at 6:23 PM, Lars Helge Øverland larshelge@gmail.com wrote:

Hi Edwin,

there is no link between resource tables and meta-data import so I don’t think that’s significant. Since the logs says surname cannot be null I think that was the source of the problem - there might be a problem with the export function not including surnames, or some database integrity issues with the source database.

Lars

On Tue, Dec 17, 2013 at 11:10 AM, Edwin Mulwa eddiemu@gmail.com wrote:

Hi All,

An interesting update is as follows:

I removed ALL the users in the XML file and managed to import everything. This of course didn’t really solve my problem because I eventually needed to import users as well.

After importation, I encountered a new problem:

When I tried to do data entry, the Data Sets combo box was not loading with data. Checking the log, I found the following message:

_* ERROR 2013-12-17 01:00:56,744 Resource table dataelementcategoryoptioncomboname does not exist, please generate it (HibernateDataElementStore.java [http-bio-8080-exec-9])

I found, from checking previous posts, that I needed to create resource tables from Maintenance->Data Administration; which I did. Then I decided to try and import all my metadata afresh, including the users (ensuring that all users have firstname and surname defined) and the import WORKED!!

What this means is that the error I was getting telling me that the surname should not be null AFTER I had rectified the source XML file was not an accurately reported error. The error must have been something to do with missing resource tables. I think this is a potential bug in DHIS that should be investigated.

Edwin


Mailing list: https://launchpad.net/~dhis2-devs

Post to : dhis2-devs@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-devs

More help : https://help.launchpad.net/ListHelp

On Mon, Dec 16, 2013 at 5:03 PM, Morten Olav Hansen mortenoh@gmail.com wrote:

Hi Edwin,

I’m not really sure… if you know your way around a text-editor, you can try and remove all user but a few… and see if it still fails, there might be a few users in there that have some errors


Morten

On Mon, Dec 16, 2013 at 2:52 PM, Edwin Mulwa eddiemu@gmail.com wrote:

Hi Morten,

You pointed me in the right direction. Thanks.

Taking a look at the log, it shows that there is a NULL value in surname field when its trying to insert a record in the userinfo table. I checked the source metadata.xml file and ensured that all surname entries have a value. I still get the same error.

See attached log snippet.

Any thoughts on why this is persisting even in the absence of NULL values?

Edwin

On Mon, Dec 16, 2013 at 4:59 AM, Edwin Mulwa eddiemu@gmail.com wrote:

Ok, thanks. Yes I am…

On Mon, Dec 16, 2013 at 3:37 PM, Morten Olav Hansen mortenoh@gmail.com wrote:

I would recommend looking at logs/catalina.out (assuming you are running tomcat)


Morten

On Mon, Dec 16, 2013 at 1:31 PM, Edwin Mulwa eddiemu@gmail.com wrote:

Hi,

I am importing all metadata from one instance of DHIS2 to another. The import process seems to be hanging on the Importing Users section (see attached screenshot).

Is there an import log that I can check to see what is happening?

Edwin


Mailing list: https://launchpad.net/~dhis2-devs

Post to : dhis2-devs@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-devs

More help : https://help.launchpad.net/ListHelp