DHIS 2.34 Debian 10 Compatibility

Hello everybody,

Do you know if DHIS 2.34 can work on Debian > 9 ?
I’ve a doubt because of these two lines :

Later DHIS2 versions require the following software versions to operate.

  • Java JDK or JRE version 8 or later.
  • Any operating system for which a Java JDK or JRE version 8 exists

(Java JDK or JRE version 8 are not present on debian 8 natively)
I’ve tried upgrading / reinstall etc, but I have got some error log each time during deployment (and 404 page).

By the way our server provider only provide Debian OS…

Thanks,

Florent

Hello @Fbeaudoin,
I have tried to install DHIS2 on Debian following this guide: dhis2 Docker (on Debian ) | Developers Portal in the Developers Portal and everything worked out fine; however, this guide uses docker and it is meant to be used for developers, but I thought I’d share this with you as a start to hear your opinion.

Additionally, have you tried using another later version of DHIS2? And would it be possible to share the error log (without including sensitive info). Thank you!

Hello, (and thanks you for your prompt response!)

In fact you’re right, it seems to work well using Docker!
I was trying the version 2.34 because we already had a database (and i’m not in the development part, but i saw structure of databases are not all the same depending on different version ?).

1 Like

@Fbeaudoin you’re welcome! Thanks! I’m glad it’s working.

I think there are always slight changes and improvements, yes, and this might be the reason why to move the data from a 2.34 instance to a 2.37 instance for example, it’s necessary to upgrade the 2.34 instance first and then be able to move the data. :pray:

Thanks a lot for your answer, i wish you to have an happy new year!

1 Like

Thanks! You too @Fbeaudoin! :blush::tada::tada: