Create table analytics_event_temp errors


I am having this same issue even though i have PostGIS installed. My error shows as follows:

Process failed: StatementCallback; SQL [create table analytics_event_temp_zdy65vlw3jq (“uidlevel1” character(11),“uidlevel2” character(11),“uidlevel3” character(11),"uidleve…

Please help.

Hi @minyoi

Welcome to the community! :tada:

Please share the version details for your enviorment (dhis2 instance, PostgreSQL, PostGIS, Java, OS…etc) and please share the full Catalina.out log (without the sensitive info)

Thank you!

Hi @Gassim

Thanks, its good to be here.

DHIS2 instance is 2.30
Postgresql 10
PostGIS 2.0
Java: jdk 1.8.0_171
jre 1.8.0_171
OS: Windows Server 2016

Please find attached the catalina.out log

Its been stable for the past 2 years before this.

Thank you!

From the log, I see lots of ‘memory leak’ … please did you try to clear server cache (Data Administration app → Maintenance → Clear analytics tables, Clear application cache, & Reload apps). If possible maybe restart the instance after clearing the cache, too!


Thanks @Gassim, tried the above instructions but it hasn’t worked. Still getting the same error.