Bulk Load app issue

Good day everyone.

I installed the Bulk load app but the app gives me this error message.
“It seems this user account does not have any permission. Please get in touch with the admin if you need access to these sections.”

Please how can I resolve this issue.
Note: This is on my localhost instance.

@Mr_jorge In response to your inquiry, it seems like there it’s a permission issue.
Try logging in as the admin or contact the admin and follow the following steps:

  • Go to the Users app in the app menu

  • Check the Bulk upload app for the user role assigned to the user

I hope our response is able to solve the issue you were facing.

With :heavy_heart_exclamation: from the Dhistance Team.

DHISTANCE.com: The Easiest DHIS2 Setup. Up and running in 5 minutes!

No technical knowledge needed! Great Support with Data Security/Confidentiality.

1 Like

Thank you for your response @e4eDHIS2 I have already tried this and it didn’t work.

1 Like

It might be you don’t have the right permissions set (anymore) for the default admin user that comes with the instance. Maybe you can try username system password System123 as login for the system user, and then change the permission for your admin user or do it from there.

1 Like

@Mr_jorge, please did you try to clear the cache (sometimes it needs hard reload and empty cache.) To be 100% sure it’s not a cache error after clearing the cache in Data Administration app → Maintenance, login in the Guest mode of your browser, and check again.

Also, I believe you are facing this issue when you first open the Bulk Load app, right? What version of the app are you using and what is the dhis2 version?

Thank you!

I’ve been dealing with the same problem for a long time, and it’s still bothering me. I followed all the steps outlined here, but no joy. I am the superuser, and I oversee setting up the instance. @Mr_jorge and Dhis2 family team let me know when get the final solution ,probably we are doing something wrong on our side

Thank you @Rene. I have tried the above Username and Password and it did not work.

Thank you @Gassim
I have cleared the cache and refresh all apps multiple times through the Data administration app, that did not solve the problem.

I switched to the other database I have and I didn’t experience the error.

I am using DHIS2 v 2.37.9. I also uninstalled and tried a previous versions of the Bulk Load app and experienced the same issue.

Thank you for your continued assistance.

Then this sounds like it’s an issue from the DB, could you please share the Catalina.out log (without sensitive info)? We might be able to get a hint.


@Gassim @Shapr0019 @Rene

Hi Everyone.
I have found the solution to the issue.

  1. Goto the Datastore Management App
  2. Locate Bulk-load
  3. Find BULK_LOAD_SETTINGS and tick the boxes as shown on the image below and Save.
    This process should solve the access issue.

Thank you everyone for you assistance and contribution


@Mr_jorge you made an excellent observation and analysis. It is now back on my side. Thank you very much.

1 Like

@Mr_jorge thank you for sharing the solution! :slight_smile: :+1::+1: