[Bug 1506317] [NEW] 'paging=false' not being understood by event api

Public bug reported:

Hello,

I am trying to turn off the automatic page limit default for viewing
events in the api (e.g. server/api/events). The default page limit is
set to 50 but I am unable to turn off with the following syntax:
server/api/events?paging=off. That syntax will still only return 50
results.

Interestingly, I am able to go from page to page (e.g.
server/api/events?page=2), but I am unable to turn paging off
completely.

For reference, I am on a v2.20 version with build 19914. I am also using
an updated version of Chrome.

Please let me know if this is a bug or if there is something I can do to
address.

Thank you,

Graham Smith

Population Services International

** Affects: dhis2
     Importance: Undecided
         Status: New

···

--
You received this bug notification because you are a member of DHIS 2
developers, which is subscribed to DHIS.
https://bugs.launchpad.net/bugs/1506317

Title:
  'paging=false' not being understood by event api

Status in DHIS:
  New

Bug description:
  Hello,

  I am trying to turn off the automatic page limit default for viewing
  events in the api (e.g. server/api/events). The default page limit is
  set to 50 but I am unable to turn off with the following syntax:
  server/api/events?paging=off. That syntax will still only return 50
  results.

  Interestingly, I am able to go from page to page (e.g.
  server/api/events?page=2), but I am unable to turn paging off
  completely.

  For reference, I am on a v2.20 version with build 19914. I am also
  using an updated version of Chrome.

  Please let me know if this is a bug or if there is something I can do
  to address.

  Thank you,

  Graham Smith

  Population Services International

To manage notifications about this bug go to:
https://bugs.launchpad.net/dhis2/+bug/1506317/+subscriptions

Hi

For events API, you must use skipPaging=true

···

--
Morten

On Thu, Oct 15, 2015 at 12:17 PM, Graham Smith <gtsmith@psi.org> wrote:

Public bug reported:

Hello,

I am trying to turn off the automatic page limit default for viewing
events in the api (e.g. server/api/events). The default page limit is
set to 50 but I am unable to turn off with the following syntax:
server/api/events?paging=off. That syntax will still only return 50
results.

Interestingly, I am able to go from page to page (e.g.
server/api/events?page=2), but I am unable to turn paging off
completely.

For reference, I am on a v2.20 version with build 19914. I am also using
an updated version of Chrome.

Please let me know if this is a bug or if there is something I can do to
address.

Thank you,

Graham Smith

Population Services International

** Affects: dhis2
     Importance: Undecided
         Status: New

--
You received this bug notification because you are subscribed to DHIS.
https://bugs.launchpad.net/bugs/1506317

Title:
  'paging=false' not being understood by event api

Status in DHIS:
  New

Bug description:
  Hello,

  I am trying to turn off the automatic page limit default for viewing
  events in the api (e.g. server/api/events). The default page limit is
  set to 50 but I am unable to turn off with the following syntax:
  server/api/events?paging=off. That syntax will still only return 50
  results.

  Interestingly, I am able to go from page to page (e.g.
  server/api/events?page=2), but I am unable to turn paging off
  completely.

  For reference, I am on a v2.20 version with build 19914. I am also
  using an updated version of Chrome.

  Please let me know if this is a bug or if there is something I can do
  to address.

  Thank you,

  Graham Smith

  Population Services International

To manage notifications about this bug go to:
https://bugs.launchpad.net/dhis2/+bug/1506317/+subscriptions

--
You received this bug notification because you are a member of DHIS 2
developers, which is subscribed to DHIS.
https://bugs.launchpad.net/bugs/1506317

Title:
  'paging=false' not being understood by event api

Status in DHIS:
  New

Bug description:
  Hello,

  I am trying to turn off the automatic page limit default for viewing
  events in the api (e.g. server/api/events). The default page limit is
  set to 50 but I am unable to turn off with the following syntax:
  server/api/events?paging=off. That syntax will still only return 50
  results.

  Interestingly, I am able to go from page to page (e.g.
  server/api/events?page=2), but I am unable to turn paging off
  completely.

  For reference, I am on a v2.20 version with build 19914. I am also
  using an updated version of Chrome.

  Please let me know if this is a bug or if there is something I can do
  to address.

  Thank you,

  Graham Smith

  Population Services International

To manage notifications about this bug go to:
https://bugs.launchpad.net/dhis2/+bug/1506317/+subscriptions

This is documented here:

https://www.dhis2.org/doc/snapshot/en/developer/html/ch01s13.html#d5e1814

** Changed in: dhis2
       Status: New => Invalid

···

--
You received this bug notification because you are a member of DHIS 2
developers, which is subscribed to DHIS.
https://bugs.launchpad.net/bugs/1506317

Title:
  'paging=false' not being understood by event api

Status in DHIS:
  Invalid

Bug description:
  Hello,

  I am trying to turn off the automatic page limit default for viewing
  events in the api (e.g. server/api/events). The default page limit is
  set to 50 but I am unable to turn off with the following syntax:
  server/api/events?paging=off. That syntax will still only return 50
  results.

  Interestingly, I am able to go from page to page (e.g.
  server/api/events?page=2), but I am unable to turn paging off
  completely.

  For reference, I am on a v2.20 version with build 19914. I am also
  using an updated version of Chrome.

  Please let me know if this is a bug or if there is something I can do
  to address.

  Thank you,

  Graham Smith

  Population Services International

To manage notifications about this bug go to:
https://bugs.launchpad.net/dhis2/+bug/1506317/+subscriptions

Hi Graham,

Its not a bug I think , but should be "paging=false"

Regards,
Jason

···

On Thu, Oct 15, 2015 at 7:17 AM, Graham Smith <gtsmith@psi.org> wrote:

Public bug reported:

Hello,

I am trying to turn off the automatic page limit default for viewing
events in the api (e.g. server/api/events). The default page limit is
set to 50 but I am unable to turn off with the following syntax:
server/api/events?paging=off. That syntax will still only return 50
results.

Interestingly, I am able to go from page to page (e.g.
server/api/events?page=2), but I am unable to turn paging off
completely.

For reference, I am on a v2.20 version with build 19914. I am also using
an updated version of Chrome.

Please let me know if this is a bug or if there is something I can do to
address.

Thank you,

Graham Smith

Population Services International

** Affects: dhis2
     Importance: Undecided
         Status: New

--
You received this bug notification because you are a member of DHIS 2
developers, which is subscribed to DHIS.
https://bugs.launchpad.net/bugs/1506317

Title:
  'paging=false' not being understood by event api

Status in DHIS:
  New

Bug description:
  Hello,

  I am trying to turn off the automatic page limit default for viewing
  events in the api (e.g. server/api/events). The default page limit is
  set to 50 but I am unable to turn off with the following syntax:
  server/api/events?paging=off. That syntax will still only return 50
  results.

  Interestingly, I am able to go from page to page (e.g.
  server/api/events?page=2), but I am unable to turn paging off
  completely.

  For reference, I am on a v2.20 version with build 19914. I am also
  using an updated version of Chrome.

  Please let me know if this is a bug or if there is something I can do
  to address.

  Thank you,

  Graham Smith

  Population Services International

To manage notifications about this bug go to:
https://bugs.launchpad.net/dhis2/+bug/1506317/+subscriptions

_______________________________________________
Mailing list: https://launchpad.net/~dhis2-devs
Post to : dhis2-devs@lists.launchpad.net
Unsubscribe : https://launchpad.net/~dhis2-devs
More help : https://help.launchpad.net/ListHelp

--
Jason P. Pickering
email: jason.p.pickering@gmail.com
tel:+46764147049

--
You received this bug notification because you are a member of DHIS 2
developers, which is subscribed to DHIS.
https://bugs.launchpad.net/bugs/1506317

Title:
  'paging=false' not being understood by event api

Status in DHIS:
  Invalid

Bug description:
  Hello,

  I am trying to turn off the automatic page limit default for viewing
  events in the api (e.g. server/api/events). The default page limit is
  set to 50 but I am unable to turn off with the following syntax:
  server/api/events?paging=off. That syntax will still only return 50
  results.

  Interestingly, I am able to go from page to page (e.g.
  server/api/events?page=2), but I am unable to turn paging off
  completely.

  For reference, I am on a v2.20 version with build 19914. I am also
  using an updated version of Chrome.

  Please let me know if this is a bug or if there is something I can do
  to address.

  Thank you,

  Graham Smith

  Population Services International

To manage notifications about this bug go to:
https://bugs.launchpad.net/dhis2/+bug/1506317/+subscriptions

Is there a reason why this is different from the normal behaviour?

···

On Thu, Oct 15, 2015 at 10:27 AM, Lars Helge Øverland <larshelge@gmail.com> wrote:

This is documented here:

https://www.dhis2.org/doc/snapshot/en/developer/html/ch01s13.html#d5e1814

** Changed in: dhis2
       Status: New => Invalid

--
You received this bug notification because you are a member of DHIS 2
developers, which is subscribed to DHIS.
https://bugs.launchpad.net/bugs/1506317

Title:
  'paging=false' not being understood by event api

Status in DHIS:
  Invalid

Bug description:
  Hello,

  I am trying to turn off the automatic page limit default for viewing
  events in the api (e.g. server/api/events). The default page limit is
  set to 50 but I am unable to turn off with the following syntax:
  server/api/events?paging=off. That syntax will still only return 50
  results.

  Interestingly, I am able to go from page to page (e.g.
  server/api/events?page=2), but I am unable to turn paging off
  completely.

  For reference, I am on a v2.20 version with build 19914. I am also
  using an updated version of Chrome.

  Please let me know if this is a bug or if there is something I can do
  to address.

  Thank you,

  Graham Smith

  Population Services International

To manage notifications about this bug go to:
https://bugs.launchpad.net/dhis2/+bug/1506317/+subscriptions

_______________________________________________
Mailing list: https://launchpad.net/~dhis2-devs
Post to : dhis2-devs@lists.launchpad.net
Unsubscribe : https://launchpad.net/~dhis2-devs
More help : https://help.launchpad.net/ListHelp

--
You received this bug notification because you are a member of DHIS 2
developers, which is subscribed to DHIS.
https://bugs.launchpad.net/bugs/1506317

Title:
  'paging=false' not being understood by event api

Status in DHIS:
  Invalid

Bug description:
  Hello,

  I am trying to turn off the automatic page limit default for viewing
  events in the api (e.g. server/api/events). The default page limit is
  set to 50 but I am unable to turn off with the following syntax:
  server/api/events?paging=off. That syntax will still only return 50
  results.

  Interestingly, I am able to go from page to page (e.g.
  server/api/events?page=2), but I am unable to turn paging off
  completely.

  For reference, I am on a v2.20 version with build 19914. I am also
  using an updated version of Chrome.

  Please let me know if this is a bug or if there is something I can do
  to address.

  Thank you,

  Graham Smith

  Population Services International

To manage notifications about this bug go to:
https://bugs.launchpad.net/dhis2/+bug/1506317/+subscriptions