[Bug 1501236] [NEW] Server cache issues to html standard report

Public bug reported:

We are using DHIS 2 version 2.19 R19258 for Aggregate Data Value. Recently we realized that there's an issue with the html standard report. The report runs successfully at the first time, but if we change the data value in data entry screen, run Data Analytics and Data Mart, then run the report, the value on report still doesn't change. If we clear the server cache, it works fine.
The problem is our user want to see report regularly and we need the value update after run Data Mart feature. How can we solve this?

** Affects: dhis2
     Importance: Undecided
         Status: New

···

--
You received this bug notification because you are a member of DHIS 2
developers, which is subscribed to DHIS.
https://bugs.launchpad.net/bugs/1501236

Title:
  Server cache issues to html standard report

Status in DHIS:
  New

Bug description:
  We are using DHIS 2 version 2.19 R19258 for Aggregate Data Value. Recently we realized that there's an issue with the html standard report. The report runs successfully at the first time, but if we change the data value in data entry screen, run Data Analytics and Data Mart, then run the report, the value on report still doesn't change. If we clear the server cache, it works fine.
  The problem is our user want to see report regularly and we need the value update after run Data Mart feature. How can we solve this?

To manage notifications about this bug go to:
https://bugs.launchpad.net/dhis2/+bug/1501236/+subscriptions

Hi Em, you can disable caching of analytical content from system
settings -> general -> cache strategy -> no cache. Not a bug.

···

--
You received this bug notification because you are a member of DHIS 2
developers, which is subscribed to DHIS.
https://bugs.launchpad.net/bugs/1501236

Title:
  Server cache issues to html standard report

Status in DHIS:
  New

Bug description:
  We are using DHIS 2 version 2.19 R19258 for Aggregate Data Value. Recently we realized that there's an issue with the html standard report. The report runs successfully at the first time, but if we change the data value in data entry screen, run Data Analytics and Data Mart, then run the report, the value on report still doesn't change. If we clear the server cache, it works fine.
  The problem is our user want to see report regularly and we need the value update after run Data Mart feature. How can we solve this?

To manage notifications about this bug go to:
https://bugs.launchpad.net/dhis2/+bug/1501236/+subscriptions

Thank you Lars, I will try

···

On Wed, Sep 30, 2015, 16:15 Lars Helge Øverland <larshelge@gmail.com> wrote:

Hi Em, you can disable caching of analytical content from system
settings -> general -> cache strategy -> no cache. Not a bug.

--
You received this bug notification because you are subscribed to the bug
report.
https://bugs.launchpad.net/bugs/1501236

Title:
  Server cache issues to html standard report

Status in DHIS:
  New

Bug description:
  We are using DHIS 2 version 2.19 R19258 for Aggregate Data Value.
Recently we realized that there's an issue with the html standard report.
The report runs successfully at the first time, but if we change the data
value in data entry screen, run Data Analytics and Data Mart, then run the
report, the value on report still doesn't change. If we clear the server
cache, it works fine.
  The problem is our user want to see report regularly and we need the
value update after run Data Mart feature. How can we solve this?

To manage notifications about this bug go to:
https://bugs.launchpad.net/dhis2/+bug/1501236/+subscriptions

--
You received this bug notification because you are a member of DHIS 2
developers, which is subscribed to DHIS.
https://bugs.launchpad.net/bugs/1501236

Title:
  Server cache issues to html standard report

Status in DHIS:
  New

Bug description:
  We are using DHIS 2 version 2.19 R19258 for Aggregate Data Value. Recently we realized that there's an issue with the html standard report. The report runs successfully at the first time, but if we change the data value in data entry screen, run Data Analytics and Data Mart, then run the report, the value on report still doesn't change. If we clear the server cache, it works fine.
  The problem is our user want to see report regularly and we need the value update after run Data Mart feature. How can we solve this?

To manage notifications about this bug go to:
https://bugs.launchpad.net/dhis2/+bug/1501236/+subscriptions