Automatically disable the program rules of an instance

Hello everyone,
We had a dhis2 instance on version 36.4.
There we had a tracker program working as expected with all the program rules. It was working on web and (most of them) on the android app.
Suddenly, all the program rules don’t work. Neither web nor android app.
We though it could be because of the version so we update it to version 36.13. and it still not working.
It is very strange, has anyone come across anything similar?
Thank you all,
Cristina

Welcome back to the community @cristina.barrena! Thank you for your post!

I’ve not come across an issue where ALL program rules stop working! What if you create a new program rule, does it work?

Regarding the program rules, were there any change to the UIDs of metadata? Sharing settings?

Please share the full Catalina.out log (without sensitive info) and if possible check the console and network tabs in the Browser’s DevTools (F12) to see if there are error messages that you could share. This does need more debugging and troubleshooting. Thank you!

@cristina.barrena, open your any enrolment of your program on your computer and open the console pls. There you may find some errors or messages.

If there are no errors shown try to add &verbose to the end of address you can see on the adresse bar. By adding this you will get additional messages on execution of each program rules.

Hope this will help you to debug and solve your problem.
Regards, Ulanbek

1 Like

Thank you both.
We had some old metadata that we weren’t using, so we decided to “clean our server” and delete all the inneccesary fields and program rules.
It seems that this worked!