After upgrade to v2.24 got error

Hi all,
after i upgrade from 2.20 until 2.24.

i got this problem: it doesn’t show attribute label and value of attribute is not proper.

please help,

thanks,

chananra

Did you do the upgrade step by step (2.21, 2.22, 2.23) and running all scripts?

Knut

···

On Tue, Aug 8, 2017 at 10:22 AM, channara rin rin.channara@gmail.com wrote:

Hi all,
after i upgrade from 2.20 until 2.24.

i got this problem: it doesn’t show attribute label and value of attribute is not proper.

please help,

thanks,

chananra


Mailing list: https://launchpad.net/~dhis2-users

Post to : dhis2-users@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-users

More help : https://help.launchpad.net/ListHelp

Knut Staring

Dept. of Informatics, University of Oslo

Norway: +4791880522

Skype: knutstar

http://dhis2.org

‎Knut,

Must the upgrade be step by step?

Does it mean that if the upgrade is not done step by step, you are likely to have issues?

If the answers to the above questions is YES, what then should be done to rectify it?

Thank you.

···

On Tue, Aug 8, 2017 at 10:22 AM, channara rin rin.channara@gmail.com wrote:

Hi all,
after i upgrade from 2.20 until 2.24.

i got this problem: it doesn’t show attribute label and value of attribute is not proper.

please help,

thanks,

chananra


Mailing list: https://launchpad.net/~dhis2-users

Post to : dhis2-users@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-users

More help : https://help.launchpad.net/ListHelp

Knut Staring

Dept. of Informatics, University of Oslo

Norway: +4791880522

Skype: knutstar

http://dhis2.org

Dear Bayo,

Lars is the best to comment on this, but most (all?) releases make some changes to the database structure (mainly additions, but not exclusively). Therefore, it is usually necessary (and most prudent as a general rule) to do things step by step, which of course is a bit of a drag if you are lagging far behind. This is why we encourage everyone to be no more than 2 releases behind (which means 1 year old files). In addition, certain releases have SQL scripts that must be executed and should not be skipped.

Also note that it is a good idea check for new builds of your particular version (e.g. 2.25) as bugfixes are committed and backported on a regular basis. However, this is usually not the case for really old releases (e.g. 2.18).

Knut

···

On Tue, Aug 8, 2017 at 5:01 PM, Bayo Mohammed Onimode bayonimode@yahoo.co.uk wrote:

‎Knut,

Must the upgrade be step by step?

Does it mean that if the upgrade is not done step by step, you are likely to have issues?

If the answers to the above questions is YES, what then should be done to rectify it?

Thank you.

God Bless Nigeria,

Bayo Mohammed Onimode
ICT4D & MERL Professional
(FIIM, MBCS, MACM, MCPN, MNCS, MCPM, AMNIM)
Tel: +234.809.812.3465; +234.805.236.7163
Skype: Bayonimode

From: Knut Staring

Sent: Tuesday, 8 August 2017 11:04

To: channara rin

Cc: DHIS 2 Users list

Subject: Re: [Dhis2-users] After upgrade to v2.24 got error

Did you do the upgrade step by step (2.21, 2.22, 2.23) and running all scripts?

Knut

On Tue, Aug 8, 2017 at 10:22 AM, channara rin rin.channara@gmail.com wrote:

Hi all,
after i upgrade from 2.20 until 2.24.

i got this problem: it doesn’t show attribute label and value of attribute is not proper.

please help,

thanks,

chananra


Mailing list: https://launchpad.net/~dhis2-users

Post to : dhis2-users@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-users

More help : https://help.launchpad.net/ListHelp


Knut Staring

Dept. of Informatics, University of Oslo

Norway: +4791880522

Skype: knutstar

http://dhis2.org

Knut Staring

Dept. of Informatics, University of Oslo

Norway: +4791880522

Skype: knutstar

http://dhis2.org

Hi Knuts,

Related to Channara issue, it’s the server cache, I guided him and he already solved it. And of course we have to follow the upgrade-notes.

Regards,

···

On Tue, Aug 8, 2017 at 10:15 PM, Knut Staring knutst@gmail.com wrote:

Dear Bayo,

Lars is the best to comment on this, but most (all?) releases make some changes to the database structure (mainly additions, but not exclusively). Therefore, it is usually necessary (and most prudent as a general rule) to do things step by step, which of course is a bit of a drag if you are lagging far behind. This is why we encourage everyone to be no more than 2 releases behind (which means 1 year old files). In addition, certain releases have SQL scripts that must be executed and should not be skipped.

Also note that it is a good idea check for new builds of your particular version (e.g. 2.25) as bugfixes are committed and backported on a regular basis. However, this is usually not the case for really old releases (e.g. 2.18).

Knut


Mailing list: https://launchpad.net/~dhis2-users

Post to : dhis2-users@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-users

More help : https://help.launchpad.net/ListHelp

On Tue, Aug 8, 2017 at 5:01 PM, Bayo Mohammed Onimode bayonimode@yahoo.co.uk wrote:

‎Knut,

Must the upgrade be step by step?

Does it mean that if the upgrade is not done step by step, you are likely to have issues?

If the answers to the above questions is YES, what then should be done to rectify it?

Thank you.

God Bless Nigeria,

Bayo Mohammed Onimode
ICT4D & MERL Professional
(FIIM, MBCS, MACM, MCPN, MNCS, MCPM, AMNIM)
Tel: +234.809.812.3465; +234.805.236.7163
Skype: Bayonimode

From: Knut Staring

Sent: Tuesday, 8 August 2017 11:04

To: channara rin

Cc: DHIS 2 Users list

Subject: Re: [Dhis2-users] After upgrade to v2.24 got error

Did you do the upgrade step by step (2.21, 2.22, 2.23) and running all scripts?

Knut


Knut Staring

Dept. of Informatics, University of Oslo

Norway: +4791880522

Skype: knutstar

http://dhis2.org

On Tue, Aug 8, 2017 at 10:22 AM, channara rin rin.channara@gmail.com wrote:

Hi all,
after i upgrade from 2.20 until 2.24.

i got this problem: it doesn’t show attribute label and value of attribute is not proper.

please help,

thanks,

chananra


Mailing list: https://launchpad.net/~dhis2-users

Post to : dhis2-users@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-users

More help : https://help.launchpad.net/ListHelp


Knut Staring

Dept. of Informatics, University of Oslo

Norway: +4791880522

Skype: knutstar

http://dhis2.org

Em Le Hong
DHIS2 Implementation| **HISP Vietnam **

em.hispvietnam@gmail.com | Skype: em.hispvietnam@gmail.com

Hi Bayo

Just to add a little to what Knut said. There is no rule set in stone that you must upgrade step by step. Sometimes it might well be possible to jump a few versions. But the upgrade from one version to the next is generally heavily tested. Whereas no one can really test all the permutations of moving from an arbitrary 2.x to 2.y. So the advice is:

(i) make sure you have a backup the database before you start. Thats the most important step.

(ii) also keep a copy of the existing deployed war file. This way you should always be able to get back to where you started.

(iii) test the whole process on something other than your production instance so you don’t inflict unnecessary down time on your users.

(iv) read the upgrade notes very carefully and apply any required sql scripts

(v) upgrade in step increments, remembering to clear the webapps folder before deploying a new war file

(vi) if you are using a reverse proxy (nginx or apache) be sure to clear any server side cache after upgrading

There is another reason to stay on the endless treadmill of keeping up to date, even though it can be a pain. The developer team have undertaken to provide security support and patches for the past 3 versions. In most cases we will backport security fixes further, but this is not always easy so we don’t guarantee it. So if you are sitting with a 3 year old war file then you will almost certainly be vulnerable to a number of attacks.

For the same reason, it is also important to regularly update the war file within the release version you have deployed (as distinct from upgrading from one version to another). This way you ensure you get the benefit of any fixes which might have been made and backported to your version.

Bob

···

On 8 August 2017 at 16:15, Knut Staring knutst@gmail.com wrote:

Dear Bayo,

Lars is the best to comment on this, but most (all?) releases make some changes to the database structure (mainly additions, but not exclusively). Therefore, it is usually necessary (and most prudent as a general rule) to do things step by step, which of course is a bit of a drag if you are lagging far behind. This is why we encourage everyone to be no more than 2 releases behind (which means 1 year old files). In addition, certain releases have SQL scripts that must be executed and should not be skipped.

Also note that it is a good idea check for new builds of your particular version (e.g. 2.25) as bugfixes are committed and backported on a regular basis. However, this is usually not the case for really old releases (e.g. 2.18).

Knut


Mailing list: https://launchpad.net/~dhis2-users

Post to : dhis2-users@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-users

More help : https://help.launchpad.net/ListHelp

On Tue, Aug 8, 2017 at 5:01 PM, Bayo Mohammed Onimode bayonimode@yahoo.co.uk wrote:

‎Knut,

Must the upgrade be step by step?

Does it mean that if the upgrade is not done step by step, you are likely to have issues?

If the answers to the above questions is YES, what then should be done to rectify it?

Thank you.

God Bless Nigeria,

Bayo Mohammed Onimode
ICT4D & MERL Professional
(FIIM, MBCS, MACM, MCPN, MNCS, MCPM, AMNIM)
Tel: +234.809.812.3465; +234.805.236.7163
Skype: Bayonimode

From: Knut Staring

Sent: Tuesday, 8 August 2017 11:04

To: channara rin

Cc: DHIS 2 Users list

Subject: Re: [Dhis2-users] After upgrade to v2.24 got error

Did you do the upgrade step by step (2.21, 2.22, 2.23) and running all scripts?

Knut


Knut Staring

Dept. of Informatics, University of Oslo

Norway: +4791880522

Skype: knutstar

http://dhis2.org

On Tue, Aug 8, 2017 at 10:22 AM, channara rin rin.channara@gmail.com wrote:

Hi all,
after i upgrade from 2.20 until 2.24.

i got this problem: it doesn’t show attribute label and value of attribute is not proper.

please help,

thanks,

chananra


Mailing list: https://launchpad.net/~dhis2-users

Post to : dhis2-users@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-users

More help : https://help.launchpad.net/ListHelp


Knut Staring

Dept. of Informatics, University of Oslo

Norway: +4791880522

Skype: knutstar

http://dhis2.org